aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-02-21 10:41:25 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-02-21 10:41:25 +0000
commit0e926939ff5dc3351b69d671193df8f5cc656f00 (patch)
tree569de199804f9a1bba024ba41c513f4edecda09a
parent5b09fe91a35985fdacde7ac24c846fd69a850f41 (diff)
downloadports-0e926939ff5dc3351b69d671193df8f5cc656f00.tar.gz
ports-0e926939ff5dc3351b69d671193df8f5cc656f00.zip
- Update to 2.1
Notes
Notes: svn path=/head/; revision=156572
-rw-r--r--archivers/rzip/Makefile2
-rw-r--r--archivers/rzip/distinfo6
-rw-r--r--archivers/rzip/files/patch-main.c15
3 files changed, 4 insertions, 19 deletions
diff --git a/archivers/rzip/Makefile b/archivers/rzip/Makefile
index 4a258300e3a6..bd684d06f4c3 100644
--- a/archivers/rzip/Makefile
+++ b/archivers/rzip/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= rzip
-PORTVERSION= 2.0
+PORTVERSION= 2.1
CATEGORIES= archivers
MASTER_SITES= http://rzip.samba.org/ftp/rzip/
diff --git a/archivers/rzip/distinfo b/archivers/rzip/distinfo
index 31e27174969c..3e566288412c 100644
--- a/archivers/rzip/distinfo
+++ b/archivers/rzip/distinfo
@@ -1,3 +1,3 @@
-MD5 (rzip-2.0.tar.gz) = 8a88b445afba919b122a3899d6d26b2a
-SHA256 (rzip-2.0.tar.gz) = 98b45538202d1bb69acac849bd5f39a30107c3b0483c3d9bdddf755c3923909a
-SIZE (rzip-2.0.tar.gz) = 42699
+MD5 (rzip-2.1.tar.gz) = 0a3ba55085661647c12f2b014c51c406
+SHA256 (rzip-2.1.tar.gz) = 4bb96f4d58ccf16749ed3f836957ce97dbcff3e3ee5fd50266229a48f89815b7
+SIZE (rzip-2.1.tar.gz) = 46785
diff --git a/archivers/rzip/files/patch-main.c b/archivers/rzip/files/patch-main.c
deleted file mode 100644
index ba89703ef58c..000000000000
--- a/archivers/rzip/files/patch-main.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- main.c.orig Thu Feb 12 01:01:08 2004
-+++ main.c Fri Apr 9 18:28:33 2004
-@@ -137,10 +137,8 @@
- strlen(control->infile) - strlen(control->suffix)) != 0) {
- fatal("%s: unknown suffix\n", control->infile);
- }
--
-- control->outfile = strndup(control->infile,
-- strlen(control->infile) -
-- strlen(control->suffix));
-+ control->outfile = malloc(strlen(control->infile) - strlen(control->suffix) + 1);
-+ strncpy(control->outfile, control->infile, strlen(control->infile) - strlen(control->suffix));
- }
-
- fd_in = open(control->infile,O_RDONLY);