aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-11-23 18:16:55 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-11-23 18:16:55 +0000
commit0ed1aea7c1dda1b52245389f0a0144b2341ee5eb (patch)
tree01edfa89d4eab0a884637e056974e9fcd91abd31
parent06992f6f6c0be2c4ced5b1024030258958c3924e (diff)
downloadports-0ed1aea7c1dda1b52245389f0a0144b2341ee5eb.tar.gz
ports-0ed1aea7c1dda1b52245389f0a0144b2341ee5eb.zip
Add patch to apply alignment attribute to a struct instead of a typedef.
This rounds the size of the struct to a multiple of the alignment such that malloc and friends allocate memory with the correct alignment. PR: 214784 MFH: 2016Q4
Notes
Notes: svn path=/head/; revision=426949
-rw-r--r--net/mpich/Makefile2
-rw-r--r--net/mpich/files/patch-src-include-mpiimpl.h11
2 files changed, 12 insertions, 1 deletions
diff --git a/net/mpich/Makefile b/net/mpich/Makefile
index b328bf70923b..5b9ce510468f 100644
--- a/net/mpich/Makefile
+++ b/net/mpich/Makefile
@@ -2,7 +2,7 @@
PORTNAME= mpich
PORTVERSION= 3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net parallel
MASTER_SITES= http://www.mpich.org/static/downloads/${DISTVERSION}/
diff --git a/net/mpich/files/patch-src-include-mpiimpl.h b/net/mpich/files/patch-src-include-mpiimpl.h
new file mode 100644
index 000000000000..47d416502f6f
--- /dev/null
+++ b/net/mpich/files/patch-src-include-mpiimpl.h
@@ -0,0 +1,11 @@
+--- src/include/mpiimpl.h.orig 2015-11-10 02:39:01 UTC
++++ src/include/mpiimpl.h
+@@ -1528,7 +1528,7 @@ typedef struct MPID_Request {
+ #ifdef MPID_DEV_REQUEST_DECL
+ MPID_DEV_REQUEST_DECL
+ #endif
+-} MPID_Request ATTRIBUTE((__aligned__(32)));
++} ATTRIBUTE((__aligned__(32))) MPID_Request;
+
+ extern MPIU_Object_alloc_t MPID_Request_mem;
+ /* Preallocated request objects */