aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-07-14 01:24:29 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-07-14 01:24:29 +0000
commit0efd6e6a411705013e0e7e41f22847aba4e32ce7 (patch)
treeb489121b23b93384074330a967c662a2cf2822f6
parent038e81ab5346f6b11831ae76cda937d7c41811cd (diff)
downloadports-0efd6e6a411705013e0e7e41f22847aba4e32ce7.tar.gz
ports-0efd6e6a411705013e0e7e41f22847aba4e32ce7.zip
science/libxc: Add NATIVE option
... to have no native optimizations by default. Otherwise libxc caused illegal instruction errors in science/sirius.
-rw-r--r--science/libxc/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/science/libxc/Makefile b/science/libxc/Makefile
index 97d3c876ff34..2207601fb62a 100644
--- a/science/libxc/Makefile
+++ b/science/libxc/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libxc
DISTVERSION= 6.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science
MASTER_SITES= https://www.tddft.org/programs/${PORTNAME}/down/${DISTVERSION}/
@@ -18,6 +18,10 @@ TEST_DEPENDS= bash:shells/bash
CMAKE_ON= BUILD_SHARED_LIBS ENABLE_FORTRAN ENABLE_PYTHON
CMAKE_OFF= BUILD_TESTING
+OPTIONS_DEFINE= NATIVE
+
+NATIVE_CMAKE_BOOL= ENABLE_XHOST
+
pre-configure:
${REINPLACE_CMD} -e 's|$${CMAKE_INSTALL_LIBDIR}/pylibxc$$|${PYTHONPREFIX_SITELIBDIR}/pylibxc|' \
-e 's|$${CMAKE_INSTALL_PREFIX}/$${CMAKE_INSTALL_LIBDIR}/pylibxc/|${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/pylibxc/|'\