aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2023-08-17 07:29:16 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2023-08-20 00:53:36 +0000
commit0f5dd65eb452b17d270948a231b13d92dfe0a242 (patch)
tree285a6d21a2fb8c4afc3ef3f7b810fa27d8128f3f
parentba4eb3a50e909d902a6e031e4c3477ed369799d2 (diff)
downloadports-0f5dd65eb452b17d270948a231b13d92dfe0a242.tar.gz
ports-0f5dd65eb452b17d270948a231b13d92dfe0a242.zip
Mk/Uses/tcl.mk: Add support of 'test' argument
Add support of 'test' argument that specifies test-time only dependency. PR: 273190 Approved by: gahr (tcltk, maintainer)
-rw-r--r--Mk/Uses/tcl.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/Mk/Uses/tcl.mk b/Mk/Uses/tcl.mk
index e9dc233fd889..d940b4a19409 100644
--- a/Mk/Uses/tcl.mk
+++ b/Mk/Uses/tcl.mk
@@ -25,7 +25,7 @@
#
# Usage:
#
-# USES+= PORT[:(VERSION|wrapper),build,run,tea]
+# USES+= PORT[:(VERSION|wrapper),build,run,tea,test]
#
# where PORT is one of:
#
@@ -49,7 +49,8 @@
# tk-wrapper is added. It is NOT possible to select a specific version of
# Tcl/Tk when using the wrapper.
#
-# Build-time / Run-time only dependencies can be specified with build or run.
+# Build-time / Run-time / Test-time only dependencies can be specified with
+# build, run or test.
#
# Tea can be used for Tcl/Tk extensions that use the Tcl Extension Architecture
# [http://www.tcl.tk/doc/tea] and allows to set common autoconf parameters.
@@ -209,6 +210,9 @@ BUILD_DEPENDS+= ${_TCLTK_WRAPPER_PORT} \
. elif ${tcl_ARGS:Mrun}
RUN_DEPENDS+= ${_TCLTK_WRAPPER_PORT} \
${_TCLTK_EXE_LINE}
+. elif ${tcl_ARGS:Mtest}
+TEST_DEPENDS+= ${_TCLTK_WRAPPER_PORT} \
+ ${_TCLTK_EXE_LINE}
. else
RUN_DEPENDS+= ${_TCLTK_WRAPPER_PORT}
LIB_DEPENDS+= ${_TCLTK_LIB_LINE}