aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-08-21 00:11:46 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-08-21 00:24:06 +0000
commit0f5efc593d2cd4a9a2bc7696f2e655eec33ae5b5 (patch)
tree93b020a132ebef34d54c6e6f4466dd5fcdaf613b
parent6ef4f846b662cf55e327d7c6b35321911f8d990e (diff)
downloadports-0f5efc593d2cd4a9a2bc7696f2e655eec33ae5b5.tar.gz
ports-0f5efc593d2cd4a9a2bc7696f2e655eec33ae5b5.zip
multimedia/kooha: verbose build per 30a00f2227a3 + 7bec7b192cda
CARGO_TERM_VERBOSE doesn't support "very verbose" required by 7bec7b192cda, so patch the wrapper instead.
-rw-r--r--multimedia/kooha/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/multimedia/kooha/Makefile b/multimedia/kooha/Makefile
index bb001d8934af..889041be87ee 100644
--- a/multimedia/kooha/Makefile
+++ b/multimedia/kooha/Makefile
@@ -214,4 +214,9 @@ CARGO_BUILD= no
CARGO_INSTALL= no
CARGO_TEST= no
+post-patch:
+# Make each cargo subcommand very verbose
+ @${REINPLACE_CMD} -e '/cargo/s/ --/&verbose&verbose&/' \
+ ${WRKSRC}/build-aux/cargo.sh
+
.include <bsd.port.mk>