aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-03-24 20:23:19 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-04-06 08:11:41 +0000
commit0f984aa02a5bae024559aa7b0f3949e447e13861 (patch)
tree0444586b23bfc8e5e6384fdd0ca49992274a1d63
parent6cc47c27a695f1f6a1582fa688e942a71bc8503e (diff)
downloadports-0f984aa02a5bae024559aa7b0f3949e447e13861.tar.gz
ports-0f984aa02a5bae024559aa7b0f3949e447e13861.zip
lang/intel-compute-runtime: update to 21.13.19438
-rw-r--r--lang/intel-compute-runtime/Makefile4
-rw-r--r--lang/intel-compute-runtime/distinfo10
-rw-r--r--lang/intel-compute-runtime/files/patch-no-perf4
3 files changed, 9 insertions, 9 deletions
diff --git a/lang/intel-compute-runtime/Makefile b/lang/intel-compute-runtime/Makefile
index 307cdca10333..7a20f25808e3 100644
--- a/lang/intel-compute-runtime/Makefile
+++ b/lang/intel-compute-runtime/Makefile
@@ -1,12 +1,12 @@
# $FreeBSD$
PORTNAME= compute-runtime
-DISTVERSION= 21.12.19358
+DISTVERSION= 21.13.19438
CATEGORIES= lang
PKGNAMEPREFIX= intel-
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES+= 2a423820aaa4.patch:-p1 # https://github.com/intel/compute-runtime/pull/361
+PATCHFILES+= 5fcfd6ac8032.patch:-p1 # https://github.com/intel/compute-runtime/pull/361
MAINTAINER= jbeich@FreeBSD.org
COMMENT= OpenCL implementation for Intel HD 5000 (Gen8) or newer
diff --git a/lang/intel-compute-runtime/distinfo b/lang/intel-compute-runtime/distinfo
index 464c0d35e2be..35f921209068 100644
--- a/lang/intel-compute-runtime/distinfo
+++ b/lang/intel-compute-runtime/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1616012863
-SHA256 (intel-compute-runtime-21.12.19358_GH0.tar.gz) = b711ed8b85ab3d04908666ede1d00a4bebeeffbfd9e68b84cdbd9887c641a476
-SIZE (intel-compute-runtime-21.12.19358_GH0.tar.gz) = 3822314
-SHA256 (2a423820aaa4.patch) = dd034e856e75d70bc6b63204aa2c67530a3212d111b67a703e4cbeb84e61685b
-SIZE (2a423820aaa4.patch) = 947
+TIMESTAMP = 1616617399
+SHA256 (intel-compute-runtime-21.13.19438_GH0.tar.gz) = b272e6bb2fcfdaaeb123a7604d3308b974457cdb289c10a088133d271fcea59c
+SIZE (intel-compute-runtime-21.13.19438_GH0.tar.gz) = 3830587
+SHA256 (5fcfd6ac8032.patch) = 128109db27ba55adab4b351d9f73531ffcb341e7c95063c9e5eed8b139ce42d3
+SIZE (5fcfd6ac8032.patch) = 957
diff --git a/lang/intel-compute-runtime/files/patch-no-perf b/lang/intel-compute-runtime/files/patch-no-perf
index fafdfa4bc9e2..94690df93378 100644
--- a/lang/intel-compute-runtime/files/patch-no-perf
+++ b/lang/intel-compute-runtime/files/patch-no-perf
@@ -6,14 +6,14 @@ level_zero/tools/source/sysman/linux/pmu/pmu_imp.h:12:10: fatal error: 'linux/pe
#include <linux/perf_event.h>
^~~~~~~~~~~~~~~~~~~~
---- level_zero/tools/source/sysman/engine/linux/os_engine_imp.cpp.orig 2020-09-11 07:53:58 UTC
+--- level_zero/tools/source/sysman/engine/linux/os_engine_imp.cpp.orig 2021-03-24 20:23:19 UTC
+++ level_zero/tools/source/sysman/engine/linux/os_engine_imp.cpp
@@ -49,9 +49,11 @@ ze_result_t LinuxEngineImp::getActivity(zes_engine_sta
return ZE_RESULT_ERROR_UNSUPPORTED_FEATURE;
}
uint64_t data[2] = {};
+#ifdef __linux__
- if (pPmuInterface->pmuReadSingle(static_cast<int>(fd), data, sizeof(data)) < 0) {
+ if (pPmuInterface->pmuRead(static_cast<int>(fd), data, sizeof(data)) < 0) {
return ZE_RESULT_ERROR_UNSUPPORTED_FEATURE;
}
+#endif