aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-04-28 21:15:03 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-04-29 00:56:57 +0000
commit10262df47cbedf56430c8a03f27991bb571ed5ac (patch)
tree462a6308699e28b1c8feffbe9feb1b91b3336912
parentd19055d61031d3e72093e07feadfe5de1d4c152f (diff)
downloadports-10262df47cbedf56430c8a03f27991bb571ed5ac.tar.gz
ports-10262df47cbedf56430c8a03f27991bb571ed5ac.zip
games/veloren-weekly: reduce memory usage during build
Suggested by: diizzy (cherry picked from commit ead75c8a3e872596c885687c1dd48ae41dba78f7)
-rw-r--r--games/veloren-weekly/files/patch-nodebug30
1 files changed, 30 insertions, 0 deletions
diff --git a/games/veloren-weekly/files/patch-nodebug b/games/veloren-weekly/files/patch-nodebug
new file mode 100644
index 000000000000..9fc648e5a459
--- /dev/null
+++ b/games/veloren-weekly/files/patch-nodebug
@@ -0,0 +1,30 @@
+Don't generate debuginfo as the binaries will be stripped
+
+--- Cargo.toml.orig 2023-04-25 17:26:27 UTC
++++ Cargo.toml
+@@ -79,25 +79,6 @@ panic = "abort" # don't need unwinding so we can skip
+ lto = true
+ debug = false
+ panic = "abort" # don't need unwinding so we can skip including the landing pads for that
+-# line tables so we can have useful backtraces for in-house crates
+-[profile.release.package."veloren-network"]
+-debug = 1
+-[profile.release.package."veloren-network-protocol"]
+-debug = 1
+-[profile.release.package."veloren-common"]
+-debug = 1
+-[profile.release.package."veloren-common-systems"]
+-debug = 1
+-[profile.release.package."veloren-client"]
+-debug = 1
+-[profile.release.package."veloren-server"]
+-debug = 1
+-[profile.release.package."veloren-server-cli"]
+-debug = 1
+-[profile.release.package."veloren-voxygen"]
+-debug = 1
+-[profile.release.package."veloren-world"]
+-debug = 1
+
+ # used for cargo bench
+ [profile.bench]