aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-12-21 18:54:30 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-12-21 18:54:30 +0000
commit10468b5b0b1abf10731f4a4e125f080281df7cb5 (patch)
tree44eedfca7789e16a5f887535fc04515e6947ff8d
parentb7eecbc66545607da8f0eed7cd2e478f633739c2 (diff)
downloadports-10468b5b0b1abf10731f4a4e125f080281df7cb5.tar.gz
ports-10468b5b0b1abf10731f4a4e125f080281df7cb5.zip
net/rubygem-grpc: Update to 1.42.0
-rw-r--r--net/rubygem-grpc/Makefile4
-rw-r--r--net/rubygem-grpc/distinfo6
-rw-r--r--net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb20
3 files changed, 15 insertions, 15 deletions
diff --git a/net/rubygem-grpc/Makefile b/net/rubygem-grpc/Makefile
index 30e3d2ee4309..7c6b4a2f5b3b 100644
--- a/net/rubygem-grpc/Makefile
+++ b/net/rubygem-grpc/Makefile
@@ -1,5 +1,5 @@
PORTNAME= grpc
-PORTVERSION= 1.41.1
+PORTVERSION= 1.42.0
CATEGORIES= net rubygems
MASTER_SITES= RG
@@ -11,7 +11,7 @@ LICENSE= BSD3CLAUSE
LIB_DEPENDS= libcares.so:dns/c-ares \
libgrpc.so:devel/grpc
RUN_DEPENDS= ca_root_nss>=0:security/ca_root_nss \
- rubygem-google-protobuf>=3.17<4:devel/rubygem-google-protobuf \
+ rubygem-google-protobuf>=3.18<4:devel/rubygem-google-protobuf \
rubygem-googleapis-common-protos-types>=1.0<2:devel/rubygem-googleapis-common-protos-types
USES= cpe gem gmake pkgconfig
diff --git a/net/rubygem-grpc/distinfo b/net/rubygem-grpc/distinfo
index 20fca444d1bd..919a0d07a8d0 100644
--- a/net/rubygem-grpc/distinfo
+++ b/net/rubygem-grpc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1637073148
-SHA256 (rubygem/grpc-1.41.1.gem) = a93c9977615acdb58a40d1078846ec3d28b3102a5972bcd4fd07fd8eb26159e9
-SIZE (rubygem/grpc-1.41.1.gem) = 4934144
+TIMESTAMP = 1638557258
+SHA256 (rubygem/grpc-1.42.0.gem) = b3d2649e67c6a636544996843d9ec191699c54c1aca797dbfea4dff36c14584a
+SIZE (rubygem/grpc-1.42.0.gem) = 4975104
diff --git a/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb b/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
index b2fa8d04a855..868b2f64b09a 100644
--- a/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
+++ b/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
@@ -1,8 +1,8 @@
---- src/ruby/ext/grpc/extconf.rb.orig 2021-04-24 13:33:17 UTC
+--- src/ruby/ext/grpc/extconf.rb.orig 2021-12-04 03:53:02 UTC
+++ src/ruby/ext/grpc/extconf.rb
-@@ -42,9 +42,9 @@ if RUBY_PLATFORM =~ /darwin/
+@@ -45,9 +45,9 @@ if darwin && !cross_compiling
ENV['ARFLAGS'] = '-o'
- end
+ end
-ENV['EMBED_OPENSSL'] = 'true'
-ENV['EMBED_ZLIB'] = 'true'
@@ -12,8 +12,8 @@
+ENV['EMBED_CARES'] = 'false'
ENV['ARCH_FLAGS'] = RbConfig::CONFIG['ARCH_FLAG']
- if RUBY_PLATFORM =~ /darwin/
-@@ -61,22 +61,23 @@ output_dir = File.expand_path(RbConfig::CONFIG['topdir
+ if darwin && !cross_compiling
+@@ -66,22 +66,23 @@ output_dir = File.expand_path(RbConfig::CONFIG['topdir
grpc_lib_dir = File.join(output_dir, 'libs', grpc_config)
ENV['BUILDDIR'] = output_dir
@@ -38,14 +38,14 @@
+#$CFLAGS << ' -I' + File.join(grpc_root, 'include')
ext_export_file = File.join(grpc_root, 'src', 'ruby', 'ext', 'grpc', 'ext-export')
--$LDFLAGS << ' -Wl,--version-script="' + ext_export_file + '.gcc"' if RUBY_PLATFORM =~ /linux/
--$LDFLAGS << ' -Wl,-exported_symbols_list,"' + ext_export_file + '.clang"' if RUBY_PLATFORM =~ /darwin/
-+#$LDFLAGS << ' -Wl,--version-script="' + ext_export_file + '.gcc"' if RUBY_PLATFORM =~ /linux/
-+#$LDFLAGS << ' -Wl,-exported_symbols_list,"' + ext_export_file + '.clang"' if RUBY_PLATFORM =~ /darwin/
-+$LDFLAGS << ' -lgrpc' unless windows
+-$LDFLAGS << ' -Wl,--version-script="' + ext_export_file + '.gcc"' if linux
+-$LDFLAGS << ' -Wl,-exported_symbols_list,"' + ext_export_file + '.clang"' if darwin
++#$LDFLAGS << ' -Wl,--version-script="' + ext_export_file + '.gcc"' if linux
++#$LDFLAGS << ' -Wl,-exported_symbols_list,"' + ext_export_file + '.clang"' if darwin
-$LDFLAGS << ' ' + File.join(grpc_lib_dir, 'libgrpc.a') unless windows
+#$LDFLAGS << ' ' + File.join(grpc_lib_dir, 'libgrpc.a') unless windows
++$LDFLAGS << ' -lgrpc' unless windows
if grpc_config == 'gcov'
$CFLAGS << ' -O0 -fprofile-arcs -ftest-coverage'
$LDFLAGS << ' -fprofile-arcs -ftest-coverage -rdynamic'