aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-02-05 15:17:17 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-02-05 15:47:41 +0000
commit10643b29365c90b777b76134df5ea3be3b92e8aa (patch)
tree3e145b747c7f456ca37dd801793d1cdbfea3962f
parentaadeaddc2f647972895edd9e006b6c2bf4d97aac (diff)
downloadports-10643b29365c90b777b76134df5ea3be3b92e8aa.tar.gz
ports-10643b29365c90b777b76134df5ea3be3b92e8aa.zip
archivers/unrar: Update to 6.20
-rw-r--r--archivers/unrar/Makefile6
-rw-r--r--archivers/unrar/distinfo6
-rw-r--r--archivers/unrar/files/patch-os.hpp4
-rw-r--r--archivers/unrar/files/patch-rijndael.cpp28
-rw-r--r--archivers/unrar/files/patch-rijndael.hpp4
5 files changed, 24 insertions, 24 deletions
diff --git a/archivers/unrar/Makefile b/archivers/unrar/Makefile
index 385c529b022c..90c66af5ee50 100644
--- a/archivers/unrar/Makefile
+++ b/archivers/unrar/Makefile
@@ -1,9 +1,9 @@
PORTNAME= unrar
-PORTVERSION= 6.12
+PORTVERSION= 6.20
PORTEPOCH= 6
CATEGORIES+= archivers
-MASTER_SITES= https://rarlab.com/rar/
-DISTNAME= unrarsrc-6.1.7
+MASTER_SITES= https://www.rarlab.com/rar/
+DISTNAME= unrarsrc-6.2.4
MAINTAINER?= sunpoet@FreeBSD.org
COMMENT= Extract, view & test RAR archives
diff --git a/archivers/unrar/distinfo b/archivers/unrar/distinfo
index f4a2ab97bce9..acf1337122e8 100644
--- a/archivers/unrar/distinfo
+++ b/archivers/unrar/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1655208208
-SHA256 (unrarsrc-6.1.7.tar.gz) = de75b6136958173fdfc530d38a0145b72342cf0d3842bf7bb120d336602d88ed
-SIZE (unrarsrc-6.1.7.tar.gz) = 236798
+TIMESTAMP = 1675190921
+SHA256 (unrarsrc-6.2.4.tar.gz) = 22e0a37444c6beb194d4dfafdce480d1143547eb1102fd65430e1e9522a545ad
+SIZE (unrarsrc-6.2.4.tar.gz) = 245672
diff --git a/archivers/unrar/files/patch-os.hpp b/archivers/unrar/files/patch-os.hpp
index c0a0c1604907..ef633fb42257 100644
--- a/archivers/unrar/files/patch-os.hpp
+++ b/archivers/unrar/files/patch-os.hpp
@@ -1,6 +1,6 @@
---- os.hpp.orig 2022-01-24 07:33:18 UTC
+--- os.hpp.orig 2023-01-17 16:25:54 UTC
+++ os.hpp
-@@ -168,6 +168,10 @@
+@@ -173,6 +173,10 @@
#include <locale.h>
diff --git a/archivers/unrar/files/patch-rijndael.cpp b/archivers/unrar/files/patch-rijndael.cpp
index 19749b3b7403..92b411d99b5c 100644
--- a/archivers/unrar/files/patch-rijndael.cpp
+++ b/archivers/unrar/files/patch-rijndael.cpp
@@ -1,4 +1,4 @@
---- rijndael.cpp.orig 2022-01-24 07:33:18 UTC
+--- rijndael.cpp.orig 2023-01-17 16:25:54 UTC
+++ rijndael.cpp
@@ -3,6 +3,8 @@
**************************************************************************/
@@ -56,18 +56,18 @@
+ EVP_CIPHER_CTX_set_padding(ctx, 0);
+#endif
+#else // OPENSSL_AES
- #ifdef USE_SSE
- // Check SSE here instead of constructor, so if object is a part of some
- // structure memset'ed before use, this variable is not lost.
-@@ -139,6 +169,7 @@ void Rijndael::Init(bool Encrypt,const byte *key,uint
+ // Check SIMD here instead of constructor, so if object is a part of some
+ // structure memset'ed before use, these variables are not lost.
+ #if defined(USE_SSE)
+@@ -141,6 +171,7 @@ void Rijndael::Init(bool Encrypt,const byte *key,uint
if(!Encrypt)
keyEncToDec();
+#endif // OPENSSL_AES
}
- void Rijndael::blockEncrypt(const byte *input,size_t inputLen,byte *outBuffer)
-@@ -146,6 +177,15 @@ void Rijndael::blockEncrypt(const byte *input,size_t i
+
+@@ -149,6 +180,15 @@ void Rijndael::blockEncrypt(const byte *input,size_t i
if (inputLen <= 0)
return;
@@ -81,9 +81,9 @@
+ return;
+#else // OPENSSL_AES
size_t numBlocks = inputLen/16;
- #ifdef USE_SSE
+ #if defined(USE_SSE)
if (AES_NI)
-@@ -204,6 +244,7 @@ void Rijndael::blockEncrypt(const byte *input,size_t i
+@@ -213,6 +253,7 @@ void Rijndael::blockEncrypt(const byte *input,size_t i
input += 16;
}
Copy128(m_initVector,prevBlock);
@@ -91,7 +91,7 @@
}
-@@ -245,6 +286,15 @@ void Rijndael::blockDecrypt(const byte *input, size_t
+@@ -288,6 +329,15 @@ void Rijndael::blockDecrypt(const byte *input, size_t
if (inputLen <= 0)
return;
@@ -105,9 +105,9 @@
+ return;
+#else // OPENSSL_AES
size_t numBlocks=inputLen/16;
- #ifdef USE_SSE
+ #if defined(USE_SSE)
if (AES_NI)
-@@ -307,6 +357,8 @@ void Rijndael::blockDecrypt(const byte *input, size_t
+@@ -356,6 +406,8 @@ void Rijndael::blockDecrypt(const byte *input, size_t
}
memcpy(m_initVector,iv,16);
@@ -116,7 +116,7 @@
}
-@@ -342,7 +394,7 @@ void Rijndael::blockDecryptSSE(const byte *input, size
+@@ -426,7 +478,7 @@ void Rijndael::blockDecryptNeon(const byte *input, siz
}
#endif
@@ -125,7 +125,7 @@
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////
// ALGORITHM
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////
-@@ -471,7 +523,7 @@ void Rijndael::GenerateTables()
+@@ -555,7 +607,7 @@ void Rijndael::GenerateTables()
U1[b][0]=U2[b][1]=U3[b][2]=U4[b][3]=T5[I][0]=T6[I][1]=T7[I][2]=T8[I][3]=gmul(b,0xe);
}
}
diff --git a/archivers/unrar/files/patch-rijndael.hpp b/archivers/unrar/files/patch-rijndael.hpp
index 3c375833ef8e..0e1ccbfbd379 100644
--- a/archivers/unrar/files/patch-rijndael.hpp
+++ b/archivers/unrar/files/patch-rijndael.hpp
@@ -1,4 +1,4 @@
---- rijndael.hpp.orig 2022-01-24 07:33:18 UTC
+--- rijndael.hpp.orig 2023-01-17 16:25:54 UTC
+++ rijndael.hpp
@@ -12,6 +12,13 @@
class Rijndael
@@ -14,7 +14,7 @@
#ifdef USE_SSE
void blockEncryptSSE(const byte *input,size_t numBlocks,byte *outBuffer);
void blockDecryptSSE(const byte *input, size_t numBlocks, byte *outBuffer);
-@@ -21,6 +28,7 @@ class Rijndael
+@@ -31,6 +38,7 @@ class Rijndael
void keySched(byte key[_MAX_KEY_COLUMNS][4]);
void keyEncToDec();
void GenerateTables();