aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-05-18 15:23:57 +0000
committerJason E. Hale <jhale@FreeBSD.org>2024-05-18 15:25:43 +0000
commit1111d2b95613b16e4cd0b1425e244de1f777d41f (patch)
tree89daa405d6fbd0159e8e228c3197c4d2b61ac2b9
parent164883f44fcb1a52473d26b2bf4216b76f296f02 (diff)
downloadports-1111d2b95613b16e4cd0b1425e244de1f777d41f.tar.gz
ports-1111d2b95613b16e4cd0b1425e244de1f777d41f.zip
sysutils/libcdio: Disable broken CDDB support
While here, pet portclippy(1) and portlint(1). PR: 278861
-rw-r--r--sysutils/libcdio/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/sysutils/libcdio/Makefile b/sysutils/libcdio/Makefile
index 12013520d9c0..3b9a662f6c98 100644
--- a/sysutils/libcdio/Makefile
+++ b/sysutils/libcdio/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libcdio
-PORTVERSION= 2.1.0
-PORTREVISION= 1
+DISTVERSION= 2.1.0
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= GNU
@@ -11,22 +11,24 @@ WWW= https://www.gnu.org/software/libcdio/
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libcddb.so:audio/libcddb
TEST_DEPENDS= genisoimage:sysutils/genisoimage
USES= compiler:c11 cpe gmake iconv libtool localbase \
ncurses pathfix perl5 pkgconfig tar:bzip2
-USE_PERL5= build
+CPE_VENDOR= gnu
USE_LDCONFIG= yes
+USE_PERL5= build
GNU_CONFIGURE= yes
-GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
-CONFIGURE_ARGS= ${ICONV_CONFIGURE_ARG}
-LIBS+= ${ICONV_LIB}
+CONFIGURE_ARGS= --disable-cddb \
+ --disable-vcd-info \
+ ${ICONV_CONFIGURE_ARG}
-INFO= libcdio
-CPE_VENDOR= gnu
INSTALL_TARGET= install-strip
TEST_TARGET= check
+LIBS+= ${ICONV_LIB}
+
+INFO= libcdio
+
.include <bsd.port.mk>