aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVidar Karlsen <vidar@karlsen.tech>2023-11-13 21:21:58 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-11-24 06:12:30 +0000
commit11a7b638a6c63425070e60ddcad9ebb27fad88c9 (patch)
tree075265917917606ac79b9617936ef2207d9cdf0b
parent51374276fb9d111a94aff980158732a8232d0337 (diff)
downloadports-11a7b638a6c63425070e60ddcad9ebb27fad88c9.tar.gz
ports-11a7b638a6c63425070e60ddcad9ebb27fad88c9.zip
dns/void-zones-tools: Fix build with WITH_PIE=YES
Patch CFLAGS from being overridden and remove -fno-pic to facilitate building with WITH_PIE=yes PR: 275039 Reported by: Marek Zarychta
-rw-r--r--dns/void-zones-tools/Makefile1
-rw-r--r--dns/void-zones-tools/files/patch-Makefile15
2 files changed, 13 insertions, 3 deletions
diff --git a/dns/void-zones-tools/Makefile b/dns/void-zones-tools/Makefile
index aa43a50a11b3..eec68d79df7e 100644
--- a/dns/void-zones-tools/Makefile
+++ b/dns/void-zones-tools/Makefile
@@ -2,6 +2,7 @@ PORTNAME= void-zones-tools
DISTVERSIONPREFIX= v
DISTVERSION= 1.0.2-18
DISTVERSIONSUFFIX= -g204634a
+PORTREVISION= 1
CATEGORIES= dns
MAINTAINER= vidar@karlsen.tech
diff --git a/dns/void-zones-tools/files/patch-Makefile b/dns/void-zones-tools/files/patch-Makefile
index eff508c7c245..7d0d77e5c7ca 100644
--- a/dns/void-zones-tools/files/patch-Makefile
+++ b/dns/void-zones-tools/files/patch-Makefile
@@ -1,13 +1,22 @@
--- Makefile.orig 2023-08-28 22:28:23 UTC
+++ Makefile
-@@ -26,9 +26,7 @@
+@@ -26,15 +26,13 @@
CC ?= clang
DV != $(CC) -dumpversion
-.if $(MACHINE) == "i386" || $(MACHINE) == "amd64" || $(MACHINE) == "x86_64"
-CFLAGS = $(CDEFS) -march=native -mssse3
-.elif $(MACHINE) == "arm"
+-CFLAGS = $(CDEFS) -fsigned-char
+.if $(MACHINE) == "arm"
- CFLAGS = $(CDEFS) -fsigned-char
++CFLAGS += $(CDEFS) -fsigned-char
.else
- CFLAGS = $(CDEFS)
+-CFLAGS = $(CDEFS)
++CFLAGS += $(CDEFS)
+ .endif
+
+-CFLAGS += -std=gnu11 -g0 -O3 -fno-pic -fvisibility=hidden -fstrict-aliasing -fno-common -fstack-protector -Wno-parentheses
++CFLAGS += -std=gnu11 -g0 -O3 -fvisibility=hidden -fstrict-aliasing -fno-common -fstack-protector -Wno-parentheses
+
+ # Clang only flags come here
+ .if $(DV) == "4.2.1"