aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-11 02:51:22 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-11 03:03:56 +0000
commit11bb9c7a8ffe63896275b64843362f2778307078 (patch)
tree83ea032fea89410893fbacd311528d9275c46c83
parent62cbc4c2937d93d6082811b6436294d551456e7a (diff)
downloadports-11bb9c7a8ffe63896275b64843362f2778307078.tar.gz
ports-11bb9c7a8ffe63896275b64843362f2778307078.zip
devel/py-setoptconf: Add py-setoptconf 0.3.0
setoptconf is a Python library that can be used to retrieve program settings from a variety of common sources: - Command Line - Environment Variables - INI Files - JSON Files - YAML Files - Python Objects/Modules The goal of this project is to define your desired settings in a simple and consistent way, and then point setoptconf at as many of the sources as you'd like to use, and let it comb them all, looking for your settings.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-setoptconf/Makefile23
-rw-r--r--devel/py-setoptconf/distinfo3
-rw-r--r--devel/py-setoptconf/pkg-descr12
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9100c98775fc..704c0199bc53 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5564,6 +5564,7 @@
SUBDIR += py-serializable
SUBDIR += py-serpent
SUBDIR += py-session-info
+ SUBDIR += py-setoptconf
SUBDIR += py-setproctitle
SUBDIR += py-setuptools
SUBDIR += py-setuptools-declarative-requirements
diff --git a/devel/py-setoptconf/Makefile b/devel/py-setoptconf/Makefile
new file mode 100644
index 000000000000..96994bbb513b
--- /dev/null
+++ b/devel/py-setoptconf/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= setoptconf
+PORTVERSION= 0.3.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Retrieve program settings from various sources in a consistant method
+WWW= https://github.com/jayclassless/setoptconf
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= YAML
+
+YAML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${PY_FLAVOR}
+
+.include <bsd.port.mk>
diff --git a/devel/py-setoptconf/distinfo b/devel/py-setoptconf/distinfo
new file mode 100644
index 000000000000..92104dd3bb45
--- /dev/null
+++ b/devel/py-setoptconf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1694348234
+SHA256 (setoptconf-0.3.0.tar.gz) = d2ecbd27c0c7d0d53990e2df98d9aad6490df8b75b71c621d8c441d6e91e3161
+SIZE (setoptconf-0.3.0.tar.gz) = 13725
diff --git a/devel/py-setoptconf/pkg-descr b/devel/py-setoptconf/pkg-descr
new file mode 100644
index 000000000000..4328c3ebb8ad
--- /dev/null
+++ b/devel/py-setoptconf/pkg-descr
@@ -0,0 +1,12 @@
+setoptconf is a Python library that can be used to retrieve program settings
+from a variety of common sources:
+- Command Line
+- Environment Variables
+- INI Files
+- JSON Files
+- YAML Files
+- Python Objects/Modules
+
+The goal of this project is to define your desired settings in a simple and
+consistent way, and then point setoptconf at as many of the sources as you'd
+like to use, and let it comb them all, looking for your settings.