aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2024-03-12 17:28:32 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2024-03-12 20:41:06 +0000
commit11bc1fbfd94400438926acaa1f8a99692a2cf1da (patch)
tree1048a6a9d2607dc0be13ec5ebe5f7c16066955e3
parentf8277a0b80987615fb79da3a30d5ee4c208e3787 (diff)
downloadports-11bc1fbfd94400438926acaa1f8a99692a2cf1da.tar.gz
ports-11bc1fbfd94400438926acaa1f8a99692a2cf1da.zip
astro/libosmpbf: update 1.5.0 → 1.5.1
-rw-r--r--astro/libosmpbf/Makefile11
-rw-r--r--astro/libosmpbf/distinfo6
-rw-r--r--astro/libosmpbf/files/patch-osmpbf_CMakeLists.txt18
-rw-r--r--astro/libosmpbf/files/patch-protobuf11
-rw-r--r--astro/libosmpbf/files/patch-tools_osmpbf-outline.cpp14
5 files changed, 25 insertions, 35 deletions
diff --git a/astro/libosmpbf/Makefile b/astro/libosmpbf/Makefile
index 9f44c474b3a5..d7fc8f4aa2c6 100644
--- a/astro/libosmpbf/Makefile
+++ b/astro/libosmpbf/Makefile
@@ -1,23 +1,20 @@
PORTNAME= libosmpbf
-PORTVERSION= 1.5.0
+PORTVERSION= 1.5.1
DISTVERSIONPREFIX= v
-PORTREVISION= 6
CATEGORIES= astro geography devel
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Library for handling binary OpenStreetMap data
-WWW= https://github.com/scrosby/OSM-binary
+WWW= https://github.com/openstreetmap/OSM-binary
LICENSE= LGPL3+
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libprotobuf.so:devel/protobuf
+USES= cmake compiler:c++17-lang
USE_GITHUB= yes
-GH_ACCOUNT= scrosby
+GH_ACCOUNT= openstreetmap
GH_PROJECT= OSM-binary
-USES= cmake compiler:c++17-lang
-USE_CXXSTD= c++17
-
.include <bsd.port.mk>
diff --git a/astro/libosmpbf/distinfo b/astro/libosmpbf/distinfo
index add620c80b51..b4a15943754c 100644
--- a/astro/libosmpbf/distinfo
+++ b/astro/libosmpbf/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1611339100
-SHA256 (scrosby-OSM-binary-v1.5.0_GH0.tar.gz) = 2abf3126729793732c3380763999cc365e51bffda369a008213879a3cd90476c
-SIZE (scrosby-OSM-binary-v1.5.0_GH0.tar.gz) = 47543
+TIMESTAMP = 1710262124
+SHA256 (openstreetmap-OSM-binary-v1.5.1_GH0.tar.gz) = 183ad76c5905c7abd35d938824320ffb82d9ca8987796018f2da8380b51cdac2
+SIZE (openstreetmap-OSM-binary-v1.5.1_GH0.tar.gz) = 47100
diff --git a/astro/libosmpbf/files/patch-osmpbf_CMakeLists.txt b/astro/libosmpbf/files/patch-osmpbf_CMakeLists.txt
new file mode 100644
index 000000000000..a752f13d9fe8
--- /dev/null
+++ b/astro/libosmpbf/files/patch-osmpbf_CMakeLists.txt
@@ -0,0 +1,18 @@
+--- osmpbf/CMakeLists.txt.orig 2024-03-11 08:26:22 UTC
++++ osmpbf/CMakeLists.txt
+@@ -1,13 +1,13 @@ add_library(osmpbf STATIC ${CPPS})
+ protobuf_generate_cpp(CPPS HS fileformat.proto osmformat.proto)
+
+ add_library(osmpbf STATIC ${CPPS})
+-target_compile_features(osmpbf PUBLIC cxx_std_11)
++target_compile_features(osmpbf PUBLIC cxx_std_17)
+ target_link_libraries(osmpbf PRIVATE protobuf::libprotobuf)
+ target_include_directories(osmpbf SYSTEM PUBLIC ${Protobuf_INCLUDE_DIRS})
+ install(TARGETS osmpbf ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
+
+ add_library(osmpbf_shared SHARED ${CPPS})
+-target_compile_features(osmpbf_shared PUBLIC cxx_std_11)
++target_compile_features(osmpbf_shared PUBLIC cxx_std_17)
+ target_link_libraries(osmpbf_shared PRIVATE protobuf::libprotobuf)
+ target_include_directories(osmpbf_shared SYSTEM PUBLIC ${Protobuf_INCLUDE_DIRS})
+ set_target_properties(osmpbf_shared PROPERTIES OUTPUT_NAME osmpbf
diff --git a/astro/libosmpbf/files/patch-protobuf b/astro/libosmpbf/files/patch-protobuf
deleted file mode 100644
index 499906ee3407..000000000000
--- a/astro/libosmpbf/files/patch-protobuf
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt.orig 2021-01-06 13:47:22 UTC
-+++ CMakeLists.txt
-@@ -4,7 +4,7 @@ project(osmpbf VERSION 1.5.0)
-
- include(GNUInstallDirs)
-
--set(CMAKE_CXX_STANDARD 11)
-+set(CMAKE_CXX_STANDARD 17)
-
- find_package(Protobuf REQUIRED)
-
diff --git a/astro/libosmpbf/files/patch-tools_osmpbf-outline.cpp b/astro/libosmpbf/files/patch-tools_osmpbf-outline.cpp
deleted file mode 100644
index e9af1e2226d6..000000000000
--- a/astro/libosmpbf/files/patch-tools_osmpbf-outline.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- tools/osmpbf-outline.cpp.orig 2021-01-06 13:47:22 UTC
-+++ tools/osmpbf-outline.cpp
-@@ -10,6 +10,11 @@
- // zlib compression is used inside the pbf blobs
- #include <zlib.h>
-
-+#ifndef WIN32
-+ // used for isatty
-+ #include <unistd.h>
-+#endif
-+
- // netinet or winsock2 provides the network-byte-order conversion function
- #ifdef D_HAVE_WINSOCK
- #include <winsock2.h>