aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2024-01-12 14:34:58 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2024-01-13 08:18:34 +0000
commit11e18f525a8390fda31c44838bde003e23176b95 (patch)
treecf7816596f03fc192828b6f90e8b9190d723638a
parent99c1ed39b70e5c82b3d8d0b01eac6e4ab8438693 (diff)
downloadports-11e18f525a8390fda31c44838bde003e23176b95.tar.gz
ports-11e18f525a8390fda31c44838bde003e23176b95.zip
lang/gcc13: Fix Address sanitizer
Software compiled with -fsanitize=address fails to run with the error message "ASan runtime does not come first in initial library list; you should either link runtime to your application or manually preload it with LD_PRELOAD". This commit fixes the issue by ignoring the [vdso] loaded shared library instead of linux-vdso.so. To successfully run the software compiled with -fsanitize=address it is still necessary to disable ASLR. PR: 267751 Reported by: yuri Co-authored-by: Andreas Tobler <andreast@gcc.gnu.org>
-rw-r--r--lang/gcc13/Makefile2
-rw-r--r--lang/gcc13/files/patch-libsanitizer_asan_asan__linux.cpp23
-rw-r--r--lang/gcc13/files/patch-libsanitizer_asan_asan__thread.cpp13
3 files changed, 37 insertions, 1 deletions
diff --git a/lang/gcc13/Makefile b/lang/gcc13/Makefile
index fb314ff3629e..11b37e3c46b8 100644
--- a/lang/gcc13/Makefile
+++ b/lang/gcc13/Makefile
@@ -1,6 +1,6 @@
PORTNAME= gcc
PORTVERSION= 13.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= GCC
PKGNAMESUFFIX= ${SUFFIX}
diff --git a/lang/gcc13/files/patch-libsanitizer_asan_asan__linux.cpp b/lang/gcc13/files/patch-libsanitizer_asan_asan__linux.cpp
new file mode 100644
index 000000000000..f6c16d8730ee
--- /dev/null
+++ b/lang/gcc13/files/patch-libsanitizer_asan_asan__linux.cpp
@@ -0,0 +1,23 @@
+Since the vDSO shared librares on Linux and FreeBSD are called
+differently, the initialization order check fails on FreeBSD.
+This patch fixes it by ignoring [vdso] instead of linux-vdso.so.
+
+GCC gets the original file from the LLVM Project, so this patch should
+probably be upstreamed directly to the LLVM Project rather than to GCC.
+
+
+--- libsanitizer/asan/asan_linux.cpp.orig 2022-11-23 11:22:41 UTC
++++ libsanitizer/asan/asan_linux.cpp
+@@ -148,6 +148,12 @@ static int FindFirstDSOCallback(struct dl_phdr_info *i
+ return 0;
+ # endif
+
++# if SANITIZER_FREEBSD
++ // Ignore vDSO
++ if (internal_strncmp(info->dlpi_name, "[vdso]", sizeof("[vdso]") - 1) == 0)
++ return 0;
++# endif
++
+ *name = info->dlpi_name;
+ return 1;
+ }
diff --git a/lang/gcc13/files/patch-libsanitizer_asan_asan__thread.cpp b/lang/gcc13/files/patch-libsanitizer_asan_asan__thread.cpp
new file mode 100644
index 000000000000..61c0ccf1cd89
--- /dev/null
+++ b/lang/gcc13/files/patch-libsanitizer_asan_asan__thread.cpp
@@ -0,0 +1,13 @@
+--- libsanitizer/asan/asan_thread.cpp.orig 2024-01-12 13:45:52 UTC
++++ libsanitizer/asan/asan_thread.cpp
+@@ -323,7 +323,9 @@ void AsanThread::ClearShadowForThreadStackAndTLS() {
+ if (tls_begin_ != tls_end_) {
+ uptr tls_begin_aligned = RoundDownTo(tls_begin_, ASAN_SHADOW_GRANULARITY);
+ uptr tls_end_aligned = RoundUpTo(tls_end_, ASAN_SHADOW_GRANULARITY);
+- FastPoisonShadow(tls_begin_aligned, tls_end_aligned - tls_begin_aligned, 0);
++ FastPoisonShadowPartialRightRedzone(tls_begin_aligned,
++ tls_end_ - tls_begin_aligned,
++ tls_end_aligned - tls_end_, 0);
+ }
+ }
+