aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2023-11-10 01:31:22 +0000
committerMatthias Andree <mandree@FreeBSD.org>2023-11-10 01:34:02 +0000
commit12264aff0819e4e49ab4690c70c01e64c9c496f8 (patch)
tree30a42e548ad51e4d4e6b6143b2055097555bea81
parentb4c952b5ddfd12f2e25acab198f22584f5264b06 (diff)
downloadports-12264aff0819e4e49ab4690c70c01e64c9c496f8.tar.gz
ports-12264aff0819e4e49ab4690c70c01e64c9c496f8.zip
mail/mailman: fix empty group/user name regression in 2.1.39_2
...and drop files/patch-configure-in, which is no longer needed; neither is autoreconf needed to be reinstated. We can cheat the test -z "$VAR" inside the MM_FIND_{GROUP,USER}... configure[.in] macros by putting the proper contents into the proper environment variables. To fix the regression in... PR: 274991 Reported by: leres@
-rw-r--r--mail/mailman/Makefile8
-rw-r--r--mail/mailman/files/patch-configure-in67
2 files changed, 7 insertions, 68 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index ecf88cdd7569..2da052f7a57c 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mailman
DISTVERSION= 2.1.39
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= GNU \
SF/${PORTNAME}/Mailman%202.1%20%28stable%29/${PORTVERSION} \
@@ -34,6 +34,12 @@ CONFIGURE_ARGS+=--with-python=${PYTHON_CMD} \
--with-permcheck=no \
--with-mailhost=localhost \
--with-urlhost=localhost
+# setting these defeats the automated check for users in configure[.in], as of 2.1.39,
+# implemented in MM_FIND_* macros:
+CONFIGURE_ENV+= CGI_GROUP=${CGI_GID} \
+ MAIL_GROUP=${MAIL_GID} \
+ MAILMAN_USER=${MM_USERNAME} \
+ MAILMAN_GROUP=${MM_GROUPNAME}
CONFLICTS= ja-mailman-2.1.* mailman*exim* mailman*postfix*
diff --git a/mail/mailman/files/patch-configure-in b/mail/mailman/files/patch-configure-in
deleted file mode 100644
index e17c6752e558..000000000000
--- a/mail/mailman/files/patch-configure-in
+++ /dev/null
@@ -1,67 +0,0 @@
-Mailman tests for existence of users during configure -- unfortunately
-this creates a problem; we create the users just before install.
-
-We remove the testing part.
-
---- configure.in.bak 2010-09-20 19:18:27.000000000 +0100
-+++ configure.in 2011-06-14 20:20:29.209438957 +0100
-@@ -311,28 +311,7 @@
- # $2 == user id to check for
- AC_SUBST($1)
- changequote(,)
--if test -z "$$1"
--then
-- cat > conftest.py <<EOF
--import grp
--gid = ''
--for group in "$2".split():
-- try:
-- try:
-- gname = grp.getgrgid(int(group))[0]
-- break
-- except ValueError:
-- gname = grp.getgrnam(group)[0]
-- break
-- except KeyError:
-- gname = ''
--fp = open("conftest.out", "w")
--fp.write("%s\n" % gname)
--fp.close()
--EOF
-- $PYTHON conftest.py
-- $1=`cat conftest.out`
--fi
-+$1=$2
- changequote([, ])
- rm -f conftest.out conftest.py])
-
-@@ -343,28 +322,7 @@
- # $2 == user id to check for
- AC_SUBST($1)
- changequote(,)
--if test -z "$$1"
--then
-- cat > conftest.py <<EOF
--import pwd
--uid = ''
--for user in "$2".split():
-- try:
-- try:
-- uname = pwd.getpwuid(int(user))[0]
-- break
-- except ValueError:
-- uname = pwd.getpwnam(user)[0]
-- break
-- except KeyError:
-- uname = ''
--fp = open("conftest.out", "w")
--fp.write("%s\n" % uname)
--fp.close()
--EOF
-- $PYTHON conftest.py
-- $1=`cat conftest.out`
--fi
-+$1=$2
- changequote([, ])
- rm -f conftest.out conftest.py])
-