aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2021-04-07 14:47:01 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2021-04-09 18:43:03 +0000
commit12ae9706d9b2bc40f303077f1b3c5801b94ea027 (patch)
tree65582983032d18cb1d4150d82d0c76098fda7667
parent39f0b40e04b44f9c4adee40147a3b105678894e3 (diff)
downloadports-12ae9706d9b2bc40f303077f1b3c5801b94ea027.tar.gz
ports-12ae9706d9b2bc40f303077f1b3c5801b94ea027.zip
Fix downloading of packages hosted on gitlab.
Gitlab changed the address beginning of April you can download packages from: curl https://gitlab.com/gitlab-org/gitlab-foss/repository/7efd19e3716ab6f9146052da76d1bd59ec815f2d/archive.tar.gz?dummy=/gitlab-org-gitlab-foss-7efd19e3716ab6f9146052da76d1bd59ec815f2d_GL0.tar.gz to: curl https://gitlab.com/gitlab-org/gitlab-foss/-/archive/7efd19e3716ab6f9146052da76d1bd59ec815f2d.tar.gz?dummy=/gitlab-org-gitlab-foss-7efd19e3716ab6f9146052da76d1bd59ec815f2d_GL0.tar.gz The new extracted archive will have a different folder name. Before it was: gitlab-foss-7efd19e3716ab6f9146052da76d1bd59ec815f2d-7efd19e3716ab6f9146052da76d1bd59ec815f2d now it is: gitlab-foss-7efd19e3716ab6f9146052da76d1bd59ec815f2d So all ports using gitlab must regen their distinfo. PR: 254866 MFH: 2021Q2 Differential Revision: https://reviews.freebsd.org/D29628
-rw-r--r--Mk/bsd.port.mk2
-rw-r--r--Mk/bsd.sites.mk6
2 files changed, 4 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 74a0954f9cc0..eaa588c56203 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1706,7 +1706,7 @@ WRKSRC?= ${WRKDIR}/${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}
.if defined(WRKSRC)
DEV_WARNING+= "You are using USE_GITLAB and WRKSRC is set which is wrong. Set GL_PROJECT, GL_ACCOUNT correctly, and/or set WRKSRC_SUBDIR and remove WRKSRC entirely."
.endif
-WRKSRC?= ${WRKDIR}/${GL_PROJECT}-${GL_COMMIT}-${GL_COMMIT}
+WRKSRC?= ${WRKDIR}/${GL_PROJECT}-${GL_COMMIT}
.endif
# If the distname is not extracting into a specific subdirectory, have the
diff --git a/Mk/bsd.sites.mk b/Mk/bsd.sites.mk
index 12415402847d..c205a378865a 100644
--- a/Mk/bsd.sites.mk
+++ b/Mk/bsd.sites.mk
@@ -547,7 +547,7 @@ GL_SUBDIR+= ${GL_TUPLE:C@^(([^:]*://[^:/]*(:[0-9]{1,5})?(/[^:]*[^/])?:)?)([^:]*)
. endif
. if empty(USE_GITLAB:Mnodefault)
-MASTER_SITES+= ${GL_SITE}/${GL_ACCOUNT}/${GL_PROJECT}/repository/${GL_COMMIT}/archive.tar.gz?dummy=/
+MASTER_SITES+= ${GL_SITE}/${GL_ACCOUNT}/${GL_PROJECT}/-/archive/${GL_COMMIT}.tar.gz?dummy=/
. endif
GL_SITE_DEFAULT= https://gitlab.com
GL_SITE?= ${GL_SITE_DEFAULT}
@@ -617,8 +617,8 @@ _GL_TUPLE_OUT:= ${_GL_TUPLE_OUT} ${GL_SITE_${_group}}:${GL_ACCOUNT_${_group}}:${
DISTNAME_${_group}:= ${GL_ACCOUNT_${_group}}-${GL_PROJECT_${_group}}-${GL_COMMIT_${_group}}_GL${_GITLAB_REV}
DISTFILE_${_group}:= ${DISTNAME_${_group}}${_GITLAB_EXTRACT_SUFX}
DISTFILES:= ${DISTFILES} ${DISTFILE_${_group}}:${_group}
-MASTER_SITES:= ${MASTER_SITES} ${GL_SITE_${_group}}/${GL_ACCOUNT_${_group}}/${GL_PROJECT_${_group}}/repository/${GL_COMMIT_${_group}}/archive.tar.gz?dummy=/:${_group}
-WRKSRC_${_group}:= ${WRKDIR}/${GL_PROJECT_${_group}}-${GL_COMMIT_${_group}}-${GL_COMMIT_${_group}}
+MASTER_SITES:= ${MASTER_SITES} ${GL_SITE_${_group}}/${GL_ACCOUNT_${_group}}/${GL_PROJECT_${_group}}/-/archive/${GL_COMMIT_${_group}}.tar.gz?dummy=/:${_group}
+WRKSRC_${_group}:= ${WRKDIR}/${GL_PROJECT_${_group}}-${GL_COMMIT_${_group}}
. if !empty(GL_SUBDIR_${_group})
_SITES_extract:= ${_SITES_extract} 690:post-extract-gl-${_group}
post-extract-gl-${_group}: