aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-01-07 07:50:39 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-01-07 07:50:39 +0000
commit12daf55f6b7bbe8c3522bebc291ce827994fb8bc (patch)
treed2f6e2d4e11daa61112c580645429fa1da87b220
parentbb3f74bc00cdd41b8b1cc93fa26f11db6a8b4582 (diff)
downloadports-12daf55f6b7bbe8c3522bebc291ce827994fb8bc.tar.gz
ports-12daf55f6b7bbe8c3522bebc291ce827994fb8bc.zip
- Deprecate as it depends on the expired x11-toolkits/gtkglarea [1]
While here: - Trim headers - Convert to OptionsNG Approved by: nivit (maintainer) [1]
Notes
Notes: svn path=/head/; revision=310026
-rw-r--r--graphics/py-visual/Makefile30
1 files changed, 15 insertions, 15 deletions
diff --git a/graphics/py-visual/Makefile b/graphics/py-visual/Makefile
index 1172bc6e84c7..9043e12606b7 100644
--- a/graphics/py-visual/Makefile
+++ b/graphics/py-visual/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: py-visual
-# Date created: 2005-07-13
-# Whom: Nicola Vitale <nivit@email.it>
-#
+# Created by: Nicola Vitale <nivit@email.it>
# $FreeBSD$
-#
PORTNAME= visual
PORTVERSION= 4.b26
@@ -16,6 +12,9 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/b/beta/}
MAINTAINER= nivit@FreeBSD.org
COMMENT= A python module that offers real 3D visual output
+DEPRECATED= Depends on the expired x11-toolkits/gtkglarea
+EXPIRATION_DATE= 2013-02-06
+
BUILD_DEPENDS= ${PYNUMPY} \
bjam:${PORTSDIR}/devel/boost-jam
LIB_DEPENDS= gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea \
@@ -29,28 +28,29 @@ USE_GMAKE= yes
USE_GNOME= gtk12
USE_PYTHON= 2.5+
-OPTIONS= EXAMPLES "install example files" on
+OPTIONS_DEFINE= DOCS EXAMPLES
OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-html-dir=${DOCSDIR} --disable-dependency-tracking
-.if defined(NOPORTDOCS)
-CONFIGURE_ARGS+= --disable-docs
-.endif
CONFIGURE_ENV= PYTHONPATH=${PYTHON_LIBDIR}
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTREAD_LIBS}
VPYTHON_SCRIPT= bin/vpython.in
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITH_EXAMPLES)
-CONFIGURE_ARGS+= --disable-examples
-PLIST_SUB+= PORTEXAMPLES="@comment "
-.else
+.if ! ${PORT_OPTIONS:MDOCS}
+CONFIGURE_ARGS+= --disable-docs
+.endif
+
+.if ${PORT_OPTIONS:MEXAMPLES}
CONFIGURE_ARGS+= --with-example-dir=${EXAMPLESDIR}
PLIST_SUB+= PORTEXAMPLES=""
+.else
+CONFIGURE_ARGS+= --disable-examples
+PLIST_SUB+= PORTEXAMPLES="@comment "
.endif
post-patch:
@@ -59,4 +59,4 @@ post-patch:
-e 's|%%PYTHON_VERSION%%|${PYTHON_VER}|g' \
${VPYTHON_SCRIPT}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>