aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-12 20:08:20 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-12 22:58:35 +0000
commit12e0c85984acfd5dce03de0026ca40c319b9ca27 (patch)
treee9124537623cd6797d841f7a39b1c0e3a501e752
parent03ddc450f67f0c111a6626012ff5390a9721555b (diff)
downloadports-12e0c85984acfd5dce03de0026ca40c319b9ca27.tar.gz
ports-12e0c85984acfd5dce03de0026ca40c319b9ca27.zip
net/isboot-kmod: Fix build with llvm15
Approved by: portmgr (blanket)
-rw-r--r--net/isboot-kmod/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/net/isboot-kmod/Makefile b/net/isboot-kmod/Makefile
index 3b6c940efb25..335560346a87 100644
--- a/net/isboot-kmod/Makefile
+++ b/net/isboot-kmod/Makefile
@@ -12,23 +12,32 @@ LICENSE= BSD2CLAUSE
ONLY_FOR_ARCHS= amd64 i386
USES= kmod uidfix
-
USE_GITHUB= yes
GH_ACCOUNT= jnielsendotnet
GH_PROJECT= isboot
SUB_FILES= pkg-message
+
WRKSRC_SUBDIR= src
+
PLIST_FILES= ${KMODDIR}/isboot.ko
PORTDOCS= README
OPTIONS_DEFINE= DEBUG DOCS VIMAGE
OPTIONS_DEFAULT=DOCS VIMAGE
+
DEBUG_DESC= Enable verbose boot logging
-DEBUG_CFLAGS= -DDEBUG -DMODDEBUG -DIBFT_VERBOSE
VIMAGE_DESC= Build for a kernel with 'options VIMAGE'
+
+DEBUG_CFLAGS= -DDEBUG -DMODDEBUG -DIBFT_VERBOSE
VIMAGE_CFLAGS= -DVIMAGE
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=unused-but-set-variable
+.endif
+
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/.. && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}