aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2024-01-05 18:48:28 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2024-01-05 21:04:09 +0000
commit12f9a46a7c999f20b74b05be9de1b56ebce16c44 (patch)
treea8eac1373d4d10807041de7a9d365a1eb4a1702a
parent3250ebd7afb568ba91b56de9dec722de6bd9e546 (diff)
downloadports-12f9a46a7c999f20b74b05be9de1b56ebce16c44.tar.gz
ports-12f9a46a7c999f20b74b05be9de1b56ebce16c44.zip
lang/gcc9: remove ELFv1 support
-rw-r--r--lang/gcc9/Makefile5
-rw-r--r--lang/gcc9/files/extra-patch-libgcc_config_rs6000_t-crtstuff8
2 files changed, 0 insertions, 13 deletions
diff --git a/lang/gcc9/Makefile b/lang/gcc9/Makefile
index 759b6e192af9..c842b6c1df18 100644
--- a/lang/gcc9/Makefile
+++ b/lang/gcc9/Makefile
@@ -65,12 +65,7 @@ CXXFLAGS:= ${CFLAGS:S/mcpu=g/mcpu=G/}
CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
.elif ${ARCH} == powerpc64
-. if defined(PPC_ABI) && ${PPC_ABI} == ELFv2
CONFIGURE_ARGS+= --with-abi=elfv2
-. else
-MAKE_ARGS+= CFLAGS_FOR_TARGET="-O0" CXXFLAGS_FOR_TARGET="-O0" BOOT_CFLAGS="-O0"
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-libgcc_config_rs6000_t-crtstuff
-. endif
.endif
LANGUAGES:= c,c++,objc,fortran
diff --git a/lang/gcc9/files/extra-patch-libgcc_config_rs6000_t-crtstuff b/lang/gcc9/files/extra-patch-libgcc_config_rs6000_t-crtstuff
deleted file mode 100644
index 5fec1e29830a..000000000000
--- a/lang/gcc9/files/extra-patch-libgcc_config_rs6000_t-crtstuff
+++ /dev/null
@@ -1,8 +0,0 @@
---- libgcc/config/rs6000/t-crtstuff.orig 2020-04-07 15:17:50 UTC
-+++ libgcc/config/rs6000/t-crtstuff
-@@ -3,4 +3,4 @@
- # Do not build crtend.o with -Os as that can result in references to
- # out-of-line register save/restore functions, which may be unresolved
- # as crtend.o is linked after libgcc.a. See PR45053.
--CRTSTUFF_T_CFLAGS = -msdata=none -O2 -fno-asynchronous-unwind-tables
-+CRTSTUFF_T_CFLAGS = -msdata=none -O0 -fno-asynchronous-unwind-tables