aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-03-09 12:02:41 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-03-09 12:02:41 +0000
commit1304072dc949be481d177bc162ce4c1f8b552274 (patch)
tree12e13b75f134105d4b2d62967c9b013171a5124b
parent9d386ce44c1170ccc81cd0c06ba3bda438d93724 (diff)
downloadports-1304072dc949be481d177bc162ce4c1f8b552274.tar.gz
ports-1304072dc949be481d177bc162ce4c1f8b552274.zip
Update to 0.14. I merged all the patches into the upstream. :)
Notes
Notes: svn path=/head/; revision=39300
-rw-r--r--irc/ruby-irc/Makefile14
-rw-r--r--irc/ruby-irc/distinfo2
-rw-r--r--irc/ruby-irc/files/patch-0:bot.rb11
-rw-r--r--irc/ruby-irc/files/patch-0:operator.rb11
-rw-r--r--irc/ruby-irc/files/patch-bot.rb5
-rw-r--r--irc/ruby-irc/files/patch-dice.cpi27
-rw-r--r--irc/ruby-irc/files/patch-init.cpi18
-rw-r--r--irc/ruby-irc/files/patch-omikuji.cpi36
-rw-r--r--irc/ruby-irc/files/patch-operator.cpi75
-rw-r--r--irc/ruby-irc/files/patch-syslog.cpi8
-rw-r--r--irc/ruby-irc/files/patch-userlog.cpi11
-rw-r--r--irc/ruby-irc/pkg-descr3
12 files changed, 9 insertions, 212 deletions
diff --git a/irc/ruby-irc/Makefile b/irc/ruby-irc/Makefile
index e8f55a37f7a3..c30a499cac32 100644
--- a/irc/ruby-irc/Makefile
+++ b/irc/ruby-irc/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= irc
-PORTVERSION= 0.13
+PORTVERSION= 0.14
CATEGORIES= irc ruby
-MASTER_SITES= http://www.ueda.info.waseda.ac.jp/~igarashi/ruby/
+MASTER_SITES= http://www.ruby-lang.org/~knu/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby
@@ -21,7 +21,7 @@ NO_BUILD= yes
DOCS_EN= BUGS ChangeLog MANIFEST \
NEWS README TODO
-DOCS_JA= MEMO.ja README.ja
+DOCS_JA= MEMO.ja README.ja doc.ja/*
do-install:
${INSTALL_DATA} ${WRKSRC}/localize.rb ${RUBY_SITELIBDIR}
@@ -35,14 +35,12 @@ do-install:
.for f in ${DOCS_JA}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/irc/ja/
.endfor
- ${INSTALL_DATA} ${WRKSRC}/doc/* ${RUBY_DOCDIR}/irc/ja/
${MKDIR} ${RUBY_EXAMPLESDIR}/irc/cpi
${MKDIR} ${RUBY_EXAMPLESDIR}/irc/ja/cpi
- cd ${WRKSRC}/cpi && \
- for f in *.cpi; do ${INSTALL_DATA} $${f} ${RUBY_EXAMPLESDIR}/irc/cpi/; done; \
- for f in *.cpi.orig; do ${INSTALL_DATA} $${f} ${RUBY_EXAMPLESDIR}/irc/ja/cpi/$${f%.orig}; done
+ ${INSTALL_DATA} ${WRKSRC}/cpi/*.cpi ${RUBY_EXAMPLESDIR}/irc/cpi/
+ ${INSTALL_DATA} ${WRKSRC}/cpi.ja/*.cpi ${RUBY_EXAMPLESDIR}/irc/ja/cpi/
${INSTALL_DATA} ${WRKSRC}/bot.rb ${RUBY_EXAMPLESDIR}/irc/
- ${INSTALL_DATA} ${WRKSRC}/bot.rb.orig ${RUBY_EXAMPLESDIR}/irc/ja/bot.rb
+ ${INSTALL_DATA} ${WRKSRC}/bot.ja.rb ${RUBY_EXAMPLESDIR}/irc/ja/bot.rb
${MKDIR} ${RUBY_EXAMPLESDIR}/irc/log
${MKDIR} ${RUBY_EXAMPLESDIR}/irc/ja/log
.endif
diff --git a/irc/ruby-irc/distinfo b/irc/ruby-irc/distinfo
index 74c92a4fbfda..d93462893577 100644
--- a/irc/ruby-irc/distinfo
+++ b/irc/ruby-irc/distinfo
@@ -1 +1 @@
-MD5 (ruby/ruby-irc-0.13.tar.gz) = 345c5cd815cd72dd09110f8faa1f8634
+MD5 (ruby/ruby-irc-0.14.tar.gz) = 4cd0bf4086e3b5b86901ccdd4022482d
diff --git a/irc/ruby-irc/files/patch-0:bot.rb b/irc/ruby-irc/files/patch-0:bot.rb
deleted file mode 100644
index b5a240426067..000000000000
--- a/irc/ruby-irc/files/patch-0:bot.rb
+++ /dev/null
@@ -1,11 +0,0 @@
---- bot.rb.orig Wed Jun 14 05:12:45 2000
-+++ bot.rb Fri Jan 19 17:17:42 2001
-@@ -30,7 +30,7 @@
- parseArgs(0, "server", "",
- "server:", "logfile:", "nick:", "operator:", "username:")
- Server = $OPT_server
--Operator = $OPT_operator || "Igapon"
-+Operator = $OPT_operator || "igapon!igarashi@mahon.ueda.info.waseda.ac.jp"
- Nick = $OPT_nick || "Bot"
- UserName = $OPT_username || "iga"
- AgentName = $OPT_agentname || "Rubyちゃん"
diff --git a/irc/ruby-irc/files/patch-0:operator.rb b/irc/ruby-irc/files/patch-0:operator.rb
deleted file mode 100644
index e1a8d6eb06d0..000000000000
--- a/irc/ruby-irc/files/patch-0:operator.rb
+++ /dev/null
@@ -1,11 +0,0 @@
---- cpi/operator.cpi.orig Wed Jun 14 10:03:51 2000
-+++ cpi/operator.cpi Fri Jan 19 17:15:50 2001
-@@ -15,7 +15,7 @@
- include IRC
- def start(client)
- super
-- @operator = User.parse("igapon!igarashi@mahon.ueda.info.waseda.ac.jp")
-+ @operator = User.parse(Operator)
- report("こんにちわ")
- end
- def stop
diff --git a/irc/ruby-irc/files/patch-bot.rb b/irc/ruby-irc/files/patch-bot.rb
deleted file mode 100644
index bb8bf687c77a..000000000000
--- a/irc/ruby-irc/files/patch-bot.rb
+++ /dev/null
@@ -1,5 +0,0 @@
---- bot.rb.orig Wed Jun 14 05:12:45 2000
-+++ bot.rb Fri Jan 19 16:53:24 2001
-@@ -36 +36 @@
--AgentName = $OPT_agentname || "Rubyちゃん"
-+AgentName = $OPT_agentname || "Ruby-chan"
diff --git a/irc/ruby-irc/files/patch-dice.cpi b/irc/ruby-irc/files/patch-dice.cpi
deleted file mode 100644
index 3723205d4e21..000000000000
--- a/irc/ruby-irc/files/patch-dice.cpi
+++ /dev/null
@@ -1,27 +0,0 @@
---- cpi/dice.cpi.orig Tue Jun 13 00:52:00 2000
-+++ cpi/dice.cpi Fri Jan 19 16:54:24 2001
-@@ -3 +3 @@
--#さいころ振りエージェント
-+# "Dice Thrower" agent
-@@ -11 +11 @@
--#このスクリプトは
-+#This script was translated from a perl script:
-@@ -15 +14,0 @@
--#を移植させて頂いたものです。
-@@ -17 +16 @@
--#"2d6"のような表現に反応し、さいころを振ってくれます。
-+#It responds to phrases like "2d6" and throws dice.
-@@ -20 +19 @@
--agent = IRC::PassiveAgent::new("さいころ振り")
-+agent = IRC::PassiveAgent::new("Dice Thrower")
-@@ -41,5 +40,5 @@
-- 'だいすのかずがへんですぅ',
-- 'そのだいすはもってないですぅ',
-- 'そんなにたくさんもってないですぅ〜',
-- 'だいすがつくえからおちたですぅ',
-- '0 ではわれないですぅ〜',
-+ 'The number of dice is invalid.',
-+ 'Sorry, I don\'t have such kind of dice.',
-+ 'Sorry, I don\'t have so many dice.',
-+ 'Oops, dice fell out of the table!',
-+ 'Divided by zero.',
diff --git a/irc/ruby-irc/files/patch-init.cpi b/irc/ruby-irc/files/patch-init.cpi
deleted file mode 100644
index db1c64757a8b..000000000000
--- a/irc/ruby-irc/files/patch-init.cpi
+++ /dev/null
@@ -1,18 +0,0 @@
---- cpi/init.cpi.orig Tue Jun 13 00:52:00 2000
-+++ cpi/init.cpi Fri Jan 19 16:20:28 2001
-@@ -3 +3 @@
--#初期化スクリプト
-+#Initialization
-@@ -12,2 +12,2 @@
--# ここではIRC::Clientクラスのメソッドが利用できます。
--# IRC::Client#startAgentを呼び出してプラグインエージェントを起動できます。
-+# You can invoke the methods of the class IRC::Client.
-+# Invoke IRC::Client#startAgent to run each plug-in agent.
-@@ -16 +16 @@
--# エージェントの起動
-+# Invocation of agents
-@@ -24,2 +24,2 @@
--# nilを返すことにより、1度きりの実行となる。
--# 登録されることはない。
-+# Returning nil means "run me just once"
-+# so as not to registered as a resident agent.
diff --git a/irc/ruby-irc/files/patch-omikuji.cpi b/irc/ruby-irc/files/patch-omikuji.cpi
deleted file mode 100644
index 8dc4c4d06ba4..000000000000
--- a/irc/ruby-irc/files/patch-omikuji.cpi
+++ /dev/null
@@ -1,36 +0,0 @@
---- cpi/omikuji.cpi.orig Tue Jun 13 00:52:00 2000
-+++ cpi/omikuji.cpi Fri Jan 19 17:07:00 2001
-@@ -3 +3 @@
--#おみくじエージェント
-+#Omikuji - Fortuneteller agent
-@@ -11 +11 @@
--agent = IRC::PassiveAgent::new("おみくじ")
-+gent = IRC::PassiveAgent::new("Fortuneteller")
-@@ -26 +26 @@
-- if message.trailing =~ /^(?:\s| )*おみくじ(?:\s| )*$/
-+ if message.trailing =~ /^(?:\s| )*(?:Fortune|Omikuji)(?:\s| )*$/
-@@ -38,2 +38,2 @@
--#from:String おみくじを引いた人
--#to:String 結果の送り先
-+#from:String - Consultee
-+#to:String - Recipient
-@@ -41,2 +41,2 @@
-- privmsg("おみくじ引きまぁす。", to)
-- privmsg("#{from}さんの運勢は……", to)
-+ privmsg("Consulting an oracle.", to)
-+ privmsg("Reading #{from}'s fortune...", to)
-@@ -48 +48 @@
-- "大吉でぇす!!"
-+ "Best Luck!!!"
-@@ -50 +50 @@
-- "中吉でぇす!"
-+ "Good Luck!!"
-@@ -52 +52 @@
-- "小吉でぇす!"
-+ "Not Much Luck!"
-@@ -54 +54 @@
-- "凶でぇす!"
-+ "Bad Luck!"
-@@ -56 +56 @@
-- "大凶でぇす!"
-+ "Worst Luck!!"
diff --git a/irc/ruby-irc/files/patch-operator.cpi b/irc/ruby-irc/files/patch-operator.cpi
deleted file mode 100644
index 72a32a9ca467..000000000000
--- a/irc/ruby-irc/files/patch-operator.cpi
+++ /dev/null
@@ -1,75 +0,0 @@
---- cpi/operator.cpi.orig Wed Jun 14 10:03:51 2000
-+++ cpi/operator.cpi Fri Jan 19 16:20:28 2001
-@@ -3,2 +3,2 @@
--#Operator命令処理エージェント
--# ぷりぶで来た!ではじまる命令に反応します。
-+#Command Executer
-+# This agent responds to privmsg's from the operator that start with "!" and execute the commands.
-@@ -12 +12 @@
--agent = IRC::PassiveAgent::new("Operator命令")
-+agent = IRC::PassiveAgent::new("CommandExecuter")
-@@ -19 +19 @@
-- report("こんにちわ")
-+ report("Hello, sir.")
-@@ -36 +36 @@
-- report("#{user}さんが「#{str}」だって。")
-+ report("#{user} commanded me \"#{str}\".")
-@@ -44 +44 @@
-- privmsg("!"+str, @operator.nick)
-+ privmsg("!"+str, @operator.nick)
-@@ -51 +51 @@
-- when /\A(?:quit|停止|ばいばい)\Z/
-+ when /\Aquit\Z/
-@@ -53 +53 @@
-- when /\A(?:reboot|再起動)\Z/
-+ when /\Areboot\Z/
-@@ -55 +55 @@
-- when /\A(?:エージェント|えーじぇんと|listAgent)\Z/
-+ when /\AlistAgent\Z/
-@@ -57 +57 @@
-- when /\A(?:restartAgent|えーじぇんとさいきどう|エージェント再起動)[\s ]+(\w+)\Z/
-+ when /\ArestartAgent[\s ]+(\w+)\Z/
-@@ -59 +59 @@
-- when /\A(?:channels|ちゃんねる|チャンネル)\Z/
-+ when /\Achannels\Z/
-@@ -61 +61 @@
-- when /\A(?:invite|おいで)[\s ]+(\S+)\Z/
-+ when /\Ainvite[\s ]+(\S+)\Z/
-@@ -64 +64 @@
-- report("ほえ?")
-+ report("Beg your pardon, sir?")
-@@ -71 +71 @@
-- report("ばいば〜い☆")
-+ report("I am leaving, sir!")
-@@ -83 +83 @@
-- # エージェント:一覧
-+ # List agents
-@@ -85 +85 @@
-- report("エージェント一覧:")
-+ report("List of agents:")
-@@ -91 +91 @@
-- report("(エージェント一覧ここまで)")
-+ report("(End of list)")
-@@ -94 +94 @@
-- # エージェント:再起動
-+ # Restart an agent
-@@ -98 +98 @@
-- report("エージェント[#{new_agent.nick}]を再起動しました。")
-+ report("Agent [#{new_agent.nick}] has been restarted.")
-@@ -102 +102 @@
-- # 自分の入っているチャンネル
-+ # List channels it's joining
-@@ -106 +106 @@
-- report("今入っているちゃんねるは")
-+ report("I am joining the channels: ")
-@@ -108 +107,0 @@
-- report("だよ。")
-@@ -110 +109 @@
-- report("今どのチャンネルにも入ってないよ")
-+ report("I am not joining any channels.")
-@@ -115 +114 @@
-- report(channel+"にいきます。")
-+ report("I'm coming to "+channel)
-@@ -117 +116 @@
-- privmsg("こんにちわ、おじゃましま〜す☆(試験運転中です)", channel)
-+ privmsg("Hello, excuse me to interrupting you. (I am in experimental service)", channel)
diff --git a/irc/ruby-irc/files/patch-syslog.cpi b/irc/ruby-irc/files/patch-syslog.cpi
deleted file mode 100644
index e06379535728..000000000000
--- a/irc/ruby-irc/files/patch-syslog.cpi
+++ /dev/null
@@ -1,8 +0,0 @@
---- cpi/syslog.cpi.orig Tue Jun 13 00:52:00 2000
-+++ cpi/syslog.cpi Fri Jan 19 16:20:28 2001
-@@ -13 +13 @@
--agent = IRC::PassiveAgent::new("syslog")
-+agent = IRC::PassiveAgent::new("Syslog")
-@@ -27 +27 @@
-- buf = log.timestamp.strftime("%m月%d日%H時%M分")
-+ buf = log.timestamp.strftime("%m/%d %H:%M")
diff --git a/irc/ruby-irc/files/patch-userlog.cpi b/irc/ruby-irc/files/patch-userlog.cpi
deleted file mode 100644
index 6ea4cd7b653d..000000000000
--- a/irc/ruby-irc/files/patch-userlog.cpi
+++ /dev/null
@@ -1,11 +0,0 @@
---- cpi/userlog.cpi.orig Tue Jun 13 00:52:00 2000
-+++ cpi/userlog.cpi Fri Jan 19 16:20:28 2001
-@@ -3 +3 @@
--# ユーザ定義のlogger
-+# User defined logger
-@@ -11 +11 @@
--agent = IRC::PassiveAgent::new("ログ取り")
-+agent = IRC::PassiveAgent::new("Logger")
-@@ -25 +25 @@
-- buf = log.timestamp.strftime("%m月%d日%H時%M分")
-+ buf = log.timestamp.strftime("%m/%d %H:%M")
diff --git a/irc/ruby-irc/pkg-descr b/irc/ruby-irc/pkg-descr
index eb96d72f7383..2c0ec81f0b3d 100644
--- a/irc/ruby-irc/pkg-descr
+++ b/irc/ruby-irc/pkg-descr
@@ -1,3 +1,4 @@
Ruby/IRC is an IRC client framework for Ruby.
-Author: Hiroshi IGARASHI <igarashi@ueda.info.waseda.ac.jp>
+Author: Hiroshi IGARASHI <igarashi@ueda.info.waseda.ac.jp>,
+ Akinori MUSHA <knu@ruby-lang.org>