aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-11-05 12:25:33 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-11-05 14:19:17 +0000
commit132aedc09212e789e1ea0dc8a74fc0e44fd4e979 (patch)
tree2183ba3cce7bd9e87bd68b86a3958761fd75b15e
parent769c0d29764169566ab59e85f5645062e7737967 (diff)
downloadports-132aedc09212e789e1ea0dc8a74fc0e44fd4e979.tar.gz
ports-132aedc09212e789e1ea0dc8a74fc0e44fd4e979.zip
security/py-securesystemslib: Update version 0.23.0=>0.25.0
-rw-r--r--security/py-securesystemslib/Makefile5
-rw-r--r--security/py-securesystemslib/distinfo6
-rw-r--r--security/py-securesystemslib/files/patch-tests_test__process.py40
3 files changed, 5 insertions, 46 deletions
diff --git a/security/py-securesystemslib/Makefile b/security/py-securesystemslib/Makefile
index ac40625dcb6e..1c8b7e1dbf94 100644
--- a/security/py-securesystemslib/Makefile
+++ b/security/py-securesystemslib/Makefile
@@ -1,5 +1,5 @@
PORTNAME= securesystemslib
-PORTVERSION= 0.23.0
+PORTVERSION= 0.25.0
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,8 +11,7 @@ WWW= https://github.com/secure-systems-lab/securesystemslib
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}colorama>=0.3.9:devel/py-colorama@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}cryptography>=3.3.2:security/py-cryptography@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=3.3.2:security/py-cryptography@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pynacl>1.2.0:security/py-pynacl@${PY_FLAVOR}
TEST_DEPENDS= ${LOCALBASE}/bin/gpg:security/gnupg
diff --git a/security/py-securesystemslib/distinfo b/security/py-securesystemslib/distinfo
index 597a86fbf3e1..1b1f380f942f 100644
--- a/security/py-securesystemslib/distinfo
+++ b/security/py-securesystemslib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1651931169
-SHA256 (securesystemslib-0.23.0.tar.gz) = 573e9c810f2a6afe9ac71a177f26b9d6a321c53574f561f5cef2ed511c3f1831
-SIZE (securesystemslib-0.23.0.tar.gz) = 174862
+TIMESTAMP = 1667649773
+SHA256 (securesystemslib-0.25.0.tar.gz) = 10d5a066e70cb87704c9bf2cef1ef6d8a06fab5ef7602dd59c26d06251317a11
+SIZE (securesystemslib-0.25.0.tar.gz) = 178770
diff --git a/security/py-securesystemslib/files/patch-tests_test__process.py b/security/py-securesystemslib/files/patch-tests_test__process.py
deleted file mode 100644
index 1801210ce421..000000000000
--- a/security/py-securesystemslib/files/patch-tests_test__process.py
+++ /dev/null
@@ -1,40 +0,0 @@
-https://github.com/secure-systems-lab/securesystemslib/pull/403
-
---- tests/test_process.py.orig 2022-02-10 09:48:17 UTC
-+++ tests/test_process.py
-@@ -39,7 +39,7 @@ class Test_Process(unittest.TestCase):
-
- stdin_file = open(path)
- cmd = \
-- "python -c \"import sys; assert(sys.stdin.read() == '{}')\""
-+ sys.executable + " -c \"import sys; assert(sys.stdin.read() == '{}')\""
-
- # input is used in favor of stdin
- securesystemslib.process.run(cmd.format("use input kwarg"),
-@@ -58,7 +58,7 @@ class Test_Process(unittest.TestCase):
- def test_run_duplicate_streams(self):
- """Test output as streams and as returned. """
- # Command that prints 'foo' to stdout and 'bar' to stderr.
-- cmd = ("python -c \""
-+ cmd = (sys.executable + " -c \""
- "import sys;"
- "sys.stdout.write('foo');"
- "sys.stderr.write('bar');\"")
-@@ -102,7 +102,7 @@ class Test_Process(unittest.TestCase):
-
- def test_run_cmd_arg_return_code(self):
- """Test command arg as string and list using return code. """
-- cmd_str = ("python -c \""
-+ cmd_str = (sys.executable + " -c \""
- "import sys;"
- "sys.exit(100)\"")
- cmd_list = shlex.split(cmd_str)
-@@ -118,7 +118,7 @@ class Test_Process(unittest.TestCase):
- def test_run_duplicate_streams_timeout(self):
- """Test raise TimeoutExpired. """
- with self.assertRaises(securesystemslib.process.subprocess.TimeoutExpired):
-- securesystemslib.process.run_duplicate_streams("python --version",
-+ securesystemslib.process.run_duplicate_streams(sys.executable + " --version",
- timeout=-1)
-
-