aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-22 03:17:14 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-22 03:17:14 +0000
commit13b3a5bbeb69bcdf48e688a4a6a164735cf5e285 (patch)
tree010e4dbdd7f95e2138e28c5e7fd8cc87afa4ba55
parent2e6190d03c47ff83a239f53dcdc82dd87b7ec045 (diff)
downloadports-13b3a5bbeb69bcdf48e688a4a6a164735cf5e285.tar.gz
ports-13b3a5bbeb69bcdf48e688a4a6a164735cf5e285.zip
security/rhonabwy: Update to 1.1.12
-rw-r--r--security/rhonabwy/Makefile10
-rw-r--r--security/rhonabwy/distinfo6
-rw-r--r--security/rhonabwy/files/patch-CMakeLists.txt26
-rw-r--r--security/rhonabwy/pkg-plist8
4 files changed, 31 insertions, 19 deletions
diff --git a/security/rhonabwy/Makefile b/security/rhonabwy/Makefile
index 3889a27c5580..8575a385536a 100644
--- a/security/rhonabwy/Makefile
+++ b/security/rhonabwy/Makefile
@@ -1,5 +1,5 @@
PORTNAME= rhonabwy
-PORTVERSION= 1.1.11
+PORTVERSION= 1.1.12
DISTVERSIONPREFIX= v
CATEGORIES= security
@@ -12,9 +12,9 @@ LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= jansson>=2.4:devel/jansson \
- orcania>=2.3.2:devel/orcania \
- ulfius>=2.7.13:www/ulfius \
- yder>=1.4.19:devel/yder
+ orcania>=2.3.3:devel/orcania \
+ ulfius>=2.7.14:www/ulfius \
+ yder>=1.4.20:devel/yder
LIB_DEPENDS= libcurl.so:ftp/curl \
libgmp.so:math/gmp \
libgnutls.so:security/gnutls \
@@ -26,7 +26,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
USES= cmake pathfix pkgconfig
-CMAKE_OFF= BUILD_RHONABWY_DOCUMENTATION BUILD_RHONABWY_TESTING BUILD_RPM DOWNLOAD_DEPENDENCIES
+CMAKE_OFF= BUILD_RHONABWY_DOCUMENTATION BUILD_RHONABWY_TESTING BUILD_RPM
CMAKE_ON= BUILD_RNBYC BUILD_STATIC INSTALL_HEADER SEARCH_ORCANIA_R SEARCH_YDER_R WITH_CURL WITH_ULFIUS
PLIST_SUB= PORTVERSION=${PORTVERSION}
diff --git a/security/rhonabwy/distinfo b/security/rhonabwy/distinfo
index 3dd3da607a9e..c6ed15dc47c2 100644
--- a/security/rhonabwy/distinfo
+++ b/security/rhonabwy/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1686496692
-SHA256 (babelouest-rhonabwy-v1.1.11_GH0.tar.gz) = 78021d176615a48477927eae9cad404760d345c70b62b86e5620eb9f80969d2e
-SIZE (babelouest-rhonabwy-v1.1.11_GH0.tar.gz) = 382916
+TIMESTAMP = 1695143235
+SHA256 (babelouest-rhonabwy-v1.1.12_GH0.tar.gz) = 99fddde30ff07d4da808d330ed494287373fec7f2fb6f60d2782619ecb5c88d5
+SIZE (babelouest-rhonabwy-v1.1.12_GH0.tar.gz) = 379199
diff --git a/security/rhonabwy/files/patch-CMakeLists.txt b/security/rhonabwy/files/patch-CMakeLists.txt
index d5037798ade4..8c0c339955dc 100644
--- a/security/rhonabwy/files/patch-CMakeLists.txt
+++ b/security/rhonabwy/files/patch-CMakeLists.txt
@@ -1,16 +1,20 @@
---- CMakeLists.txt.orig 2023-02-08 14:06:47 UTC
+--- CMakeLists.txt.orig 2023-09-16 21:43:59 UTC
+++ CMakeLists.txt
-@@ -167,11 +167,11 @@ endif ()
-
- add_library(rhonabwy SHARED ${LIB_SRC})
+@@ -179,7 +179,7 @@ target_include_directories(rhonabwy
+ PUBLIC "$<BUILD_INTERFACE:${INC_DIR}>"
+ PUBLIC "$<BUILD_INTERFACE:${PROJECT_BINARY_DIR}>"
+ PUBLIC "$<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}>")
+-target_link_libraries(rhonabwy PUBLIC ${RHONABWY_LIBS})
++target_link_libraries(rhonabwy PUBLIC ${RHONABWY_LIBS} -L${CMAKE_INSTALL_PREFIX}/lib -lgmp -lhogweed)
set_target_properties(rhonabwy PROPERTIES
-- COMPILE_OPTIONS "-Wextra;-Wconversion"
-+ COMPILE_OPTIONS "-Wextra;-Wconversion;-Wno-sign-conversion;-Wno-unknown-warning-option"
PUBLIC_HEADER "${INC_DIR}/rhonabwy.h;${PROJECT_BINARY_DIR}/rhonabwy-cfg.h"
VERSION "${LIBRARY_VERSION}"
- SOVERSION "${LIBRARY_SOVERSION}")
--target_link_libraries(rhonabwy ${LIBS})
-+target_link_libraries(rhonabwy ${LIBS} -L${CMAKE_INSTALL_PREFIX}/lib -lgmp)
+@@ -232,7 +232,7 @@ option(BUILD_RNBYC "Build rnbyc application." ON)
- set(SEARCH_ORCANIA OFF CACHE BOOL "Force to false") # Avoid to search and download orcania during yder search and download
- set(SEARCH_ORCANIA_U OFF CACHE BOOL "Force to false") # Avoid to search and download orcania during ulfius search and download
+ if (BUILD_RNBYC)
+ add_executable(rnbyc ${RNBYC_DIR}/rnbyc.c ${INC_DIR}/rhonabwy.h ${PROJECT_BINARY_DIR}/rhonabwy-cfg.h)
+- set_target_properties(rnbyc PROPERTIES SKIP_BUILD_RPATH TRUE COMPILE_OPTIONS "-Wextra;-Wconversion")
++ set_target_properties(rnbyc PROPERTIES SKIP_BUILD_RPATH TRUE COMPILE_OPTIONS "-Wextra;-Wconversion;-Wno-sign-conversion;-Wno-unknown-warning-option")
+ add_dependencies(rnbyc rhonabwy)
+ target_link_libraries(rnbyc rhonabwy ${RHONABWY_LIBS} Yder::Yder Orcania::Orcania)
+ install(TARGETS rnbyc RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
diff --git a/security/rhonabwy/pkg-plist b/security/rhonabwy/pkg-plist
index b32f616755a0..f673bf0d6b80 100644
--- a/security/rhonabwy/pkg-plist
+++ b/security/rhonabwy/pkg-plist
@@ -1,6 +1,14 @@
bin/rnbyc
include/rhonabwy-cfg.h
include/rhonabwy.h
+lib/cmake/Rhonabwy/FindGnuTLS.cmake
+lib/cmake/Rhonabwy/FindJansson.cmake
+lib/cmake/Rhonabwy/FindMHD.cmake
+lib/cmake/Rhonabwy/FindNettle.cmake
+lib/cmake/Rhonabwy/RhonabwyConfig.cmake
+lib/cmake/Rhonabwy/RhonabwyConfigVersion.cmake
+lib/cmake/Rhonabwy/RhonabwyTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Rhonabwy/RhonabwyTargets.cmake
lib/librhonabwy.a
lib/librhonabwy.so
lib/librhonabwy.so.1.1