aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 16:11:01 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 16:11:01 +0000
commit140b0020bc6c2976175a95b8d2c3291ebdb32f16 (patch)
tree90ceefd89f63cfddda3fac229a239350aaf3669a
parentcc7172dc8eef540a800c338d107e2c62bb6d2d44 (diff)
downloadports-140b0020bc6c2976175a95b8d2c3291ebdb32f16.tar.gz
ports-140b0020bc6c2976175a95b8d2c3291ebdb32f16.zip
net/Sockets: Fix build with llvm16
- Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--net/Sockets/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/net/Sockets/Makefile b/net/Sockets/Makefile
index 464b659d4a72..6799ae96bc3b 100644
--- a/net/Sockets/Makefile
+++ b/net/Sockets/Makefile
@@ -9,15 +9,17 @@ MAINTAINER= ml@netfence.it
COMMENT= C++ wrapper for BSD-style sockets
WWW= http://www.alhem.net/Sockets/
-USES+= gmake gnome ssl
+USES= gmake gnome ssl
+USE_CXXSTD= c++14
USE_GNOME= libxml2
USE_LDCONFIG= yes
-CFLAGS+= -I${OPENSSLINC}
-LDFLAGS+= -L${OPENSSLLIB}
ALL_TARGET= all shared
INSTALL_TARGET= install_shared
+CFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
+
post-patch:
# PREFIX safeness
@${CP} ${PATCHDIR}/Makefile.Defines.freebsd ${WRKSRC}