aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2023-12-18 21:23:19 +0000
committerThierry Thomas <thierry@FreeBSD.org>2023-12-18 21:26:58 +0000
commit141ef0c641119a06a15c13e4ebcece7c9e857f92 (patch)
treee1ba78e873efb71edba3869c915d1fd12415ffa7
parent9adb7c18c4707e89084824854d4e8cce3157df6e (diff)
downloadports-141ef0c641119a06a15c13e4ebcece7c9e857f92.tar.gz
ports-141ef0c641119a06a15c13e4ebcece7c9e857f92.zip
net/mpich: fix with Slurm-23.11.1
-rw-r--r--net/mpich/Makefile1
-rw-r--r--net/mpich/files/patch-src_pm_hydra_lib_tools_bootstrap_external_slurm__query__node__list.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/net/mpich/Makefile b/net/mpich/Makefile
index 3d9686bd29f0..115f15a2d9fc 100644
--- a/net/mpich/Makefile
+++ b/net/mpich/Makefile
@@ -1,5 +1,6 @@
PORTNAME= mpich
PORTVERSION= 4.1.2
+PORTREVISION= 1
CATEGORIES= net parallel
MASTER_SITES= https://www.mpich.org/static/downloads/${DISTVERSION}/
diff --git a/net/mpich/files/patch-src_pm_hydra_lib_tools_bootstrap_external_slurm__query__node__list.c b/net/mpich/files/patch-src_pm_hydra_lib_tools_bootstrap_external_slurm__query__node__list.c
new file mode 100644
index 000000000000..920a91348c9a
--- /dev/null
+++ b/net/mpich/files/patch-src_pm_hydra_lib_tools_bootstrap_external_slurm__query__node__list.c
@@ -0,0 +1,11 @@
+--- src/pm/hydra/lib/tools/bootstrap/external/slurm_query_node_list.c.orig 2023-06-06 14:38:37 UTC
++++ src/pm/hydra/lib/tools/bootstrap/external/slurm_query_node_list.c
+@@ -26,7 +26,7 @@ static HYD_status list_to_nodes(char *str)
+ #if defined(HAVE_SLURM)
+ static HYD_status list_to_nodes(char *str)
+ {
+- hostlist_t hostlist;
++ hostlist_t *hostlist;
+ char *host;
+ int k = 0;
+ HYD_status status = HYD_SUCCESS;