aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2024-02-16 04:39:45 +0000
committerNeel Chauhan <nc@FreeBSD.org>2024-02-16 04:43:26 +0000
commit1441e2e7ec527c4b919ddf9c3bd204e94503869d (patch)
treea70bae904f7a059c92d266177de06b10824046a2
parent67f7186fb65a06c92a0ab2eb899e3a6128973e64 (diff)
downloadports-1441e2e7ec527c4b919ddf9c3bd204e94503869d.tar.gz
ports-1441e2e7ec527c4b919ddf9c3bd204e94503869d.zip
games/SpaceCadetPinball: Update to 2.1.0
-rw-r--r--games/SpaceCadetPinball/Makefile5
-rw-r--r--games/SpaceCadetPinball/distinfo6
-rw-r--r--games/SpaceCadetPinball/files/patch-CMakeLists.txt17
-rw-r--r--games/SpaceCadetPinball/files/patch-SpaceCadetPinball_pch.h16
-rw-r--r--games/SpaceCadetPinball/pkg-plist8
5 files changed, 15 insertions, 37 deletions
diff --git a/games/SpaceCadetPinball/Makefile b/games/SpaceCadetPinball/Makefile
index 2c9ff952d0ac..8d3cdc57a4de 100644
--- a/games/SpaceCadetPinball/Makefile
+++ b/games/SpaceCadetPinball/Makefile
@@ -1,6 +1,5 @@
PORTNAME= SpaceCadetPinball
-PORTVERSION= 2.0.1
-PORTREVISION= 2
+PORTVERSION= 2.1.0
DISTVERSIONPREFIX= Release_
CATEGORIES= games
@@ -19,6 +18,4 @@ GH_PROJECT= SpaceCadetPinball
USE_SDL= mixer2 sdl2
USE_XORG= ice sm x11 xext
-PLIST_FILES= bin/SpaceCadetPinball
-
.include <bsd.port.mk>
diff --git a/games/SpaceCadetPinball/distinfo b/games/SpaceCadetPinball/distinfo
index ae8fd7bccbf0..bfc82eb60f7d 100644
--- a/games/SpaceCadetPinball/distinfo
+++ b/games/SpaceCadetPinball/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1641229815
-SHA256 (k4zmu2a-SpaceCadetPinball-Release_2.0.1_GH0.tar.gz) = 7b71815339c86a428d3569a5235c6ece0e2d4ff1d8025984ede6f772ca4f5423
-SIZE (k4zmu2a-SpaceCadetPinball-Release_2.0.1_GH0.tar.gz) = 1882629
+TIMESTAMP = 1708058258
+SHA256 (k4zmu2a-SpaceCadetPinball-Release_2.1.0_GH0.tar.gz) = b647dc59abad3d52378b9f67ff4fb70a37e9752afaff1d098b71028cad29b8d6
+SIZE (k4zmu2a-SpaceCadetPinball-Release_2.1.0_GH0.tar.gz) = 3219590
diff --git a/games/SpaceCadetPinball/files/patch-CMakeLists.txt b/games/SpaceCadetPinball/files/patch-CMakeLists.txt
index f958334acbad..4312d114b9d2 100644
--- a/games/SpaceCadetPinball/files/patch-CMakeLists.txt
+++ b/games/SpaceCadetPinball/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2021-12-29 06:46:09 UTC
+--- CMakeLists.txt.orig 2023-10-16 06:14:43 UTC
+++ CMakeLists.txt
-@@ -23,9 +23,10 @@ endif()
+@@ -32,9 +32,10 @@ find_package(SDL2 REQUIRED)
set(SDL2_BUILDING_LIBRARY ON)
find_package(SDL2 REQUIRED)
@@ -12,7 +12,7 @@
get_property(dirs DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR} PROPERTY INCLUDE_DIRECTORIES)
foreach(dir ${dirs})
message(STATUS "Include dir='${dir}'")
-@@ -199,7 +200,7 @@ if(${CMAKE_VERSION} VERSION_GREATER "3.16.0" OR ${CMAK
+@@ -215,7 +216,7 @@ endif()
)
endif()
@@ -21,14 +21,3 @@
# On Windows, copy DLL to output
if(WIN32)
-@@ -221,8 +222,8 @@ endif()
- if(UNIX AND NOT APPLE)
- include(GNUInstallDirs)
- install(TARGETS "${PROJECT_NAME}" RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}")
-- install(FILES "/Platform/Linux/${PROJECT_NAME}.desktop" DESTINATION "share/applications")
-- install(FILES "/Platform/Linux/${PROJECT_NAME}.metainfo.xml" DESTINATION "share/metainfo")
-+ install(FILES "Platform/Linux/${PROJECT_NAME}.desktop" DESTINATION "share/applications")
-+ install(FILES "Platform/Linux/${PROJECT_NAME}.metainfo.xml" DESTINATION "share/metainfo")
- foreach(S 16 32 48 128 192)
- install(FILES "${PROJECT_NAME}/Icon_${S}x${S}.png" DESTINATION
- "share/icons/hicolor/${S}x${S}/apps" RENAME "${PROJECT_NAME}.png")
diff --git a/games/SpaceCadetPinball/files/patch-SpaceCadetPinball_pch.h b/games/SpaceCadetPinball/files/patch-SpaceCadetPinball_pch.h
deleted file mode 100644
index 13976847fe4e..000000000000
--- a/games/SpaceCadetPinball/files/patch-SpaceCadetPinball_pch.h
+++ /dev/null
@@ -1,16 +0,0 @@
-Fix SDL_Mixer version detection broken after SDL_mixer 2.6.1.
-This is already fixed in SpaceCadetPinball master after 2.0.1.
---- SpaceCadetPinball/pch.h.orig 2021-12-29 06:46:09 UTC
-+++ SpaceCadetPinball/pch.h
-@@ -37,11 +37,7 @@
-
- // MIX_INIT_FLUIDSYNTH was renamed to MIX_INIT_MID in SDL_mixer v2.0.2
- constexpr int MIX_INIT_MID_Proxy =
--#if SDL_MIXER_PATCHLEVEL >= 2
- MIX_INIT_MID;
--#else
-- MIX_INIT_FLUIDSYNTH;
--#endif
-
- //https://github.com/ocornut/imgui 7b913db1ce9dd2fd98e5790aa59974dd4496be3b
- #include "imgui.h"
diff --git a/games/SpaceCadetPinball/pkg-plist b/games/SpaceCadetPinball/pkg-plist
new file mode 100644
index 000000000000..476fbc681c77
--- /dev/null
+++ b/games/SpaceCadetPinball/pkg-plist
@@ -0,0 +1,8 @@
+bin/SpaceCadetPinball
+share/applications/SpaceCadetPinball.desktop
+share/icons/hicolor/128x128/apps/SpaceCadetPinball.png
+share/icons/hicolor/16x16/apps/SpaceCadetPinball.png
+share/icons/hicolor/192x192/apps/SpaceCadetPinball.png
+share/icons/hicolor/32x32/apps/SpaceCadetPinball.png
+share/icons/hicolor/48x48/apps/SpaceCadetPinball.png
+share/metainfo/SpaceCadetPinball.metainfo.xml