aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-02-13 18:10:12 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-02-13 19:13:04 +0000
commit146bb4da8d31a34f013b593b85f47796cd06158d (patch)
treeb5e3a9eaa296c98a597cafb6f9eae175ff262c02
parente592c6f47ac4e632606ce4f190ab0e60e792c258 (diff)
downloadports-146bb4da8d31a34f013b593b85f47796cd06158d.tar.gz
ports-146bb4da8d31a34f013b593b85f47796cd06158d.zip
x11-toolkits/wlroots: limit hwdata dependency to DRM as build only
pnp.ids is converted to pnpids.c, so won't pick up changes without rebuild. pnp.ids is also unused when nesting on X11 or Wayland (WLR_BACKENDS != drm). https://gitlab.freedesktop.org/wlroots/wlroots/-/commit/eec95e3d5e1a
-rw-r--r--x11-toolkits/wlroots/Makefile6
-rw-r--r--x11-wm/gamescope/Makefile1
2 files changed, 4 insertions, 3 deletions
diff --git a/x11-toolkits/wlroots/Makefile b/x11-toolkits/wlroots/Makefile
index 1a818713af4f..5d0313843037 100644
--- a/x11-toolkits/wlroots/Makefile
+++ b/x11-toolkits/wlroots/Makefile
@@ -1,6 +1,7 @@
PORTNAME= wlroots
DISTVERSION= 0.16.2
DISTVERSIONSUFFIX= -g${GL_COMMIT:C/(.{12}).*/\1/}
+PORTREVISION= 1
CATEGORIES= x11-toolkits
PATCH_SITES+= https://github.com/swaywm/${GL_PROJECT}/commit/:github
@@ -16,14 +17,12 @@ WWW= https://gitlab.freedesktop.org/wlroots/wlroots
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= wayland-protocols>=1.27:graphics/wayland-protocols \
- hwdata>0:misc/hwdata
+BUILD_DEPENDS= wayland-protocols>=1.27:graphics/wayland-protocols
LIB_DEPENDS= libudev.so:devel/libudev-devd \
libdrm.so:graphics/libdrm \
libwayland-server.so:graphics/wayland \
libseat.so:sysutils/seatd \
libxkbcommon.so:x11/libxkbcommon
-RUN_DEPENDS= hwdata>0:misc/hwdata
USES= compiler:c11 gl meson pkgconfig xorg
USE_GITLAB= yes
@@ -39,6 +38,7 @@ OPTIONS_DEFAULT=DRM OPENGL VULKAN X11
OPTIONS_SUB= yes
DRM_DESC= KMS console support
+DRM_BUILD_DEPENDS= hwdata>0:misc/hwdata
DRM_LIB_DEPENDS= libinput.so:x11/libinput
DRM_VARS= BACKENDS+="drm libinput"
diff --git a/x11-wm/gamescope/Makefile b/x11-wm/gamescope/Makefile
index b81a85e23bb6..54067811d230 100644
--- a/x11-wm/gamescope/Makefile
+++ b/x11-wm/gamescope/Makefile
@@ -19,6 +19,7 @@ BUILD_DEPENDS= glslangValidator:graphics/glslang \
libliftoff>=0.3.0<0.4.0:graphics/libliftoff \
vulkan-headers>0:graphics/vulkan-headers \
wayland-protocols>=1.17:graphics/wayland-protocols \
+ hwdata>0:misc/hwdata \
wlroots>=0.16.0<0.17.0:x11-toolkits/wlroots
LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
libdrm.so:graphics/libdrm \