aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-01-18 18:17:45 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-01-18 18:29:10 +0000
commit147a6723542d29626979348f2814a58ae276391b (patch)
treed738db8aea02059abe76cd4c9c807f2161df6efe
parentfcb6fddd5d098e0a155b469c9101cf41142c7796 (diff)
downloadports-147a6723542d29626979348f2814a58ae276391b.tar.gz
ports-147a6723542d29626979348f2814a58ae276391b.zip
lang/php82: Update version 8.2.14=>8.2.15
-rw-r--r--lang/php82/Makefile3
-rw-r--r--lang/php82/distinfo6
-rw-r--r--lang/php82/files/patch-configure.ac4
-rw-r--r--lang/php82/files/patch-ext_standard_filestat.c26
-rw-r--r--lang/php82/files/patch-main_fopen__wrappers.c14
-rw-r--r--lang/php82/files/patch-main_main.c14
-rw-r--r--lang/php82/pkg-plist12
-rw-r--r--sysutils/php82-posix/files/patch-posix.c62
8 files changed, 129 insertions, 12 deletions
diff --git a/lang/php82/Makefile b/lang/php82/Makefile
index 82634154a4ac..9956d1494a5a 100644
--- a/lang/php82/Makefile
+++ b/lang/php82/Makefile
@@ -1,5 +1,5 @@
PORTNAME= php82
-DISTVERSION= 8.2.14
+DISTVERSION= 8.2.15
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
@@ -22,6 +22,7 @@ LIB_DEPENDS= libargon2.so:security/libargon2 \
libpcre2-8.so:devel/pcre2
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${MANPREFIX}/share
CONFIGURE_ARGS+= --disable-all \
--program-prefix="" \
--with-config-file-scan-dir=${PREFIX}/etc/php \
diff --git a/lang/php82/distinfo b/lang/php82/distinfo
index 09fae9d03f24..3dca65c2fa4a 100644
--- a/lang/php82/distinfo
+++ b/lang/php82/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1703153770
-SHA256 (php-8.2.14.tar.xz) = 763ecd39fcf51c3815af6ef6e43fa9aa0d0bd8e5a615009e5f4780c92705f583
-SIZE (php-8.2.14.tar.xz) = 12080468
+TIMESTAMP = 1705528747
+SHA256 (php-8.2.15.tar.xz) = eca5deac02d77d806838275f8a3024b38b35ac0a5d9853dcc71c6cbe3f1f8765
+SIZE (php-8.2.15.tar.xz) = 12075384
diff --git a/lang/php82/files/patch-configure.ac b/lang/php82/files/patch-configure.ac
index a2444a37fa50..c3b522563908 100644
--- a/lang/php82/files/patch-configure.ac
+++ b/lang/php82/files/patch-configure.ac
@@ -1,4 +1,4 @@
---- configure.ac.orig 2023-12-20 06:28:06 UTC
+--- configure.ac.orig 2024-01-16 12:19:32 UTC
+++ configure.ac
@@ -55,6 +55,7 @@ AH_BOTTOM([
@@ -34,7 +34,7 @@
exec_prefix=$old_exec_prefix
libdir=$old_libdir
-@@ -1666,7 +1666,7 @@ PHP_SUBST(install_binary_targets)
+@@ -1667,7 +1667,7 @@ PHP_SUBST(install_binary_targets)
PHP_SUBST(install_targets)
PHP_SUBST(install_binary_targets)
diff --git a/lang/php82/files/patch-ext_standard_filestat.c b/lang/php82/files/patch-ext_standard_filestat.c
new file mode 100644
index 000000000000..776093def4e6
--- /dev/null
+++ b/lang/php82/files/patch-ext_standard_filestat.c
@@ -0,0 +1,26 @@
+--- ext/standard/filestat.c.orig 2024-01-17 22:33:41 UTC
++++ ext/standard/filestat.c
+@@ -315,7 +315,11 @@ PHPAPI int php_get_gid_by_name(const char *name, gid_t
+ char *grbuf;
+
+ if (grbuflen < 1) {
++#if defined(__FreeBSD__) && defined(_SC_PAGESIZE)
++ grbuflen = sysconf(_SC_PAGESIZE);
++#else
+ return FAILURE;
++#endif
+ }
+
+ grbuf = emalloc(grbuflen);
+@@ -441,7 +445,11 @@ PHPAPI uid_t php_get_uid_by_name(const char *name, uid
+ char *pwbuf;
+
+ if (pwbuflen < 1) {
++#if defined(__FreeBSD__) && defined(_SC_PAGESIZE)
++ pwbuflen = sysconf(_SC_PAGESIZE);
++#else
+ return FAILURE;
++#endif
+ }
+
+ pwbuf = emalloc(pwbuflen);
diff --git a/lang/php82/files/patch-main_fopen__wrappers.c b/lang/php82/files/patch-main_fopen__wrappers.c
new file mode 100644
index 000000000000..c07c9a867270
--- /dev/null
+++ b/lang/php82/files/patch-main_fopen__wrappers.c
@@ -0,0 +1,14 @@
+--- main/fopen_wrappers.c.orig 2024-01-17 22:32:57 UTC
++++ main/fopen_wrappers.c
+@@ -369,7 +369,11 @@ PHPAPI int php_fopen_primary_script(zend_file_handle *
+ char *pwbuf;
+
+ if (pwbuflen < 1) {
++#if defined(__FreeBSD__) && defined(_SC_PAGESIZE)
++ buflen = sysconf(_SC_PAGESIZE);
++#else
+ return FAILURE;
++#endif
+ }
+
+ pwbuf = emalloc(pwbuflen);
diff --git a/lang/php82/files/patch-main_main.c b/lang/php82/files/patch-main_main.c
new file mode 100644
index 000000000000..ce0c20318317
--- /dev/null
+++ b/lang/php82/files/patch-main_main.c
@@ -0,0 +1,14 @@
+--- main/main.c.orig 2024-01-17 22:30:20 UTC
++++ main/main.c
+@@ -1448,7 +1448,11 @@ PHPAPI char *php_get_current_user(void)
+ char *pwbuf;
+
+ if (pwbuflen < 1) {
++#if defined(__FreeBSD__) && defined(_SC_PAGESIZE)
++ pwbuflen = sysconf(_SC_PAGESIZE);
++#else
+ return "";
++#endif
+ }
+ pwbuf = emalloc(pwbuflen);
+ if (getpwuid_r(pstat->st_uid, &_pw, pwbuf, pwbuflen, &retpwptr) != 0) {
diff --git a/lang/php82/pkg-plist b/lang/php82/pkg-plist
index 431ae89ee086..8d1afa2e164f 100644
--- a/lang/php82/pkg-plist
+++ b/lang/php82/pkg-plist
@@ -306,10 +306,10 @@ lib/php/build/phpize.m4
lib/php/build/pkg.m4
lib/php/build/run-tests.php
lib/php/build/shtool
-%%CGI%%man/man1/php-cgi.1.gz
-man/man1/php-config.1.gz
-%%CLI%%man/man1/php.1.gz
-%%PHPDBG%%man/man1/phpdbg.1.gz
-man/man1/phpize.1.gz
-%%FPM%%man/man8/php-fpm.8.gz
+%%CGI%%share/man/man1/php-cgi.1.gz
+share/man/man1/php-config.1.gz
+%%CLI%%share/man/man1/php.1.gz
+%%PHPDBG%%share/man/man1/phpdbg.1.gz
+share/man/man1/phpize.1.gz
+%%FPM%%share/man/man8/php-fpm.8.gz
%%FPM%%share/php/fpm/status.html
diff --git a/sysutils/php82-posix/files/patch-posix.c b/sysutils/php82-posix/files/patch-posix.c
new file mode 100644
index 000000000000..8d54d8ebd935
--- /dev/null
+++ b/sysutils/php82-posix/files/patch-posix.c
@@ -0,0 +1,62 @@
+--- posix.c.orig 2024-01-17 22:35:53 UTC
++++ posix.c
+@@ -465,7 +465,11 @@ PHP_FUNCTION(posix_ttyname)
+ #if defined(ZTS) && defined(HAVE_TTYNAME_R) && defined(_SC_TTY_NAME_MAX)
+ buflen = sysconf(_SC_TTY_NAME_MAX);
+ if (buflen < 1) {
++#if defined(__FreeBSD__) && defined(_SC_PAGESIZE)
++ buflen = sysconf(_SC_PAGESIZE);
++#else
+ RETURN_FALSE;
++#endif
+ }
+ p = emalloc(buflen);
+
+@@ -728,7 +732,11 @@ PHP_FUNCTION(posix_getgrnam)
+ #if defined(ZTS) && defined(HAVE_GETGRNAM_R) && defined(_SC_GETGR_R_SIZE_MAX)
+ buflen = sysconf(_SC_GETGR_R_SIZE_MAX);
+ if (buflen < 1) {
++#if defined(__FreeBSD__) && defined(_SC_PAGESIZE)
++ buflen = sysconf(_SC_PAGESIZE);
++#else
+ RETURN_FALSE;
++#endif
+ }
+ buf = emalloc(buflen);
+ try_again:
+@@ -784,7 +792,11 @@ PHP_FUNCTION(posix_getgrgid)
+
+ grbuflen = sysconf(_SC_GETGR_R_SIZE_MAX);
+ if (grbuflen < 1) {
++#if defined(__FreeBSD__) && defined(_SC_PAGESIZE)
++ grbuflen = sysconf(_SC_PAGESIZE);
++#else
+ RETURN_FALSE;
++#endif
+ }
+
+ grbuf = emalloc(grbuflen);
+@@ -858,7 +870,11 @@ PHP_FUNCTION(posix_getpwnam)
+ #if defined(ZTS) && defined(_SC_GETPW_R_SIZE_MAX) && defined(HAVE_GETPWNAM_R)
+ buflen = sysconf(_SC_GETPW_R_SIZE_MAX);
+ if (buflen < 1) {
++#if defined(__FreeBSD__) && defined(_SC_PAGESIZE)
++ buflen = sysconf(_SC_PAGESIZE);
++#else
+ RETURN_FALSE;
++#endif
+ }
+ buf = emalloc(buflen);
+ pw = &pwbuf;
+@@ -913,7 +929,11 @@ PHP_FUNCTION(posix_getpwuid)
+ #if defined(ZTS) && defined(_SC_GETPW_R_SIZE_MAX) && defined(HAVE_GETPWUID_R)
+ pwbuflen = sysconf(_SC_GETPW_R_SIZE_MAX);
+ if (pwbuflen < 1) {
++#if defined(__FreeBSD__) && defined(_SC_PAGESIZE)
++ pwbuflen = sysconf(_SC_PAGESIZE);
++#else
+ RETURN_FALSE;
++#endif
+ }
+ pwbuf = emalloc(pwbuflen);
+