aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Osipov <michael.osipov@siemens.com>2023-09-16 20:15:57 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2023-09-17 05:30:09 +0000
commit152d92bf575e1c2f2efd4b06372898aa8b653db0 (patch)
treec2388a0c6c8eddfc8348727780333cbb5620006a
parente99662361104e992a3bccfa98112ffb8722d1de9 (diff)
downloadports-152d92bf575e1c2f2efd4b06372898aa8b653db0.tar.gz
ports-152d92bf575e1c2f2efd4b06372898aa8b653db0.zip
*/*: Use only HTTPS to fetch ports from Maven Central
Maven Central supports HTTPS only for quite some time now and responds with "Not Implemented" over HTTP. Source: https://blog.sonatype.com/central-repository-moving-to-https PR: 272867
-rw-r--r--java/hamcrest/Makefile2
-rw-r--r--java/junit/Makefile2
-rw-r--r--lang/jython/Makefile3
-rw-r--r--math/apache-commons-math/Makefile2
-rw-r--r--www/servlet-api/Makefile3
5 files changed, 5 insertions, 7 deletions
diff --git a/java/hamcrest/Makefile b/java/hamcrest/Makefile
index cb0c81262192..eab63fa1d110 100644
--- a/java/hamcrest/Makefile
+++ b/java/hamcrest/Makefile
@@ -1,7 +1,7 @@
PORTNAME= hamcrest
PORTVERSION= 1.3
CATEGORIES= java devel
-MASTER_SITES= http://repo1.maven.org/maven2/org/${PORTNAME}/${PORTNAME}-all/${PORTVERSION}/
+MASTER_SITES= https://repo1.maven.org/maven2/org/${PORTNAME}/${PORTNAME}-all/${PORTVERSION}/
DISTFILES= ${PORTNAME}-all-${PORTVERSION}.jar ${PORTNAME}-all-${PORTVERSION}-sources.jar
EXTRACT_ONLY=
diff --git a/java/junit/Makefile b/java/junit/Makefile
index 90e9d5d6b598..49601d6ad9fd 100644
--- a/java/junit/Makefile
+++ b/java/junit/Makefile
@@ -1,7 +1,7 @@
PORTNAME= junit
PORTVERSION= 4.12
CATEGORIES= java devel
-MASTER_SITES= http://repo1.maven.org/maven2/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
+MASTER_SITES= https://repo1.maven.org/maven2/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
DISTFILES= ${DISTNAME}.jar ${DISTNAME}-sources.jar
EXTRACT_ONLY=
diff --git a/lang/jython/Makefile b/lang/jython/Makefile
index fe6daa77fc86..51b0564da3ef 100644
--- a/lang/jython/Makefile
+++ b/lang/jython/Makefile
@@ -2,8 +2,7 @@ PORTNAME= jython
PORTVERSION= 2.7.0
DISTVERSIONPREFIX= installer-
CATEGORIES= lang python java
-MASTER_SITES= https://repo1.maven.org/maven2/org/python/jython-installer/${PORTVERSION}/ \
- http://repo1.maven.org/maven2/org/python/jython-installer/${PORTVERSION}/
+MASTER_SITES= https://repo1.maven.org/maven2/org/python/jython-installer/${PORTVERSION}/
EXTRACT_SUFX= .jar
MAINTAINER= python@FreeBSD.org
diff --git a/math/apache-commons-math/Makefile b/math/apache-commons-math/Makefile
index 2366c781e663..59e38cc39ec5 100644
--- a/math/apache-commons-math/Makefile
+++ b/math/apache-commons-math/Makefile
@@ -3,7 +3,7 @@ PORTVERSION= 3.6.1
PORTREVISION= 1
CATEGORIES= math java
MASTER_SITES= APACHE_COMMONS_SOURCE \
- http://repo1.maven.org/maven2/junit/junit/4.8.2/:source2
+ https://repo1.maven.org/maven2/junit/junit/4.8.2/:source2
PKGNAMEPREFIX= apache-
DISTNAME= ${PORTNAME}3-${PORTVERSION}-src
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
diff --git a/www/servlet-api/Makefile b/www/servlet-api/Makefile
index 413dc8d2b03d..cefa0d464e3c 100644
--- a/www/servlet-api/Makefile
+++ b/www/servlet-api/Makefile
@@ -2,8 +2,7 @@ PORTNAME= servlet-api
PORTVERSION= 2.5
PORTREVISION= 3
CATEGORIES= www java
-MASTER_SITES= http://maven.ibiblio.org/maven2/javax/servlet/servlet-api/2.5/ \
- http://repo1.maven.org/maven2/javax/servlet/servlet-api/2.5/
+MASTER_SITES= https://repo1.maven.org/maven2/javax/servlet/servlet-api/2.5/
EXTRACT_SUFX= .jar
EXTRACT_ONLY= # empty