aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2023-09-04 08:22:42 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2023-09-04 08:22:42 +0000
commit16446be04be60fc4831368bf7dc9b2199aa1d6ac (patch)
treed216230dc0d8796e55ad69edd130e765f248ad3b
parent041cacb90b5cb523a3a41cd300f3081442c00f98 (diff)
downloadports-16446be04be60fc4831368bf7dc9b2199aa1d6ac.tar.gz
ports-16446be04be60fc4831368bf7dc9b2199aa1d6ac.zip
security/py-yubikey-manager: update 4.0.9 to 5.2.0
While here, * Add OTP HID support for FreeBSD (merged in upstream) [0]; * Move into pep517 (https://wiki.freebsd.org/Python/PEP-517); * Start using USES=pycryptography as introduced by 7bb64b89d0e5ec8 Note that, * should one does not with to set PYCRYPTOGRAHY_DEFAULT=legacy, `ykman` (and other packages/ports depending on that) would require CRYPTOGRAPHY_OPENSSL_NO_LEGACY= to be true. [0] https://github.com/Yubico/yubikey-manager/commit/ecd7897b3f020542f70581f77f47ba57c739b334 PR: 273505 Reported by: David Horn <dhorn2000 % gmail.com>
-rw-r--r--security/py-yubikey-manager/Makefile12
-rw-r--r--security/py-yubikey-manager/distinfo6
-rw-r--r--security/py-yubikey-manager/files/patch-ykman_hid_____init____.py12
3 files changed, 10 insertions, 20 deletions
diff --git a/security/py-yubikey-manager/Makefile b/security/py-yubikey-manager/Makefile
index 1e0c98ae7bda..627003afdcca 100644
--- a/security/py-yubikey-manager/Makefile
+++ b/security/py-yubikey-manager/Makefile
@@ -1,9 +1,9 @@
PORTNAME= yubikey-manager
-PORTVERSION= 4.0.9
-PORTREVISION= 4
+PORTVERSION= 5.2.0
CATEGORIES= security python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= yubikey_manager-${PORTVERSION}
MAINTAINER= egypcio@FreeBSD.org
COMMENT= Python library and command line tool for configuring a YubiKey
@@ -12,9 +12,11 @@ WWW= https://developers.yubico.com/yubikey-manager/
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ ${PYTHON_PKGNAMEPREFIX}poetry>=0:devel/py-poetry@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}fido2>0:security/py-fido2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}keyring>=0:security/py-keyring@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}openssl>0:security/py-openssl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyscard>0:security/py-pyscard@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyusb>0:devel/py-pyusb@${PY_FLAVOR} \
@@ -25,8 +27,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}makefun>0:devel/py-makefun@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
-USES= dos2unix python pycryptography:run
-USE_PYTHON= autoplist concurrent distutils unittest
+USES= dos2unix pycryptography python
+USE_PYTHON= autoplist concurrent pep517 unittest
DOS2UNIX_GLOB= *.adoc *.py
diff --git a/security/py-yubikey-manager/distinfo b/security/py-yubikey-manager/distinfo
index 253879d02872..222bb2ba71c4 100644
--- a/security/py-yubikey-manager/distinfo
+++ b/security/py-yubikey-manager/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1655559347
-SHA256 (yubikey-manager-4.0.9.tar.gz) = 384e3a2a66df4ce417aede734eb8c5d0c1b7981290e9bc940c85cc000ef833b4
-SIZE (yubikey-manager-4.0.9.tar.gz) = 145952
+TIMESTAMP = 1693744660
+SHA256 (yubikey_manager-5.2.0.tar.gz) = 45e0f09e3cee2375b6f930dd5d89c1d3a7ca5d5cccb599b16a12f8f7d989fd36
+SIZE (yubikey_manager-5.2.0.tar.gz) = 184873
diff --git a/security/py-yubikey-manager/files/patch-ykman_hid_____init____.py b/security/py-yubikey-manager/files/patch-ykman_hid_____init____.py
deleted file mode 100644
index baa8cb71818f..000000000000
--- a/security/py-yubikey-manager/files/patch-ykman_hid_____init____.py
+++ /dev/null
@@ -1,12 +0,0 @@
-See https://github.com/Yubico/yubikey-manager/commit/ecd7897b3f02054
---- ykman/hid/__init__.py.orig 2022-05-27 13:02:44 UTC
-+++ ykman/hid/__init__.py
-@@ -41,6 +41,8 @@ elif sys.platform.startswith("win32"):
- from . import windows as backend
- elif sys.platform.startswith("darwin"):
- from . import macos as backend
-+elif sys.platform.startswith("freebsd"):
-+ from . import freebsd as backend
- else:
-
- class backend: