aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2018-06-16 03:44:54 +0000
committerEitan Adler <eadler@FreeBSD.org>2018-06-16 03:44:54 +0000
commit170b5bcbf486b374692bb9c86397b42f1aecf910 (patch)
tree3591a2395007070bb1f53ca4e41f2e27bf089e68
parentbe8bf72894bc11b325140d364c50d75120c5ffa7 (diff)
downloadports-170b5bcbf486b374692bb9c86397b42f1aecf910.tar.gz
ports-170b5bcbf486b374692bb9c86397b42f1aecf910.zip
x11/xorg-minimal: correct deps for intel; remove intel29
- Remove intel29, which is well past EoL - correct a mistake I made earlier and add back a missing dep Reported by: jbeich
Notes
Notes: svn path=/head/; revision=472515
-rw-r--r--x11/xorg-minimal/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/x11/xorg-minimal/Makefile b/x11/xorg-minimal/Makefile
index 2e4d0803a05c..b9234f2d1634 100644
--- a/x11/xorg-minimal/Makefile
+++ b/x11/xorg-minimal/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xorg
PORTVERSION= 7.5.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 x11-servers
PKGNAMESUFFIX= -minimal
@@ -21,10 +21,9 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/Xorg:x11-servers/xorg-server \
${LOCALBASE}/bin/xauth:x11/xauth
.if ${VIDEO_DRIVER} == "nvidia"
RUN_DEPENDS+= ${LOCALBASE}/lib/xorg/modules/drivers/nvidia_drv.so:x11/nvidia-driver
-.elif ${VIDEO_DRIVER} == "intel29"
-RUN_DEPENDS+= ${LOCALBASE}/lib/xorg/modules/drivers/intel_drv.so:x11-drivers/xf86-video-intel
.elif ${VIDEO_DRIVER} == "intel"
RUN_DEPENDS+= ${LOCALBASE}/lib/va/i965_drv_video.so:multimedia/libva-intel-driver
+RUN_DEPENDS+= ${LOCALBASE}/lib/xorg/modules/drivers/${VIDEO_DRIVER}_drv.so:x11-drivers/xf86-video-${VIDEO_DRIVER}
.else
RUN_DEPENDS+= ${LOCALBASE}/lib/xorg/modules/drivers/${VIDEO_DRIVER}_drv.so:x11-drivers/xf86-video-${VIDEO_DRIVER}
.endif