aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2022-02-23 21:21:02 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2022-02-23 21:21:02 +0000
commit1735c5dd90ff1c3468d4e1a1ca8d7dd0759125ce (patch)
treec2a3ea7d1a3d9422b1094b675e8ab077af46cac7
parente638181305a9a2cb9e74a54e28df70453cb4a152 (diff)
downloadports-1735c5dd90ff1c3468d4e1a1ca8d7dd0759125ce.tar.gz
ports-1735c5dd90ff1c3468d4e1a1ca8d7dd0759125ce.zip
graphics/kseexpr: add new port
kseexpr is a fork of SeExpr for Krita. WWW: https://invent.kde.org/graphics/kseexpr
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/kseexpr/Makefile18
-rw-r--r--graphics/kseexpr/distinfo3
-rw-r--r--graphics/kseexpr/pkg-descr6
-rw-r--r--graphics/kseexpr/pkg-plist85
5 files changed, 113 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index a88316025099..9f3180afeda9 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -422,6 +422,7 @@
SUBDIR += kqtquickcharts
SUBDIR += kquickimageeditor
SUBDIR += krita
+ SUBDIR += kseexpr
SUBDIR += ksnip
SUBDIR += kxstitch
SUBDIR += l2p
diff --git a/graphics/kseexpr/Makefile b/graphics/kseexpr/Makefile
new file mode 100644
index 000000000000..48acc54c219e
--- /dev/null
+++ b/graphics/kseexpr/Makefile
@@ -0,0 +1,18 @@
+PORTNAME= kseexpr
+DISTVERSION= 4.0.4.0
+CATEGORIES= graphics kde
+MASTER_SITES= KDE/stable/${PORTNAME}/${DISTVERSION:R}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Embeddable expression engine for Krita
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+CONFLICTS_INSTALL= seexpr
+
+USES= bison cmake kde:5 qt:5
+USE_KDE= ecm i18n
+USE_QT= core gui widgets buildtools_build linguisttools_build qmake_build
+
+.include <bsd.port.mk>
diff --git a/graphics/kseexpr/distinfo b/graphics/kseexpr/distinfo
new file mode 100644
index 000000000000..51c479b26776
--- /dev/null
+++ b/graphics/kseexpr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1645649162
+SHA256 (kseexpr-4.0.4.0.tar.gz) = ea4f6a8e820e6cc12d2a1e6977e96ea5457f37729fe0bc4ee8cc62d4c26c36ae
+SIZE (kseexpr-4.0.4.0.tar.gz) = 955577
diff --git a/graphics/kseexpr/pkg-descr b/graphics/kseexpr/pkg-descr
new file mode 100644
index 000000000000..6073f299bd8a
--- /dev/null
+++ b/graphics/kseexpr/pkg-descr
@@ -0,0 +1,6 @@
+SeExpr is an embeddable, arithmetic expression language that enables flexible
+artistic control and customization in creating computer graphics images.
+
+kseexpr is a fork of SeExpr for Krita.
+
+WWW: https://invent.kde.org/graphics/kseexpr
diff --git a/graphics/kseexpr/pkg-plist b/graphics/kseexpr/pkg-plist
new file mode 100644
index 000000000000..028d143aa8d3
--- /dev/null
+++ b/graphics/kseexpr/pkg-plist
@@ -0,0 +1,85 @@
+include/KSeExpr/Context.h
+include/KSeExpr/Curve.h
+include/KSeExpr/ErrorCode.h
+include/KSeExpr/Evaluator.h
+include/KSeExpr/ExprBuiltins.h
+include/KSeExpr/ExprConfig.h
+include/KSeExpr/ExprEnv.h
+include/KSeExpr/ExprFunc.h
+include/KSeExpr/ExprFuncStandard.h
+include/KSeExpr/ExprFuncX.h
+include/KSeExpr/ExprLLVM.h
+include/KSeExpr/ExprLLVMAll.h
+include/KSeExpr/ExprMultiExpr.h
+include/KSeExpr/ExprNode.h
+include/KSeExpr/ExprParser.h
+include/KSeExpr/ExprPatterns.h
+include/KSeExpr/ExprType.h
+include/KSeExpr/ExprWalker.h
+include/KSeExpr/Expression.h
+include/KSeExpr/Interpreter.h
+include/KSeExpr/Noise.h
+include/KSeExpr/NoiseTables.h
+include/KSeExpr/PerformanceTimer.h
+include/KSeExpr/StringUtils.h
+include/KSeExpr/Timer.h
+include/KSeExpr/TypePrinter.h
+include/KSeExpr/Utils.h
+include/KSeExpr/VarBlock.h
+include/KSeExpr/Vec.h
+include/KSeExpr/kseexpr_export.h
+include/KSeExprUI/BasicExpression.h
+include/KSeExprUI/ControlSpec.h
+include/KSeExprUI/Debug.h
+include/KSeExprUI/Editable.h
+include/KSeExprUI/EditableExpression.h
+include/KSeExprUI/ErrorMessages.h
+include/KSeExprUI/ExprAddDialog.h
+include/KSeExprUI/ExprBrowser.h
+include/KSeExprUI/ExprColorCurve.h
+include/KSeExprUI/ExprColorSwatch.h
+include/KSeExprUI/ExprCompletionModel.h
+include/KSeExprUI/ExprControl.h
+include/KSeExprUI/ExprControlCollection.h
+include/KSeExprUI/ExprCurve.h
+include/KSeExprUI/ExprEditor.h
+include/KSeExprUI/ExprFileDialog.h
+include/KSeExprUI/ExprHighlighter.h
+include/KSeExprUI/ExprPopupDoc.h
+include/KSeExprUI/ExprSpecType.h
+include/KSeExprUI/ExprTextEdit.h
+include/KSeExprUI/Utils.h
+lib/cmake/KSeExpr/KSeExprTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KSeExpr/KSeExprTargets.cmake
+lib/cmake/KSeExpr/kseexpr-config-version.cmake
+lib/cmake/KSeExpr/kseexpr-config.cmake
+lib/libKSeExpr.so
+lib/libKSeExpr.so.4
+lib/libKSeExpr.so.4.0.4.0
+lib/libKSeExprUI.so
+lib/libKSeExprUI.so.4
+lib/libKSeExprUI.so.4.0.4.0
+share/locale/ca/LC_MESSAGES/seexpr2_qt.qm
+share/locale/ca@valencia/LC_MESSAGES/seexpr2_qt.qm
+share/locale/cs/LC_MESSAGES/seexpr2_qt.qm
+share/locale/de/LC_MESSAGES/seexpr2_qt.qm
+share/locale/en_GB/LC_MESSAGES/seexpr2_qt.qm
+share/locale/es/LC_MESSAGES/seexpr2_qt.qm
+share/locale/fr/LC_MESSAGES/seexpr2_qt.qm
+share/locale/it/LC_MESSAGES/seexpr2_qt.qm
+share/locale/ja/LC_MESSAGES/seexpr2_qt.qm
+share/locale/ko/LC_MESSAGES/seexpr2_qt.qm
+share/locale/lt/LC_MESSAGES/seexpr2_qt.qm
+share/locale/nl/LC_MESSAGES/seexpr2_qt.qm
+share/locale/nn/LC_MESSAGES/seexpr2_qt.qm
+share/locale/pl/LC_MESSAGES/seexpr2_qt.qm
+share/locale/pt/LC_MESSAGES/seexpr2_qt.qm
+share/locale/pt_BR/LC_MESSAGES/seexpr2_qt.qm
+share/locale/ru/LC_MESSAGES/seexpr2_qt.qm
+share/locale/sk/LC_MESSAGES/seexpr2_qt.qm
+share/locale/sl/LC_MESSAGES/seexpr2_qt.qm
+share/locale/sv/LC_MESSAGES/seexpr2_qt.qm
+share/locale/uk/LC_MESSAGES/seexpr2_qt.qm
+share/locale/zh_CN/LC_MESSAGES/seexpr2_qt.qm
+share/locale/zh_TW/LC_MESSAGES/seexpr2_qt.qm
+share/pkgconfig/kseexpr.pc