aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-01 05:30:17 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-01 05:30:17 +0000
commit1745375d9587044c1a74e751cd4dac02802fa363 (patch)
treec6a216d40d3260ba2b918defb0067c20adc8a523
parent80c578f61a9e46025df7bedd3114bc8f990ce0cd (diff)
downloadports-1745375d9587044c1a74e751cd4dac02802fa363.tar.gz
ports-1745375d9587044c1a74e751cd4dac02802fa363.zip
www/gitlab-ce: Fix Gemfile to match RUN_DEPENDS
The error message is as follows: cp -f /wrkdirs/usr/ports/www/gitlab-ce/work/gitlab-foss-v16.5.0/config/database.yml.postgresql /wrkdirs/usr/ports/www/gitlab-ce/work/gitlab-foss-v16.5.0/config/database.yml.sample (cd /wrkdirs/usr/ports/www/gitlab-ce/work/gitlab-foss-v16.5.0 && /bin/rm -f Gemfile.lock && bundle install --local) Don't run Bundler as root. Installing your bundle as root will break this application for all non-root users on this machine. Could not find gem 'grpc (~> 1.58.0)' in cached gems or installed locally. The source contains the following gems matching 'grpc': * grpc-1.59.0 *** Error code 7 Approved by: portmgr (blanket)
-rw-r--r--www/gitlab-ce/Makefile1
-rw-r--r--www/gitlab-ce/files/patch-Gemfile9
2 files changed, 9 insertions, 1 deletions
diff --git a/www/gitlab-ce/Makefile b/www/gitlab-ce/Makefile
index 45a5e5aacce8..a3ed69be12c9 100644
--- a/www/gitlab-ce/Makefile
+++ b/www/gitlab-ce/Makefile
@@ -272,7 +272,6 @@ MY_DEPENDS= git>=2.41.0:devel/git \
rubygem-duo_api>=1.3<2:security/rubygem-duo_api \
rubygem-google-cloud-profiler-v2>=0.3<1:textproc/rubygem-google-cloud-profiler-v2
-
BUILD_DEPENDS= gem:devel/ruby-gems \
${MY_DEPENDS}
diff --git a/www/gitlab-ce/files/patch-Gemfile b/www/gitlab-ce/files/patch-Gemfile
index c97f50a4dba2..34c54fa1a116 100644
--- a/www/gitlab-ce/files/patch-Gemfile
+++ b/www/gitlab-ce/files/patch-Gemfile
@@ -155,6 +155,15 @@
gem 'octokit', '~> 6.0' # rubocop:todo Gemfile/MissingFeatureCategory
gem 'gitlab-mail_room', '~> 0.0.23', require: 'mail_room' # rubocop:todo Gemfile/MissingFeatureCategory
+@@ -536,7 +437,7 @@ gem 'gitaly', '~> 16.5.0.pre.rc1' # rubocop:todo Gemfi
+ # KAS GRPC protocol definitions
+ gem 'kas-grpc', '~> 0.2.0' # rubocop:todo Gemfile/MissingFeatureCategory
+
+-gem 'grpc', '~> 1.58.0' # rubocop:todo Gemfile/MissingFeatureCategory
++gem 'grpc', '~> 1.58' # rubocop:todo Gemfile/MissingFeatureCategory
+
+ gem 'google-protobuf', '~> 3.24', '>= 3.24.4' # rubocop:todo Gemfile/MissingFeatureCategory
+
@@ -557,7 +458,7 @@ gem 'grape_logging', '~> 1.8', feature_category: :api
gem 'gitlab-net-dns', '~> 0.9.2' # rubocop:todo Gemfile/MissingFeatureCategory