aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 14:32:03 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:07:14 +0000
commit1758092d1988ad748c36394aff50294cc0c04183 (patch)
tree0c4cb2ee886a110ccb304d3796686afde0eba70d
parentb7ec1cb90ebe0d04cf3498b5e0ba08fdb3184eeb (diff)
downloadports-1758092d1988ad748c36394aff50294cc0c04183.tar.gz
ports-1758092d1988ad748c36394aff50294cc0c04183.zip
devel/py-check-jsonschema: Update to 0.28.0
-rw-r--r--devel/py-check-jsonschema/Makefile6
-rw-r--r--devel/py-check-jsonschema/distinfo6
-rw-r--r--devel/py-check-jsonschema/files/patch-setup.cfg8
3 files changed, 12 insertions, 8 deletions
diff --git a/devel/py-check-jsonschema/Makefile b/devel/py-check-jsonschema/Makefile
index 1ff8fe841158..59376b55ae1b 100644
--- a/devel/py-check-jsonschema/Makefile
+++ b/devel/py-check-jsonschema/Makefile
@@ -1,5 +1,5 @@
PORTNAME= check-jsonschema
-PORTVERSION= 0.27.3
+PORTVERSION= 0.28.0
CATEGORIES= devel python
MASTER_SITES= PYPI \
https://github.com/python-jsonschema/check-jsonschema/releases/download/${PORTVERSION}/
@@ -28,4 +28,8 @@ NO_ARCH= yes
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-resources>=1.4.0:devel/py-importlib-resources@${PY_FLAVOR}
.endif
+.if ${PYTHON_REL} < 1100
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tomli>=2.0:textproc/py-tomli@${PY_FLAVOR}
+.endif
+
.include <bsd.port.post.mk>
diff --git a/devel/py-check-jsonschema/distinfo b/devel/py-check-jsonschema/distinfo
index 9e9fe3ff08f4..f0135dfb23e9 100644
--- a/devel/py-check-jsonschema/distinfo
+++ b/devel/py-check-jsonschema/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1702028090
-SHA256 (check-jsonschema-0.27.3.tar.gz) = d6537ef049f34d770345327b2d41aa1e4bec1b6b02b57d4458348f039980228c
-SIZE (check-jsonschema-0.27.3.tar.gz) = 236664
+TIMESTAMP = 1708449138
+SHA256 (check-jsonschema-0.28.0.tar.gz) = defd6c5e944f07416170df33f218ab048c87129163601eec7b191fa076e91ca5
+SIZE (check-jsonschema-0.28.0.tar.gz) = 245274
diff --git a/devel/py-check-jsonschema/files/patch-setup.cfg b/devel/py-check-jsonschema/files/patch-setup.cfg
index 81afb78e868b..26d648ed7a0c 100644
--- a/devel/py-check-jsonschema/files/patch-setup.cfg
+++ b/devel/py-check-jsonschema/files/patch-setup.cfg
@@ -1,11 +1,11 @@
---- setup.cfg.orig 2023-08-10 22:07:07 UTC
+--- setup.cfg.orig 2024-02-06 04:43:45 UTC
+++ setup.cfg
-@@ -17,7 +17,7 @@ classifiers =
- python_requires = >=3.8
+@@ -18,7 +18,7 @@ install_requires =
install_requires =
importlib-resources>=1.4.0;python_version<"3.9"
+ tomli>=2.0;python_version<"3.11"
- ruamel.yaml==0.18.5
+ ruamel.yaml>=0.18.5
jsonschema>=4.18.0,<5.0
+ regress>=0.4.0
requests<3.0
- click>=8,<9