aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:34:07 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 13:00:16 +0000
commit177600dea5946bc6f05ba0b87152db53996d0b05 (patch)
tree94f0b8c9f5d20a72cb4e2f4a63d13ff0d522b806
parent86b78e6eff2960028d9b2c5f1b5c36059134ec08 (diff)
downloadports-177600dea5946bc6f05ba0b87152db53996d0b05.tar.gz
ports-177600dea5946bc6f05ba0b87152db53996d0b05.zip
security/py-nassl: Update to 5.0.0
-rw-r--r--security/py-nassl/Makefile2
-rw-r--r--security/py-nassl/distinfo6
-rw-r--r--security/py-nassl/files/patch-openssl26
3 files changed, 17 insertions, 17 deletions
diff --git a/security/py-nassl/Makefile b/security/py-nassl/Makefile
index 253922235353..fd80067d2213 100644
--- a/security/py-nassl/Makefile
+++ b/security/py-nassl/Makefile
@@ -1,5 +1,5 @@
PORTNAME= nassl
-PORTVERSION= 4.0.2
+PORTVERSION= 5.0.0
CATEGORIES= security python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/security/py-nassl/distinfo b/security/py-nassl/distinfo
index 7894a28255b0..041603a59e79 100644
--- a/security/py-nassl/distinfo
+++ b/security/py-nassl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1656092882
-SHA256 (nabla-c0d3-nassl-4.0.2_GH0.tar.gz) = 440296e07ee021dc283bfe7b810f3139349e26445bc21b5e05820808e15186a2
-SIZE (nabla-c0d3-nassl-4.0.2_GH0.tar.gz) = 212003
+TIMESTAMP = 1674589996
+SHA256 (nabla-c0d3-nassl-5.0.0_GH0.tar.gz) = b1529de53e1017a4b69ad656bcef762633aec54c86c9ec016879d657bf463297
+SIZE (nabla-c0d3-nassl-5.0.0_GH0.tar.gz) = 214351
diff --git a/security/py-nassl/files/patch-openssl b/security/py-nassl/files/patch-openssl
index d25df5b8be4e..584bd6dd83be 100644
--- a/security/py-nassl/files/patch-openssl
+++ b/security/py-nassl/files/patch-openssl
@@ -1,4 +1,4 @@
---- nassl/_nassl/nassl_SSL.c.orig 2022-01-01 11:07:11 UTC
+--- nassl/_nassl/nassl_SSL.c.orig 2022-11-20 14:28:29 UTC
+++ nassl/_nassl/nassl_SSL.c
@@ -1034,6 +1034,7 @@ static PyObject *nassl_SSL_get_dh_info(nassl_SSL_Objec
return return_dict;
@@ -16,7 +16,7 @@
#endif
else
{
---- nassl/_nassl/nassl_SSL_CTX.c.orig 2022-01-01 11:07:11 UTC
+--- nassl/_nassl/nassl_SSL_CTX.c.orig 2022-11-20 14:28:29 UTC
+++ nassl/_nassl/nassl_SSL_CTX.c
@@ -88,8 +88,10 @@ static PyObject* nassl_SSL_CTX_new(PyTypeObject *type,
// Replicate the pre-1.1.0 OpenSSL API to avoid breaking _nassl's API
@@ -29,9 +29,9 @@
SSL_CTX_set_max_proto_version(sslCtx, 0);
break;
#endif
---- nassl/ssl_client.py.orig 2022-01-01 11:07:11 UTC
+--- nassl/ssl_client.py.orig 2022-11-20 14:28:29 UTC
+++ nassl/ssl_client.py
-@@ -417,6 +417,25 @@ class SslClient(BaseSslClient):
+@@ -429,6 +429,25 @@ class SslClient(BaseSslClient):
# The default client uses the modern OpenSSL
_NASSL_MODULE = _nassl
@@ -57,7 +57,7 @@
def write_early_data(self, data: bytes) -> int:
"""Returns the number of (encrypted) bytes sent."""
if self._is_handshake_completed:
---- setup.py.orig 2022-01-01 11:07:11 UTC
+--- setup.py.orig 2022-11-20 14:28:29 UTC
+++ setup.py
@@ -2,29 +2,25 @@ import copy
import sys
@@ -86,7 +86,7 @@
"version": __version__,
- "packages": find_packages(exclude=["docs", "tests"]),
+ "packages": find_packages(exclude=["docs*", "tests*"]),
- "package_data": {"nassl": ["py.typed"]},
+ "package_data": {"nassl": ["py.typed", "_nassl.pyi", "_nassl_legacy.pyi"]},
"py_modules": [
"nassl.__init__",
"nassl.ssl_client",
@@ -95,7 +95,7 @@
"nassl.ocsp_response",
"nassl.cert_chain_verifier",
],
-@@ -70,58 +66,21 @@ BASE_NASSL_EXT_SETUP = {
+@@ -71,58 +67,21 @@ BASE_NASSL_EXT_SETUP = {
],
}
@@ -161,7 +161,7 @@
],
}
)
-@@ -130,18 +89,11 @@ MODERN_NASSL_EXT_SETUP["sources"].append(
+@@ -131,18 +90,11 @@ MODERN_NASSL_EXT_SETUP["sources"].append(
) # API only available in modern nassl
@@ -182,7 +182,7 @@
)
---- tests/SSL_CTX_test.py.orig 2022-01-01 11:07:11 UTC
+--- tests/SSL_CTX_test.py.orig 2022-11-20 14:28:29 UTC
+++ tests/SSL_CTX_test.py
@@ -2,11 +2,11 @@ import tempfile
@@ -198,7 +198,7 @@
class TestCommonSSL_CTX:
def test_new(self, nassl_module):
assert nassl_module.SSL_CTX(OpenSslVersionEnum.SSLV23.value)
---- tests/SSL_test.py.orig 2022-01-01 11:07:11 UTC
+--- tests/SSL_test.py.orig 2022-11-20 14:28:29 UTC
+++ tests/SSL_test.py
@@ -1,11 +1,10 @@
import pytest
@@ -248,7 +248,7 @@
- test_ssl.set_connect_state()
- with pytest.raises(_nassl.OpenSSLError, match="ssl handshake failure"):
- test_ssl.write("tests")
---- tests/X509_test.py.orig 2022-01-01 11:07:11 UTC
+--- tests/X509_test.py.orig 2022-11-20 14:28:29 UTC
+++ tests/X509_test.py
@@ -1,10 +1,9 @@
import pytest
@@ -262,7 +262,7 @@
class TestX509:
def test_from_pem(self, nassl_module):
# Given a PEM-formatted certificate
---- tests/ocsp_response_test.py.orig 2022-01-01 11:07:11 UTC
+--- tests/ocsp_response_test.py.orig 2022-11-20 14:28:29 UTC
+++ tests/ocsp_response_test.py
@@ -5,7 +5,6 @@ import pytest
import socket
@@ -281,7 +281,7 @@
class TestCommonOcspResponseOnline:
def test(self, ssl_client_cls):
# Given a website that support OCSP stapling
---- tests/ssl_client_test.py.orig 2022-01-01 11:07:11 UTC
+--- tests/ssl_client_test.py.orig 2022-11-20 14:28:29 UTC
+++ tests/ssl_client_test.py
@@ -4,7 +4,6 @@ from pathlib import Path
import pytest