aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-22 06:07:30 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-22 06:11:21 +0000
commit177f895c0f754535f44d8d7c683882b34087e40e (patch)
tree1f234b7a585bb03a15a62ba60261345df342a114
parentfbb3f1c01c4e60c53dd0d0dd3c11449c3dd97486 (diff)
downloadports-177f895c0f754535f44d8d7c683882b34087e40e.tar.gz
ports-177f895c0f754535f44d8d7c683882b34087e40e.zip
devel/mpatrol: Fix build with llvm16
- Add LICENSE GPLv2 Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--devel/mpatrol/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/mpatrol/Makefile b/devel/mpatrol/Makefile
index 5e01d9e15508..922d1aeec1d1 100644
--- a/devel/mpatrol/Makefile
+++ b/devel/mpatrol/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mpatrol
PORTVERSION= 1.4.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel
MASTER_SITES= SF
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -9,6 +9,9 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Dynamic memory debugging and profiling library
WWW= http://mpatrol.sourceforge.net/
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/../../COPYING
+
ONLY_FOR_ARCHS= amd64 i386
.if ${/usr/bin/ld:L:tA} == /usr/bin/ld.lld
BROKEN_i386= ld: error: relocation R_386_PC32 cannot be used against symbol __mp_init
@@ -42,6 +45,10 @@ OPTIONS_DEFINE= DOCS
CFLAGS+= -DENVIRON=\"ENVIRON_64\" -DMP_INIT_SUPPORT=0
.endif
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=dynamic-exception-spec
+.endif
+
do-install:
.for file in hexwords mpedit mpsym mupdate
${INSTALL_SCRIPT} ${WRKSRC}/../../bin/${file} ${STAGEDIR}${PREFIX}/bin