aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-07-05 17:45:25 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-07-05 17:45:31 +0000
commit17c30e448be37877c283b2e1cb17936746eb7232 (patch)
treea2534554ced6ce4bc88fbb2495df0c538c171e5a
parent1d8bd44f535d40fed827d5dfdb470346f487409b (diff)
downloadports-17c30e448be37877c283b2e1cb17936746eb7232.tar.gz
ports-17c30e448be37877c283b2e1cb17936746eb7232.zip
audio/a2jmidid: Fix shebang and disable predefined optimization
* Fix shebang in a2j_control * Disable optimization set by upstream Approved by: portmgr (blanket)
-rw-r--r--audio/a2jmidid/Makefile3
-rw-r--r--audio/a2jmidid/files/patch-meson.build16
2 files changed, 15 insertions, 4 deletions
diff --git a/audio/a2jmidid/Makefile b/audio/a2jmidid/Makefile
index 6eaa38e7b771..fa6d8eebf2d5 100644
--- a/audio/a2jmidid/Makefile
+++ b/audio/a2jmidid/Makefile
@@ -12,7 +12,8 @@ LICENSE= GPLv2+
LIB_DEPENDS= libasound.so:audio/alsa-lib \
libjack.so:audio/jack
-USES= meson pkgconfig tar:bzip2 uidfix
+USES= meson pkgconfig python:env shebangfix tar:bzip2 uidfix
+SHEBANG_FILES= a2j_control
USE_GITHUB= yes
GH_ACCOUNT= jackaudio
diff --git a/audio/a2jmidid/files/patch-meson.build b/audio/a2jmidid/files/patch-meson.build
index 0365fdbf790a..3402e5fdff4e 100644
--- a/audio/a2jmidid/files/patch-meson.build
+++ b/audio/a2jmidid/files/patch-meson.build
@@ -1,6 +1,16 @@
---- meson.build.orig 2022-02-11 10:51:29 UTC
+--- meson.build.orig 2019-09-23 22:34:12 UTC
+++ meson.build
-@@ -17,6 +17,7 @@ dep_jack = dependency('jack')
+@@ -3,8 +3,7 @@ project(
+ 'c',
+ default_options: [
+ 'prefix=/usr/local',
+- 'b_pie=true',
+- 'b_lto=true'
++ 'b_pie=true'
+ ],
+ meson_version: '>=0.50.0',
+ license: 'GPL2+',
+@@ -17,6 +16,7 @@ dep_jack = dependency('jack')
dep_alsa = dependency('alsa')
lib_dl = cc.find_library('dl')
lib_pthread = cc.find_library('pthread')
@@ -8,7 +18,7 @@
deps_a2jmidid = [dep_alsa, dep_jack, lib_dl, lib_pthread]
# source definitions
-@@ -50,6 +51,7 @@ if get_option('disable-dbus')
+@@ -50,6 +50,7 @@ if get_option('disable-dbus')
else
dep_dbus = dependency('dbus-1')
deps_a2jmidid += [dep_dbus]