aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-01-30 19:25:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-01-30 19:25:22 +0000
commit18506f2253fd770f2bee243be89814d057720e8c (patch)
tree643906831ff3d66835af05496c0cda7fda4e3d87
parentfd2b9aecd1349ad18855f7903a169092e674b3ce (diff)
downloadports-18506f2253fd770f2bee243be89814d057720e8c.tar.gz
ports-18506f2253fd770f2bee243be89814d057720e8c.zip
- Update to 2.6.2
- Remove CMAKE_BUILD_TYPE [1] CMAKE_BUILD_TYPE only affects compiler FLAGS and linking with specific library versions (debug |optimized | general). In our case external libraries reside in other ports and only install one version (no separate debug/optimized). Also, the ports system provide correct compiler flags (-g and no optimizations when WITH_DEBUG is used). Thus, cmake buildtypes only add extra compiler flags. Ports will be built correctly both by default and for WITH_DEBUG case. - Also, change WRKSRC to CONFIGURE_WRKSRC. (use CONFIGURE_WRKSRC for configure target instead of WRKSRC) PR: 126507 [1] Submitted by: amdmi3@ [1] Tested with: exp-run Thanks to: pav/amdmi3
Notes
Notes: svn path=/head/; revision=227174
-rw-r--r--Mk/bsd.cmake.mk15
-rw-r--r--devel/cmake/Makefile3
-rw-r--r--devel/cmake/distinfo6
-rw-r--r--devel/cmake/pkg-plist2
-rw-r--r--x11/qimageblitz/Makefile1
5 files changed, 12 insertions, 15 deletions
diff --git a/Mk/bsd.cmake.mk b/Mk/bsd.cmake.mk
index d663c5bd67d5..812642a27374 100644
--- a/Mk/bsd.cmake.mk
+++ b/Mk/bsd.cmake.mk
@@ -7,11 +7,9 @@
# Default: ${CONFIGURE_ENV}
# CMAKE_ARGS - Arguments passed to cmake
# Default: see below
-# CMAKE_USE_PTHREAD - Instruct cmake to use pthreads when
+# CMAKE_USE_PTHREAD - Instruct cmake to use pthreads when
# compiling/linking
# Default: not set
-# CMAKE_BUILD_TYPE - Type of build (release, debug)
-# Default: Release
# CMAKE_VERBOSE - Verbose build
# Default: not set
# CMAKE_SOURCE_PATH - Path to sourcedir for cmake
@@ -47,12 +45,11 @@ CMAKE_ARGS+= -DCMAKE_C_COMPILER:STRING="${CC}" \
-DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
-DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}" \
-DCMAKE_INSTALL_PREFIX:PATH="${CMAKE_INSTALL_PREFIX}" \
- -DCMAKE_BUILD_TYPE:STRING="${CMAKE_BUILD_TYPE}"
+ -DCMAKE_BUILD_TYPE:STRING=""
#
# Default build type and sourcedir
#
-CMAKE_BUILD_TYPE?= Release
CMAKE_SOURCE_PATH?= .
CMAKE_INSTALL_PREFIX?= ${PREFIX}
@@ -69,10 +66,10 @@ CMAKE_ARGS+= -DCMAKE_THREAD_LIBS:STRING="${PTHREAD_LIBS}" \
.endif
#
-# Force DEBUG buildtype if needed
+# Strip binaries
#
-.if defined(CMAKE_DEBUG) || defined(WITH_DEBUG)
-CMAKE_BUILD_TYPE=DEBUG
+.if !defined(WITH_DEBUG)
+CMAKE_ARGS+= -DCMAKE_INSTALL_DO_STRIP:BOOL=ON
.endif
#
@@ -87,6 +84,6 @@ CMAKE_ARGS+= -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON
#
.if !target(do-configure)
do-configure:
- @cd ${WRKSRC}; ${SETENV} ${CMAKE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} ${CMAKE_SOURCE_PATH}
+ @cd ${CONFIGURE_WRKSRC}; ${SETENV} ${CMAKE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} ${CMAKE_SOURCE_PATH}
.endif
diff --git a/devel/cmake/Makefile b/devel/cmake/Makefile
index 691dc4e0657f..e505ddef879f 100644
--- a/devel/cmake/Makefile
+++ b/devel/cmake/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= cmake
-PORTVERSION= 2.6.1
-PORTREVISION= 2
+PORTVERSION= 2.6.2
CATEGORIES= devel
MASTER_SITES= http://www.cmake.org/files/v${PORTVERSION:C/\.[[:digit:]]+$//}/ \
${MASTER_SITE_LOCAL}
diff --git a/devel/cmake/distinfo b/devel/cmake/distinfo
index 83ecb921c99a..61421e73b8a5 100644
--- a/devel/cmake/distinfo
+++ b/devel/cmake/distinfo
@@ -1,3 +1,3 @@
-MD5 (cmake-2.6.1.tar.gz) = 6717f4bc3cfcced4172ad98660ce7599
-SHA256 (cmake-2.6.1.tar.gz) = 2e0040fd2ecd4fbe29db0429eeeecd078f2f8b2bf0e5fafced209c32bea20d80
-SIZE (cmake-2.6.1.tar.gz) = 3518689
+MD5 (cmake-2.6.2.tar.gz) = 9e82aa3beb991aa8e5797cf330618d42
+SHA256 (cmake-2.6.2.tar.gz) = b3f5a9dfa97fb82cb1b7d78a62d949f93c8d4317af36674f337d27066fa6b7e9
+SIZE (cmake-2.6.2.tar.gz) = 3543548
diff --git a/devel/cmake/pkg-plist b/devel/cmake/pkg-plist
index 145ee9b0b944..6428a4bf369d 100644
--- a/devel/cmake/pkg-plist
+++ b/devel/cmake/pkg-plist
@@ -3,6 +3,7 @@ bin/cmake
bin/cpack
bin/ctest
%%DATADIR%%/Modules/AddFileDependencies.cmake
+%%DATADIR%%/Modules/BundleUtilities.cmake
%%DATADIR%%/Modules/CMake.cmake
%%DATADIR%%/Modules/CMakeASM-ATTInformation.cmake
%%DATADIR%%/Modules/CMakeASMCompiler.cmake.in
@@ -230,6 +231,7 @@ bin/ctest
%%DATADIR%%/Modules/InstallRequiredSystemLibraries.cmake
%%DATADIR%%/Modules/KDE3Macros.cmake
%%DATADIR%%/Modules/MacOSXBundleInfo.plist.in
+%%DATADIR%%/Modules/MacOSXFrameworkInfo.plist.in
%%DATADIR%%/Modules/MacroAddFileDependencies.cmake
%%DATADIR%%/Modules/NSIS.InstallOptions.ini.in
%%DATADIR%%/Modules/NSIS.template.in
diff --git a/x11/qimageblitz/Makefile b/x11/qimageblitz/Makefile
index 8efe0d60cf2a..fa9e8c3747cc 100644
--- a/x11/qimageblitz/Makefile
+++ b/x11/qimageblitz/Makefile
@@ -20,7 +20,6 @@ USE_LDCONFIG= yes
USE_QT_VER= 4
QT_COMPONENTS= gui qmake_build moc_build uic_build rcc_build
USE_CMAKE= yes
-CMAKE_DEBUG= yes
CMAKE_VERBOSE= yes
post-patch: