aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-08-03 00:39:51 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-09-20 14:35:01 +0000
commit18741dd85a2e8e88c89e2fcbaa7c71d48f4d3740 (patch)
tree571fba9e464020ea103c302987377776582b8db8
parent14af59f1879184d0c954536321ef797e743a4229 (diff)
downloadports-18741dd85a2e8e88c89e2fcbaa7c71d48f4d3740.tar.gz
ports-18741dd85a2e8e88c89e2fcbaa7c71d48f4d3740.zip
x11-wm/sway-devel: unbreak Rust-based clients after edd477c5e7a4
interface 'wl_surface' has no event 2 PR: 268810
-rw-r--r--audio/spotify-player/Makefile2
-rw-r--r--audio/spotify-player/files/patch-sctk15
-rw-r--r--games/jumpy/Makefile2
-rw-r--r--games/jumpy/files/patch-sctk15
-rw-r--r--games/punchy/Makefile2
-rw-r--r--games/punchy/files/patch-sctk15
-rw-r--r--games/veloren-weekly/Makefile2
-rw-r--r--games/veloren-weekly/files/patch-sctk15
-rw-r--r--misc/binocle/Makefile2
-rw-r--r--misc/binocle/files/patch-sctk15
-rw-r--r--net/sniffnet/Makefile2
-rw-r--r--net/sniffnet/files/patch-sctk15
-rw-r--r--security/gpg-tui/Makefile1
-rw-r--r--security/gpg-tui/files/patch-sctk15
-rw-r--r--x11/alacritty/Makefile2
-rw-r--r--x11/alacritty/files/patch-sctk15
-rw-r--r--x11/kickoff/Makefile2
-rw-r--r--x11/kickoff/files/patch-sctk25
-rw-r--r--x11/rio/Makefile1
-rw-r--r--x11/rio/files/patch-sctk15
-rw-r--r--x11/wezterm/Makefile2
-rw-r--r--x11/wezterm/files/patch-sctk15
22 files changed, 186 insertions, 9 deletions
diff --git a/audio/spotify-player/Makefile b/audio/spotify-player/Makefile
index c1a33a3db4a7..4403bb3f402b 100644
--- a/audio/spotify-player/Makefile
+++ b/audio/spotify-player/Makefile
@@ -1,7 +1,7 @@
PORTNAME= spotify-player
DISTVERSIONPREFIX= v
DISTVERSION= 0.10.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= audio
MAINTAINER= jfree@FreeBSD.org
diff --git a/audio/spotify-player/files/patch-sctk b/audio/spotify-player/files/patch-sctk
new file mode 100644
index 000000000000..9d2cabb1bcb0
--- /dev/null
+++ b/audio/spotify-player/files/patch-sctk
@@ -0,0 +1,15 @@
+Backport https://github.com/Smithay/client-toolkit/commit/5cfd95021c05
+to ignore wl_surface::Event::preferred_buffer_scale after
+https://invent.kde.org/plasma/kwin/-/commit/d2b0ed0c5a1e
+https://github.com/swaywm/sway/commit/fc16fb65491b
+
+--- cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs.orig 1970-01-01 00:00:00 UTC
++++ cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs
+@@ -283,6 +283,7 @@ impl<I: Interface + Clone + From<Proxy<I>> + AsRef<Pro
+ version: u32,
+ _: DispatchData,
+ ) {
++ let version = I::VERSION.min(version);
+ self.global = Some((*registry.bind::<I>(version, id)).clone())
+ }
+ fn get(&self) -> Option<Attached<I>> {
diff --git a/games/jumpy/Makefile b/games/jumpy/Makefile
index 89a7ec52f711..cc990f264e1d 100644
--- a/games/jumpy/Makefile
+++ b/games/jumpy/Makefile
@@ -1,7 +1,7 @@
PORTNAME= jumpy
DISTVERSIONPREFIX= v
DISTVERSION= 0.7.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games wayland
MAINTAINER= jbeich@FreeBSD.org
diff --git a/games/jumpy/files/patch-sctk b/games/jumpy/files/patch-sctk
new file mode 100644
index 000000000000..9d2cabb1bcb0
--- /dev/null
+++ b/games/jumpy/files/patch-sctk
@@ -0,0 +1,15 @@
+Backport https://github.com/Smithay/client-toolkit/commit/5cfd95021c05
+to ignore wl_surface::Event::preferred_buffer_scale after
+https://invent.kde.org/plasma/kwin/-/commit/d2b0ed0c5a1e
+https://github.com/swaywm/sway/commit/fc16fb65491b
+
+--- cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs.orig 1970-01-01 00:00:00 UTC
++++ cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs
+@@ -283,6 +283,7 @@ impl<I: Interface + Clone + From<Proxy<I>> + AsRef<Pro
+ version: u32,
+ _: DispatchData,
+ ) {
++ let version = I::VERSION.min(version);
+ self.global = Some((*registry.bind::<I>(version, id)).clone())
+ }
+ fn get(&self) -> Option<Attached<I>> {
diff --git a/games/punchy/Makefile b/games/punchy/Makefile
index 53e5de6f81c7..a0e796d7cc67 100644
--- a/games/punchy/Makefile
+++ b/games/punchy/Makefile
@@ -1,7 +1,7 @@
PORTNAME= punchy
DISTVERSIONPREFIX= v
DISTVERSION= 0.3.0
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= games wayland
MAINTAINER= jbeich@FreeBSD.org
diff --git a/games/punchy/files/patch-sctk b/games/punchy/files/patch-sctk
new file mode 100644
index 000000000000..9d2cabb1bcb0
--- /dev/null
+++ b/games/punchy/files/patch-sctk
@@ -0,0 +1,15 @@
+Backport https://github.com/Smithay/client-toolkit/commit/5cfd95021c05
+to ignore wl_surface::Event::preferred_buffer_scale after
+https://invent.kde.org/plasma/kwin/-/commit/d2b0ed0c5a1e
+https://github.com/swaywm/sway/commit/fc16fb65491b
+
+--- cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs.orig 1970-01-01 00:00:00 UTC
++++ cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs
+@@ -283,6 +283,7 @@ impl<I: Interface + Clone + From<Proxy<I>> + AsRef<Pro
+ version: u32,
+ _: DispatchData,
+ ) {
++ let version = I::VERSION.min(version);
+ self.global = Some((*registry.bind::<I>(version, id)).clone())
+ }
+ fn get(&self) -> Option<Attached<I>> {
diff --git a/games/veloren-weekly/Makefile b/games/veloren-weekly/Makefile
index 98d03dcd0cb6..c5ef4273ce25 100644
--- a/games/veloren-weekly/Makefile
+++ b/games/veloren-weekly/Makefile
@@ -1,6 +1,6 @@
PORTNAME= veloren
PORTVERSION= s20230913
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games wayland
PKGNAMESUFFIX= -weekly
diff --git a/games/veloren-weekly/files/patch-sctk b/games/veloren-weekly/files/patch-sctk
new file mode 100644
index 000000000000..9d2cabb1bcb0
--- /dev/null
+++ b/games/veloren-weekly/files/patch-sctk
@@ -0,0 +1,15 @@
+Backport https://github.com/Smithay/client-toolkit/commit/5cfd95021c05
+to ignore wl_surface::Event::preferred_buffer_scale after
+https://invent.kde.org/plasma/kwin/-/commit/d2b0ed0c5a1e
+https://github.com/swaywm/sway/commit/fc16fb65491b
+
+--- cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs.orig 1970-01-01 00:00:00 UTC
++++ cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs
+@@ -283,6 +283,7 @@ impl<I: Interface + Clone + From<Proxy<I>> + AsRef<Pro
+ version: u32,
+ _: DispatchData,
+ ) {
++ let version = I::VERSION.min(version);
+ self.global = Some((*registry.bind::<I>(version, id)).clone())
+ }
+ fn get(&self) -> Option<Attached<I>> {
diff --git a/misc/binocle/Makefile b/misc/binocle/Makefile
index 84f23fbde591..60d63fd7bad4 100644
--- a/misc/binocle/Makefile
+++ b/misc/binocle/Makefile
@@ -1,7 +1,7 @@
PORTNAME= binocle
DISTVERSIONPREFIX= v
DISTVERSION= 0.3.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= misc
MAINTAINER= yuri@FreeBSD.org
diff --git a/misc/binocle/files/patch-sctk b/misc/binocle/files/patch-sctk
new file mode 100644
index 000000000000..a9f0f1cbd59f
--- /dev/null
+++ b/misc/binocle/files/patch-sctk
@@ -0,0 +1,15 @@
+Backport https://github.com/Smithay/client-toolkit/commit/5cfd95021c05
+to ignore wl_surface::Event::preferred_buffer_scale after
+https://invent.kde.org/plasma/kwin/-/commit/d2b0ed0c5a1e
+https://github.com/swaywm/sway/commit/fc16fb65491b
+
+--- cargo-crates/smithay-client-toolkit-0.15.4/src/environment.rs.orig 1970-01-01 00:00:00 UTC
++++ cargo-crates/smithay-client-toolkit-0.15.4/src/environment.rs
+@@ -283,6 +283,7 @@ impl<I: Interface + Clone + From<Proxy<I>> + AsRef<Pro
+ version: u32,
+ _: DispatchData,
+ ) {
++ let version = I::VERSION.min(version);
+ self.global = Some((*registry.bind::<I>(version, id)).clone())
+ }
+ fn get(&self) -> Option<Attached<I>> {
diff --git a/net/sniffnet/Makefile b/net/sniffnet/Makefile
index 5129d8529c7b..900d76587fad 100644
--- a/net/sniffnet/Makefile
+++ b/net/sniffnet/Makefile
@@ -1,7 +1,7 @@
PORTNAME= sniffnet
DISTVERSIONPREFIX= v
DISTVERSION= 1.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MAINTAINER= tagattie@FreeBSD.org
diff --git a/net/sniffnet/files/patch-sctk b/net/sniffnet/files/patch-sctk
new file mode 100644
index 000000000000..9d2cabb1bcb0
--- /dev/null
+++ b/net/sniffnet/files/patch-sctk
@@ -0,0 +1,15 @@
+Backport https://github.com/Smithay/client-toolkit/commit/5cfd95021c05
+to ignore wl_surface::Event::preferred_buffer_scale after
+https://invent.kde.org/plasma/kwin/-/commit/d2b0ed0c5a1e
+https://github.com/swaywm/sway/commit/fc16fb65491b
+
+--- cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs.orig 1970-01-01 00:00:00 UTC
++++ cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs
+@@ -283,6 +283,7 @@ impl<I: Interface + Clone + From<Proxy<I>> + AsRef<Pro
+ version: u32,
+ _: DispatchData,
+ ) {
++ let version = I::VERSION.min(version);
+ self.global = Some((*registry.bind::<I>(version, id)).clone())
+ }
+ fn get(&self) -> Option<Attached<I>> {
diff --git a/security/gpg-tui/Makefile b/security/gpg-tui/Makefile
index 43a0d4b70077..c39953cb828b 100644
--- a/security/gpg-tui/Makefile
+++ b/security/gpg-tui/Makefile
@@ -1,6 +1,7 @@
PORTNAME= gpg-tui
DISTVERSIONPREFIX= v
DISTVERSION= 0.10.0
+PORTREVISION= 1
CATEGORIES= security
MAINTAINER= se@FreeBSD.org
diff --git a/security/gpg-tui/files/patch-sctk b/security/gpg-tui/files/patch-sctk
new file mode 100644
index 000000000000..9d2cabb1bcb0
--- /dev/null
+++ b/security/gpg-tui/files/patch-sctk
@@ -0,0 +1,15 @@
+Backport https://github.com/Smithay/client-toolkit/commit/5cfd95021c05
+to ignore wl_surface::Event::preferred_buffer_scale after
+https://invent.kde.org/plasma/kwin/-/commit/d2b0ed0c5a1e
+https://github.com/swaywm/sway/commit/fc16fb65491b
+
+--- cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs.orig 1970-01-01 00:00:00 UTC
++++ cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs
+@@ -283,6 +283,7 @@ impl<I: Interface + Clone + From<Proxy<I>> + AsRef<Pro
+ version: u32,
+ _: DispatchData,
+ ) {
++ let version = I::VERSION.min(version);
+ self.global = Some((*registry.bind::<I>(version, id)).clone())
+ }
+ fn get(&self) -> Option<Attached<I>> {
diff --git a/x11/alacritty/Makefile b/x11/alacritty/Makefile
index 942466461b4a..3d26e7f13795 100644
--- a/x11/alacritty/Makefile
+++ b/x11/alacritty/Makefile
@@ -1,7 +1,7 @@
PORTNAME= alacritty
DISTVERSIONPREFIX= v
DISTVERSION= 0.12.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 wayland
MAINTAINER= vishwin@FreeBSD.org
diff --git a/x11/alacritty/files/patch-sctk b/x11/alacritty/files/patch-sctk
new file mode 100644
index 000000000000..9d2cabb1bcb0
--- /dev/null
+++ b/x11/alacritty/files/patch-sctk
@@ -0,0 +1,15 @@
+Backport https://github.com/Smithay/client-toolkit/commit/5cfd95021c05
+to ignore wl_surface::Event::preferred_buffer_scale after
+https://invent.kde.org/plasma/kwin/-/commit/d2b0ed0c5a1e
+https://github.com/swaywm/sway/commit/fc16fb65491b
+
+--- cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs.orig 1970-01-01 00:00:00 UTC
++++ cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs
+@@ -283,6 +283,7 @@ impl<I: Interface + Clone + From<Proxy<I>> + AsRef<Pro
+ version: u32,
+ _: DispatchData,
+ ) {
++ let version = I::VERSION.min(version);
+ self.global = Some((*registry.bind::<I>(version, id)).clone())
+ }
+ fn get(&self) -> Option<Attached<I>> {
diff --git a/x11/kickoff/Makefile b/x11/kickoff/Makefile
index 950059c67d02..28417b2ae274 100644
--- a/x11/kickoff/Makefile
+++ b/x11/kickoff/Makefile
@@ -1,7 +1,7 @@
PORTNAME= kickoff
DISTVERSIONPREFIX= v
DISTVERSION= 0.7.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11 wayland
MAINTAINER= ports@FreeBSD.org
diff --git a/x11/kickoff/files/patch-sctk b/x11/kickoff/files/patch-sctk
new file mode 100644
index 000000000000..ed5aa00e138b
--- /dev/null
+++ b/x11/kickoff/files/patch-sctk
@@ -0,0 +1,25 @@
+Backport https://github.com/Smithay/client-toolkit/commit/5cfd95021c05
+to ignore wl_surface::Event::preferred_buffer_scale after
+https://invent.kde.org/plasma/kwin/-/commit/d2b0ed0c5a1e
+https://github.com/swaywm/sway/commit/fc16fb65491b
+
+--- cargo-crates/smithay-client-toolkit-0.15.4/src/environment.rs.orig 1970-01-01 00:00:00 UTC
++++ cargo-crates/smithay-client-toolkit-0.15.4/src/environment.rs
+@@ -283,6 +283,7 @@ impl<I: Interface + Clone + From<Proxy<I>> + AsRef<Pro
+ version: u32,
+ _: DispatchData,
+ ) {
++ let version = I::VERSION.min(version);
+ self.global = Some((*registry.bind::<I>(version, id)).clone())
+ }
+ fn get(&self) -> Option<Attached<I>> {
+--- cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs.orig 1970-01-01 00:00:00 UTC
++++ cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs
+@@ -283,6 +283,7 @@ impl<I: Interface + Clone + From<Proxy<I>> + AsRef<Pro
+ version: u32,
+ _: DispatchData,
+ ) {
++ let version = I::VERSION.min(version);
+ self.global = Some((*registry.bind::<I>(version, id)).clone())
+ }
+ fn get(&self) -> Option<Attached<I>> {
diff --git a/x11/rio/Makefile b/x11/rio/Makefile
index 2a6f239c6b21..b42395feae90 100644
--- a/x11/rio/Makefile
+++ b/x11/rio/Makefile
@@ -1,6 +1,7 @@
PORTNAME= rio
DISTVERSIONPREFIX= v
DISTVERSION= 0.0.19
+PORTREVISION= 1
CATEGORIES= x11
PKGNAMESUFFIX= -terminal-emulator
diff --git a/x11/rio/files/patch-sctk b/x11/rio/files/patch-sctk
new file mode 100644
index 000000000000..9d2cabb1bcb0
--- /dev/null
+++ b/x11/rio/files/patch-sctk
@@ -0,0 +1,15 @@
+Backport https://github.com/Smithay/client-toolkit/commit/5cfd95021c05
+to ignore wl_surface::Event::preferred_buffer_scale after
+https://invent.kde.org/plasma/kwin/-/commit/d2b0ed0c5a1e
+https://github.com/swaywm/sway/commit/fc16fb65491b
+
+--- cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs.orig 1970-01-01 00:00:00 UTC
++++ cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs
+@@ -283,6 +283,7 @@ impl<I: Interface + Clone + From<Proxy<I>> + AsRef<Pro
+ version: u32,
+ _: DispatchData,
+ ) {
++ let version = I::VERSION.min(version);
+ self.global = Some((*registry.bind::<I>(version, id)).clone())
+ }
+ fn get(&self) -> Option<Attached<I>> {
diff --git a/x11/wezterm/Makefile b/x11/wezterm/Makefile
index 10a0f8d7e63c..c439afa52755 100644
--- a/x11/wezterm/Makefile
+++ b/x11/wezterm/Makefile
@@ -1,6 +1,6 @@
PORTNAME= wezterm
DISTVERSION= 20230408-112425-69ae8472
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11 wayland
MAINTAINER= ports@FreeBSD.org
diff --git a/x11/wezterm/files/patch-sctk b/x11/wezterm/files/patch-sctk
new file mode 100644
index 000000000000..9d2cabb1bcb0
--- /dev/null
+++ b/x11/wezterm/files/patch-sctk
@@ -0,0 +1,15 @@
+Backport https://github.com/Smithay/client-toolkit/commit/5cfd95021c05
+to ignore wl_surface::Event::preferred_buffer_scale after
+https://invent.kde.org/plasma/kwin/-/commit/d2b0ed0c5a1e
+https://github.com/swaywm/sway/commit/fc16fb65491b
+
+--- cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs.orig 1970-01-01 00:00:00 UTC
++++ cargo-crates/smithay-client-toolkit-0.16.0/src/environment.rs
+@@ -283,6 +283,7 @@ impl<I: Interface + Clone + From<Proxy<I>> + AsRef<Pro
+ version: u32,
+ _: DispatchData,
+ ) {
++ let version = I::VERSION.min(version);
+ self.global = Some((*registry.bind::<I>(version, id)).clone())
+ }
+ fn get(&self) -> Option<Attached<I>> {