aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Branco <rbranco@suse.de>2024-04-26 19:44:26 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2024-04-29 04:11:05 +0000
commit188a62cbfecb9d70e4f6ab0ce419c681ffde80c1 (patch)
tree65b95d377112042fc04816bda9361ff001a04a1b
parentab480990aa3ddc96b5be7cde7995671ef2c88e49 (diff)
downloadports-188a62cbfecb9d70e4f6ab0ce419c681ffde80c1.tar.gz
ports-188a62cbfecb9d70e4f6ab0ce419c681ffde80c1.zip
devel/py-python-bugzilla: Fix for API key leak
Fixes https://github.com/python-bugzilla/python-bugzilla/issues/187 PR: 278612 MFH: 2024Q2 Pull Request: https://github.com/freebsd/freebsd-ports/pull/253 (cherry picked from commit e199513d74a5585e71a2aa278fc495f1ce3c41fe)
-rw-r--r--devel/py-python-bugzilla/Makefile1
-rw-r--r--devel/py-python-bugzilla/files/patch-bugzilla___session.py23
2 files changed, 24 insertions, 0 deletions
diff --git a/devel/py-python-bugzilla/Makefile b/devel/py-python-bugzilla/Makefile
index 42db2a632006..35eb957c3a9d 100644
--- a/devel/py-python-bugzilla/Makefile
+++ b/devel/py-python-bugzilla/Makefile
@@ -1,5 +1,6 @@
PORTNAME= python-bugzilla
PORTVERSION= 3.2.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/devel/py-python-bugzilla/files/patch-bugzilla___session.py b/devel/py-python-bugzilla/files/patch-bugzilla___session.py
new file mode 100644
index 000000000000..bf9849a0eef2
--- /dev/null
+++ b/devel/py-python-bugzilla/files/patch-bugzilla___session.py
@@ -0,0 +1,23 @@
+--- bugzilla/_session.py
++++ bugzilla/_session.py
+@@ -98,14 +98,14 @@ def request(self, *args, **kwargs):
+ if "timeout" not in kwargs:
+ kwargs["timeout"] = timeout
+
+- response = self._session.request(*args, **kwargs)
++ try:
++ response = self._session.request(*args, **kwargs)
+
+- if self._is_xmlrpc:
+- # Yes this still appears to matter for properly decoding unicode
+- # code points in bugzilla.redhat.com content
+- response.encoding = "UTF-8"
++ if self._is_xmlrpc:
++ # This still appears to matter for properly decoding unicode
++ # code points in bugzilla.redhat.com content
++ response.encoding = "UTF-8"
+
+- try:
+ response.raise_for_status()
+ except requests.HTTPError as e:
+ # Scrape the api key out of the returned exception string