aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-23 14:18:14 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-23 14:30:40 +0000
commit18b6f9d163b303aa6b3590117308ba6b35714285 (patch)
tree4ea0c0e0d0b10d6b5ad56306e2a8c44cb0cf1b8c
parent143075b45c772f5bc65271d7c4b6d0490e6a18e0 (diff)
downloadports-18b6f9d163b303aa6b3590117308ba6b35714285.tar.gz
ports-18b6f9d163b303aa6b3590117308ba6b35714285.zip
devel/grpc: Update to 1.62.1
-rw-r--r--devel/grpc/Makefile6
-rw-r--r--devel/grpc/distinfo10
-rw-r--r--devel/grpc/files/patch-CMakeLists.txt11
-rw-r--r--devel/grpc/files/patch-src-core-lib-surface-wait_for_cq_end_op.cc10
4 files changed, 24 insertions, 13 deletions
diff --git a/devel/grpc/Makefile b/devel/grpc/Makefile
index abf15c039727..a1e74f9bd53d 100644
--- a/devel/grpc/Makefile
+++ b/devel/grpc/Makefile
@@ -1,5 +1,5 @@
PORTNAME= grpc
-PORTVERSION= 1.62.0
+PORTVERSION= 1.62.1
DISTVERSIONPREFIX= v
PORTEPOCH= 2
CATEGORIES= devel
@@ -19,11 +19,11 @@ LIB_DEPENDS= libabsl_base.so:devel/abseil \
libprotobuf.so:devel/protobuf \
libre2.so:devel/re2
-USES= cmake compiler:c++17-lang cpe localbase:ldflags pathfix pkgconfig ssl
+USES= cmake compiler:c++17-lang cpe localbase:ldflags pkgconfig ssl
USE_GITHUB= yes
GH_TUPLE= census-instrumentation:opencensus-proto:v0.4.1:census_instrumentation_opencensus_proto/third_party/opencensus-proto/src \
- cncf:xds:0fa0005:cncf_xds/third_party/xds
+ cncf:xds:91a88dc:cncf_xds/third_party/xds
CMAKE_ARGS= -DCMAKE_CXX_STANDARD=17 \
-DgRPC_ABSL_PROVIDER=package \
diff --git a/devel/grpc/distinfo b/devel/grpc/distinfo
index 550e84606b84..8f1016bdb7a6 100644
--- a/devel/grpc/distinfo
+++ b/devel/grpc/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1709390362
-SHA256 (grpc-grpc-v1.62.0_GH0.tar.gz) = f40bde4ce2f31760f65dc49a2f50876f59077026494e67dccf23992548b1b04f
-SIZE (grpc-grpc-v1.62.0_GH0.tar.gz) = 22383594
+TIMESTAMP = 1710712318
+SHA256 (grpc-grpc-v1.62.1_GH0.tar.gz) = c9f9ae6e4d6f40464ee9958be4068087881ed6aa37e30d0e64d40ed7be39dd01
+SIZE (grpc-grpc-v1.62.1_GH0.tar.gz) = 22384671
SHA256 (census-instrumentation-opencensus-proto-v0.4.1_GH0.tar.gz) = e3d89f7f9ed84c9b6eee818c2e9306950519402bf803698b15c310b77ca2f0f3
SIZE (census-instrumentation-opencensus-proto-v0.4.1_GH0.tar.gz) = 164379
-SHA256 (cncf-xds-0fa0005_GH0.tar.gz) = bb9e05e048ef35335b70f8c4038e47c0a5586122108738e2bd82f18b57d59885
-SIZE (cncf-xds-0fa0005_GH0.tar.gz) = 105778
+SHA256 (cncf-xds-91a88dc_GH0.tar.gz) = 6aed44b321ea07bdf62a4a9c2860b5c49907ee44509d191fff8aadd9c9535324
+SIZE (cncf-xds-91a88dc_GH0.tar.gz) = 113935
diff --git a/devel/grpc/files/patch-CMakeLists.txt b/devel/grpc/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..da8424a3320c
--- /dev/null
+++ b/devel/grpc/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2024-03-08 01:33:47 UTC
++++ CMakeLists.txt
+@@ -36178,7 +36178,7 @@ function(generate_pkgconfig name description version r
+ "${output_filepath}"
+ @ONLY)
+ install(FILES "${output_filepath}"
+- DESTINATION "${gRPC_INSTALL_LIBDIR}/pkgconfig")
++ DESTINATION "libdata/pkgconfig")
+ endfunction()
+
+ # gpr .pc file
diff --git a/devel/grpc/files/patch-src-core-lib-surface-wait_for_cq_end_op.cc b/devel/grpc/files/patch-src-core-lib-surface-wait_for_cq_end_op.cc
index 2d232ae338a3..fe71b1d50e39 100644
--- a/devel/grpc/files/patch-src-core-lib-surface-wait_for_cq_end_op.cc
+++ b/devel/grpc/files/patch-src-core-lib-surface-wait_for_cq_end_op.cc
@@ -1,13 +1,13 @@
---- src/core/lib/surface/wait_for_cq_end_op.cc.orig 2024-02-20 20:23:19 UTC
+--- src/core/lib/surface/wait_for_cq_end_op.cc.orig 2024-03-08 01:33:47 UTC
+++ src/core/lib/surface/wait_for_cq_end_op.cc
-@@ -14,6 +14,7 @@
+@@ -12,6 +12,7 @@
+ // See the License for the specific language governing permissions and
+ // limitations under the License.
++#include <absl/strings/str_format.h>
#include <grpc/support/port_platform.h>
-+#include "absl/strings/str_format.h"
#include "src/core/lib/surface/wait_for_cq_end_op.h"
-
- #include <atomic>
@@ -72,4 +73,4 @@ std::string WaitForCqEndOp::StateString(const State& s
[](const Invalid&) -> std::string { return "Invalid{}"; });
}