aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-11-23 05:55:47 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-11-23 08:15:37 +0000
commit18d435c1e3c253c2d10e08b4b5878504c46b43e7 (patch)
treee780ddfe0e30fcfe6de1f084cdec612e49392b4f
parent396d79ca69de656f10aed6eeab092ce37293fb76 (diff)
graphics/libjxl: enable AVX512 runtime detection (amd64-only)
Upstream default is optimized for bundling or Linux-style micro-packages. FreeBSD currently doesn't split docs/headers/plugins, so minor binary size increase (7 MiB -> 9 MiB) is less important. FreeBSD is primarily used on servers where AVX512 is more common while on old desktops libjxl bloat is dwarfed by many other packages (e.g., firefox, llvm*, gcc*, boost-libs). See also https://github.com/libjxl/libjxl/pull/2627#issuecomment-1618237136
-rw-r--r--graphics/libjxl/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/graphics/libjxl/Makefile b/graphics/libjxl/Makefile
index 1ea90da38987..ee421b0d625b 100644
--- a/graphics/libjxl/Makefile
+++ b/graphics/libjxl/Makefile
@@ -1,7 +1,7 @@
PORTNAME= libjxl
DISTVERSIONPREFIX= v
DISTVERSION= 0.11.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MAINTAINER= jbeich@FreeBSD.org
@@ -23,6 +23,7 @@ GH_TUPLE= libjxl:testdata:ff8d743:testdata/testdata \
webmproject:sjpeg:e5ab130:sjpeg/third_party/sjpeg \
${NULL}
CMAKE_ON= JPEGXL_ENABLE_PLUGINS
+CMAKE_ON+= ${AVX512 AVX512_SPR AVX512_ZEN4:L:S/^/JPEGXL_ENABLE_/}
CMAKE_OFF= ${BENCHMARK FUZZERS TCMALLOC:L:S/^/JPEGXL_ENABLE_/}
CMAKE_OFF+= ${OpenGL GLUT:L:S/^/CMAKE_DISABLE_FIND_PACKAGE_/} # sjpeg
CMAKE_OFF+= ${CMAKE_TESTING_ON}