aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-08-05 01:10:27 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-08-05 01:10:27 +0000
commit18d608442484b42f25b68aa98b1b23ffc628f26e (patch)
treedee52940a4b264e7eb4f497382027160ec9f4188
parenta25f6777312ab415fe8ce796d983c4c50d55b450 (diff)
downloadports-18d608442484b42f25b68aa98b1b23ffc628f26e.tar.gz
ports-18d608442484b42f25b68aa98b1b23ffc628f26e.zip
- p5-podlators and p5-PodParser conflict with perl 5.6 or above.
They should be conditional dependency when PERL_LEVEL < 500601. - add "CONFLICTS= perl-5.6.* perl-5.8.*" in p5-podlators and p5-PodParser PR: 68086 Submitted by: leeym Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=115432
-rw-r--r--textproc/p5-Pod-Constants/Makefile14
-rw-r--r--textproc/p5-Pod-Parser/Makefile9
-rw-r--r--textproc/p5-Pod-Stripper/Makefile17
-rw-r--r--textproc/p5-PodParser/Makefile9
-rw-r--r--textproc/p5-podlators/Makefile7
5 files changed, 34 insertions, 22 deletions
diff --git a/textproc/p5-Pod-Constants/Makefile b/textproc/p5-Pod-Constants/Makefile
index 11349801f60b..131c67581f23 100644
--- a/textproc/p5-Pod-Constants/Makefile
+++ b/textproc/p5-Pod-Constants/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Pod-Constants
PORTVERSION= 0.15
+PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../../authors/id/S/SA/SAMV
@@ -15,12 +16,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Include constants from POD
-BUILD_DEPENDS= ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MAN3= Pod::Constants.3
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+BUILD_DEPENDS+= ${SITE_PERL}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-PodParser
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Pod-Parser/Makefile b/textproc/p5-Pod-Parser/Makefile
index 85cb67c4ecbf..e4fc220ae6be 100644
--- a/textproc/p5-Pod-Parser/Makefile
+++ b/textproc/p5-Pod-Parser/Makefile
@@ -16,13 +16,14 @@ MAINTAINER= skv@FreeBSD.org
COMMENT= Modules to work with POD (Plain Old Documentation)
PERL_CONFIGURE= yes
-CONFIGURE_ARGS+= INSTALLDIRS="site"
+CONFIGURE_ARGS= INSTALLDIRS="site"
MAN1= pod2usage.1 podchecker.1 podselect.1
MAN3= Pod::Checker.3 Pod::Find.3 Pod::InputObjects.3 \
Pod::ParseUtils.3 Pod::Parser.3 Pod::PlainText.3 Pod::Select.3 \
Pod::Usage.3
-MAN1PREFIX= ${PREFIX}
+
+CONFLICTS= perl-5.6.* perl-5.8.*
post-patch:
@${FIND} ${WRKSRC} -name \*.orig -exec ${RM} {} \;
@@ -30,8 +31,8 @@ post-patch:
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS+= ${BUILD_DEPENDS}
.endif
.include <bsd.port.post.mk>
diff --git a/textproc/p5-Pod-Stripper/Makefile b/textproc/p5-Pod-Stripper/Makefile
index 39e2e9844094..d684b7c8e74a 100644
--- a/textproc/p5-Pod-Stripper/Makefile
+++ b/textproc/p5-Pod-Stripper/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Pod-Stripper
PORTVERSION= 0.22
+PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Pod
@@ -15,17 +16,21 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Strip all pod, and output what's left
-BUILD_DEPENDS= ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
-CONFIGURE_ARGS+= INSTALLDIRS="site"
+CONFIGURE_ARGS= INSTALLDIRS="site"
MAN1= podstrip.1
MAN3= Pod::Stripper.3
-MAN1PREFIX= ${PREFIX}
post-patch:
@${FIND} ${WRKSRC} -type f|${XARGS} ${PERL} -pi -e 's/\x0d(?=\x0a)//;'
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+BUILD_DEPENDS+= ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-PodParser/Makefile b/textproc/p5-PodParser/Makefile
index 85cb67c4ecbf..e4fc220ae6be 100644
--- a/textproc/p5-PodParser/Makefile
+++ b/textproc/p5-PodParser/Makefile
@@ -16,13 +16,14 @@ MAINTAINER= skv@FreeBSD.org
COMMENT= Modules to work with POD (Plain Old Documentation)
PERL_CONFIGURE= yes
-CONFIGURE_ARGS+= INSTALLDIRS="site"
+CONFIGURE_ARGS= INSTALLDIRS="site"
MAN1= pod2usage.1 podchecker.1 podselect.1
MAN3= Pod::Checker.3 Pod::Find.3 Pod::InputObjects.3 \
Pod::ParseUtils.3 Pod::Parser.3 Pod::PlainText.3 Pod::Select.3 \
Pod::Usage.3
-MAN1PREFIX= ${PREFIX}
+
+CONFLICTS= perl-5.6.* perl-5.8.*
post-patch:
@${FIND} ${WRKSRC} -name \*.orig -exec ${RM} {} \;
@@ -30,8 +31,8 @@ post-patch:
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS+= ${BUILD_DEPENDS}
.endif
.include <bsd.port.post.mk>
diff --git a/textproc/p5-podlators/Makefile b/textproc/p5-podlators/Makefile
index e6b80d545934..11758ac3cfe6 100644
--- a/textproc/p5-podlators/Makefile
+++ b/textproc/p5-podlators/Makefile
@@ -7,6 +7,7 @@
PORTNAME= podlators
PORTVERSION= 1.27
+PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Pod
@@ -15,9 +16,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Modules to convert and parse POD (Plain Old Documentation)
-RUN_DEPENDS= ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
-BUILD_DEPENDS= ${RUN_DEPENDS}
-
PERL_CONFIGURE= yes
CONFIGURE_ARGS= INSTALLDIRS=site
@@ -25,10 +23,13 @@ MAN1= pod2man.1 pod2text.1
MAN3= Pod::Man.3 Pod::ParseLink.3 Pod::Text.3 Pod::Text::Color.3 \
Pod::Text::Overstrike.3 Pod::Text::Termcap.3
+CONFLICTS= perl-5.6.* perl-5.8.*
+
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500601
RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
+ ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser \
${SITE_PERL}/Term/ANSIColor.pm:${PORTSDIR}/devel/p5-Term-ANSIColor
.endif