aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChrister Edwards <christer.edwards@gmail.com>2022-02-13 19:36:49 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2022-02-13 19:43:33 +0000
commit18e98e507f2de378c62668b003827c4cacb01ed7 (patch)
treec422db406b7239008e1967651c332eac9c31a09b
parentfac8a211bfa41f0b8dfe18771ea0e159f83b3690 (diff)
downloadports-18e98e507f2de378c62668b003827c4cacb01ed7.tar.gz
ports-18e98e507f2de378c62668b003827c4cacb01ed7.zip
sysutils/rocinante: New port: A lightweight configuration management software
A lightweight configuration management software that makes Bastille templates compatible with host automation. WWW: https://github.com/bastillebsd/rocinante PR: 260712
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/rocinante/Makefile29
-rw-r--r--sysutils/rocinante/distinfo3
-rw-r--r--sysutils/rocinante/pkg-descr4
-rw-r--r--sysutils/rocinante/pkg-plist18
5 files changed, 55 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index d6f04fec98ef..ee9f71b5f243 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1138,6 +1138,7 @@
SUBDIR += rhc
SUBDIR += rinse
SUBDIR += rmlint
+ SUBDIR += rocinante
SUBDIR += rocr
SUBDIR += roct
SUBDIR += root-tail
diff --git a/sysutils/rocinante/Makefile b/sysutils/rocinante/Makefile
new file mode 100644
index 000000000000..0081a29f8936
--- /dev/null
+++ b/sysutils/rocinante/Makefile
@@ -0,0 +1,29 @@
+# Created by: Christer Edwards <christer.edwards@gmail.com>
+
+PORTNAME= rocinante
+DISTVERSION= 0.1.20211225
+CATEGORIES= sysutils
+
+MAINTAINER= christer.edwards@gmail.com
+COMMENT= Rocinante is a lightweight configuration management software
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= bastillebsd
+GH_TAGNAME= 81a4898
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PREFIX}/bin/rocinante ${STAGEDIR}${PREFIX}/bin
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}
+ (cd ${WRKSRC}/${PREFIX}/libexec/${PORTNAME} && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/libexec/${PORTNAME})
+ ${INSTALL_DATA} ${WRKSRC}${PREFIX}/etc/rocinante.conf ${STAGEDIR}${PREFIX}/etc/rocinante.conf.sample
+
+.include <bsd.port.mk>
diff --git a/sysutils/rocinante/distinfo b/sysutils/rocinante/distinfo
new file mode 100644
index 000000000000..5178751c891e
--- /dev/null
+++ b/sysutils/rocinante/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1640409059
+SHA256 (bastillebsd-rocinante-0.1.20211225-81a4898_GH0.tar.gz) = ca0cbb90f45ce3642202c4a4b07e35121254a86052b937d4cd52a07f29525cb2
+SIZE (bastillebsd-rocinante-0.1.20211225-81a4898_GH0.tar.gz) = 9901
diff --git a/sysutils/rocinante/pkg-descr b/sysutils/rocinante/pkg-descr
new file mode 100644
index 000000000000..52329a49b051
--- /dev/null
+++ b/sysutils/rocinante/pkg-descr
@@ -0,0 +1,4 @@
+Rocinante is lightweight configuration management software
+compatible with Bastille templates.
+
+WWW: https://github.com/bastillebsd/rocinante
diff --git a/sysutils/rocinante/pkg-plist b/sysutils/rocinante/pkg-plist
new file mode 100644
index 000000000000..992b42a91ff6
--- /dev/null
+++ b/sysutils/rocinante/pkg-plist
@@ -0,0 +1,18 @@
+bin/rocinante
+@sample %%ETCDIR%%.conf.sample
+libexec/rocinante/bootstrap.sh
+libexec/rocinante/cmd.sh
+libexec/rocinante/common.sh
+libexec/rocinante/cp.sh
+libexec/rocinante/limits.sh
+libexec/rocinante/list.sh
+libexec/rocinante/pkg.sh
+libexec/rocinante/service.sh
+libexec/rocinante/sysctl.sh
+libexec/rocinante/sysrc.sh
+libexec/rocinante/template.sh
+libexec/rocinante/update.sh
+libexec/rocinante/upgrade.sh
+libexec/rocinante/verify.sh
+libexec/rocinante/zfs.sh
+libexec/rocinante/zpool.sh