aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2002-11-08 23:03:48 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2002-11-08 23:03:48 +0000
commit197dfc33216bbe1cfed7595fc5d1390963c330fd (patch)
tree1e1f9905bb0dacd75342f58ad7a3cc222554e8d1
parent8fe52170fabf7e974027f6e33d85c2494ec84c5b (diff)
downloadports-197dfc33216bbe1cfed7595fc5d1390963c330fd.tar.gz
ports-197dfc33216bbe1cfed7595fc5d1390963c330fd.zip
lang/fpc needed perl to complete its install, the others are renaming
of PERL to REINPLACE_CMD Noticed on: bento
Notes
Notes: svn path=/head/; revision=69762
-rw-r--r--devel/mingw-gcc/Makefile3
-rw-r--r--devel/mingw32-gcc/Makefile3
-rw-r--r--graphics/linplasma/Makefile5
-rw-r--r--lang/fpc-devel/Makefile1
-rw-r--r--lang/fpc/Makefile1
-rw-r--r--sysutils/msyslog/Makefile5
-rw-r--r--www/wb0/Makefile3
7 files changed, 14 insertions, 7 deletions
diff --git a/devel/mingw-gcc/Makefile b/devel/mingw-gcc/Makefile
index c7b11af8a523..1fc55c0e5e93 100644
--- a/devel/mingw-gcc/Makefile
+++ b/devel/mingw-gcc/Makefile
@@ -26,6 +26,7 @@ RUN_DEPENDS= ${LOCALBASE}/i386-mingw32msvc/bin/as:${PORTSDIR}/devel/mingw-binuti
WRKSRC= ${WRKDIR}/gcc-${PORTVERSION}-20010828
USE_GMAKE= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target=i386-mingw32msvc \
--with-gxx-include-dir=${PREFIX}/lib/gcc-lib/i386-mingw32msvc/${PORTVERSION}/include/g++
@@ -38,7 +39,7 @@ MAN1= cccp.1 \
i386-mingw32msvc-gcc.1
post-patch:
- ${PERL} -i.orig -pe 's/install-libiberty//' ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e 's/install-libiberty//' ${WRKSRC}/Makefile.in
pre-install:
${MV} ${PREFIX}/bin/i386-mingw32msvc-c++filt \
diff --git a/devel/mingw32-gcc/Makefile b/devel/mingw32-gcc/Makefile
index c7b11af8a523..1fc55c0e5e93 100644
--- a/devel/mingw32-gcc/Makefile
+++ b/devel/mingw32-gcc/Makefile
@@ -26,6 +26,7 @@ RUN_DEPENDS= ${LOCALBASE}/i386-mingw32msvc/bin/as:${PORTSDIR}/devel/mingw-binuti
WRKSRC= ${WRKDIR}/gcc-${PORTVERSION}-20010828
USE_GMAKE= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target=i386-mingw32msvc \
--with-gxx-include-dir=${PREFIX}/lib/gcc-lib/i386-mingw32msvc/${PORTVERSION}/include/g++
@@ -38,7 +39,7 @@ MAN1= cccp.1 \
i386-mingw32msvc-gcc.1
post-patch:
- ${PERL} -i.orig -pe 's/install-libiberty//' ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e 's/install-libiberty//' ${WRKSRC}/Makefile.in
pre-install:
${MV} ${PREFIX}/bin/i386-mingw32msvc-c++filt \
diff --git a/graphics/linplasma/Makefile b/graphics/linplasma/Makefile
index 6bb40df9f7e7..e27647566463 100644
--- a/graphics/linplasma/Makefile
+++ b/graphics/linplasma/Makefile
@@ -20,10 +20,11 @@ DOCFILES= README GPL
DOCDIR= share/doc/${PORTNAME}/
PLIST= ${WRKDIR}/pkg-plist
WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_REINPLACE= yes
post-patch:
- @${PERL} -pi -e "s:%%PREFIX%%:${PREFIX}:g" ${WRKSRC}/Makefile
- @${PERL} -pi -e "s:PI:M_PI:g" ${WRKSRC}/linplasma.c
+ @${REINPLACE_CMD} -e "s:%%PREFIX%%:${PREFIX}:g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s:PI:M_PI:g" ${WRKSRC}/linplasma.c
pre-install:
${ECHO_CMD} "bin/linplasma" > ${PLIST}
diff --git a/lang/fpc-devel/Makefile b/lang/fpc-devel/Makefile
index 9b8ffbe58212..c2bef8a6968c 100644
--- a/lang/fpc-devel/Makefile
+++ b/lang/fpc-devel/Makefile
@@ -30,6 +30,7 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/acroread4:${PORTSDIR}/print/acroread4
ONLY_FOR_ARCHS= i386
NO_WRKSUBDIR= yes
NO_BUILD= yes
+USE_PERL5= yes
PKGDEINSTALL= ${PKGINSTALL}
MAN1= delp.1 fpc.1 fpcmake.1 h2pas.1 plex.1 ppc386.1 ppdep.1 \
diff --git a/lang/fpc/Makefile b/lang/fpc/Makefile
index 9b8ffbe58212..c2bef8a6968c 100644
--- a/lang/fpc/Makefile
+++ b/lang/fpc/Makefile
@@ -30,6 +30,7 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/acroread4:${PORTSDIR}/print/acroread4
ONLY_FOR_ARCHS= i386
NO_WRKSUBDIR= yes
NO_BUILD= yes
+USE_PERL5= yes
PKGDEINSTALL= ${PKGINSTALL}
MAN1= delp.1 fpc.1 fpcmake.1 h2pas.1 plex.1 ppc386.1 ppdep.1 \
diff --git a/sysutils/msyslog/Makefile b/sysutils/msyslog/Makefile
index ee973d705098..fc1f995ba79c 100644
--- a/sysutils/msyslog/Makefile
+++ b/sysutils/msyslog/Makefile
@@ -26,6 +26,7 @@ LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
#USE_AUTOCONF_VER= 252 # not yet
AUTOCONF= ${LOCALBASE}/bin/autoconf
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
.if !defined(WITH_MYSQL)
CONFIGURE_ARGS+= --without-mysql
@@ -56,8 +57,8 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
pre-patch:
.for f in ${FIXPREFIX}
- ${PERL} -pi -e "s|/etc/syslog.conf|${PREFIX}/etc/syslog.conf|g" \
- ${WRKSRC}/${f}
+ ${REINPLACE_CMD} -e "s|/etc/syslog.conf|${PREFIX}/etc/syslog.conf|g" \
+ ${WRKSRC}/${f}
.endfor
pre-configure:
diff --git a/www/wb0/Makefile b/www/wb0/Makefile
index c8623eefb83c..e242b053a94f 100644
--- a/www/wb0/Makefile
+++ b/www/wb0/Makefile
@@ -21,9 +21,10 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
DOCDIR= share/doc/${PORTNAME}
DOCS= AUTHORS Changelog README
PLIST= ${WRKDIR}/pkg-plist
+USE_REINPLACE= yes
post-patch:
- ${PERL} -pi -e 's|/etc/wb0|${LOCALBASE}/etc|g ; \
+ ${REINPLACE_CMD} -e 's|/etc/wb0|${LOCALBASE}/etc|g ; \
s|/usr/local/src/wb0/font/bit|${LOCALBASE}/share/wb0/|g' \
${WRKSRC}/wb0.c