aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-08-06 12:43:41 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-08-06 14:09:30 +0000
commit197e928ffb54ae1da12fdda26dc45a8713409730 (patch)
tree4ab885b05a898a0fa262ad0346e69945b373a5ad
parentb69b6e55f09ddc759b3fc8b9a9275c3a19a817bb (diff)
downloadports-197e928ffb54ae1da12fdda26dc45a8713409730.tar.gz
ports-197e928ffb54ae1da12fdda26dc45a8713409730.zip
games/critterding: prepare for freetype2 update
- freetype2 will no longer ship freetype-config (which was a pkg-config wrapper) in the near future -- use pkg-config to gather the required flags. - while here, convert to USES=localbase PR: 251512
-rw-r--r--games/critterding/Makefile6
-rw-r--r--games/critterding/files/patch-configure.in24
2 files changed, 27 insertions, 3 deletions
diff --git a/games/critterding/Makefile b/games/critterding/Makefile
index a54a8b802a0e..01d9796d3beb 100644
--- a/games/critterding/Makefile
+++ b/games/critterding/Makefile
@@ -9,12 +9,10 @@ COMMENT= Evolving Artificial Life
LIB_DEPENDS= libfreetype.so:print/freetype2
-USES= autoreconf gl libtool ncurses pkgconfig sdl tar:bzip2
+USES= autoreconf gl libtool localbase:ldflags ncurses pkgconfig sdl tar:bzip2
GNU_CONFIGURE= yes
USE_SDL= sdl
USE_GL= gl
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2
-LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-system-ftgl
USE_GCC= yes
@@ -24,6 +22,8 @@ PORTDOCS= README AUTHORS Changelog
OPTIONS_DEFINE= DOCS
+BINARY_ALIAS= freetype-config=true
+
post-patch:
@${REINPLACE_CMD} -e 's|../share/critterding|${DATADIR}|' \
${WRKSRC}/src/gui/textprinter.cpp ${WRKSRC}/src/gl/glwindow.cpp
diff --git a/games/critterding/files/patch-configure.in b/games/critterding/files/patch-configure.in
new file mode 100644
index 000000000000..d987b10eea05
--- /dev/null
+++ b/games/critterding/files/patch-configure.in
@@ -0,0 +1,24 @@
+--- configure.in.orig 2010-02-19 13:26:47 UTC
++++ configure.in
+@@ -77,8 +77,8 @@ AC_SUBST(SDLMAIN)
+ AC_MSG_CHECKING(for Freetype)
+ AC_CHECK_PROG([FREETYPE_CONFIG],[freetype-config],yes,no)
+ if test "$FREETYPE_CONFIG" = yes; then
+- FT2_CFLAGS=`freetype-config --cflags`
+- FT2_LIBS=`freetype-config --libs`
++ FT2_CFLAGS=`pkg-config freetype2 --cflags`
++ FT2_LIBS=`pkg-config freetype2 --libs`
+ AC_MSG_RESULT($FT2_CFLAGS)
+ CPPFLAGS="$CPPFLAGS $FT2_CFLAGS"
+ HOST_LIBS="$HOST_LIBS $FT2_LIBS"
+@@ -94,8 +94,8 @@ AC_SUBST(SDLMAIN)
+ AC_MSG_CHECKING(for Freetype)
+ AC_CHECK_PROG([FREETYPE_CONFIG],[freetype-config],yes,no)
+ if test "$FREETYPE_CONFIG" = yes; then
+- FT2_CFLAGS=`freetype-config --cflags`
+- FT2_LIBS=`freetype-config --libs`
++ FT2_CFLAGS=`pkg-config freetype2 --cflags`
++ FT2_LIBS=`pkg-config freetype2 --libs`
+ AC_MSG_RESULT($FT2_CFLAGS)
+ CPPFLAGS="$CPPFLAGS $FT2_CFLAGS"
+ HOST_LIBS="$HOST_LIBS $FT2_LIBS"