aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2015-09-26 07:40:47 +0000
committerDon Lewis <truckman@FreeBSD.org>2015-09-26 07:40:47 +0000
commit19bbc1b1cd97a5c1fee89f9dcc4a860e83443fbf (patch)
treea174a56302213f75af8f982612d9906640b20104
parent506ed9efd6fed4c0af8f70b4cbbe8db9346a5e17 (diff)
downloadports-19bbc1b1cd97a5c1fee89f9dcc4a860e83443fbf.tar.gz
ports-19bbc1b1cd97a5c1fee89f9dcc4a860e83443fbf.zip
Add Caladea and Carlito fonts. They are metrically equivalent to some
Microsoft fonts and the proper definitions within OpenOffice have been added so that they are recognized as such. [1] The Linux ports handle the mapping from the printeradmin command to the spadmin executable in the shell wrapper. Do the same in the FreeBSD port rather than munging the printeradmin.desktop file. Retain the spadmin link to the wrapper for backwards compatability. The setofficelang command went away a long time ago. Remove it from the shell wrapper and remove the link. Exec the OpenOffice executables from the wrapper so that the shell for the wrapper doesn't hang around as an extra process until OpenOffice terminates. Nuke an extraneous shell continuation in the Makefile. Suggested by: pfg [1]
Notes
Notes: svn path=/head/; revision=397932
-rw-r--r--editors/openoffice-4/Makefile10
-rw-r--r--editors/openoffice-4/files/openoffice-wrapper9
-rw-r--r--editors/openoffice-4/files/patch-sysui_desktop_menus_printeradmin.desktop10
-rw-r--r--editors/openoffice-4/files/pkg-message.in5
-rw-r--r--editors/openoffice-devel/Makefile10
-rw-r--r--editors/openoffice-devel/files/openoffice-wrapper9
-rw-r--r--editors/openoffice-devel/files/patch-sysui_desktop_menus_printeradmin.desktop10
-rw-r--r--editors/openoffice-devel/files/pkg-message.in5
8 files changed, 24 insertions, 44 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index effd27fa780a..66cf1c1f8be5 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION}
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= editors java
MASTER_SITES= APACHE/openoffice/${PORTVERSION}/source \
http://tools.openoffice.org/unowinreg_prebuild/680/:unoreg \
@@ -91,6 +91,8 @@ RUN_DEPENDS= \
${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme \
${JAVALIBDIR}/commons-httpclient.jar:${PORTSDIR}/java/jakarta-commons-httpclient \
${JAVALIBDIR}/bsh.jar:${PORTSDIR}/lang/bsh \
+ ${LOCALBASE}/share/fonts/Caladea/Caladea-Bold.ttf:${PORTSDIR}/x11-fonts/crosextrafonts-caladea-ttf \
+ ${LOCALBASE}/share/fonts/Carlito/Carlito-Bold.ttf:${PORTSDIR}/x11-fonts/crosextrafonts-carlito-ttf \
${LOCALBASE}/share/fonts/ChromeOS/Arimo-Bold.ttf:${PORTSDIR}/x11-fonts/croscorefonts-fonts-ttf
AOOVERSION1= 4
@@ -402,7 +404,7 @@ do-install:
@cd ${STAGEDIR}${OOPATH}/program ; \
${ECHO_CMD} "stripping executables and shared libraries" ; \
${STRIP_CMD} crashrep pagein uri-encode javaldx regmerge \
- regview *.so* *.bin ; \
+ regview *.so* *.bin
${FIND} ${STAGEDIR}${PRINSTALLATION_BASEDIR} -type d -exec ${CHMOD} 755 {} \;
${REINPLACE_CMD} \
-e '/^UserInstallation/s/=.*/=$$SYSUSERCONFIG\/${AOOUDIR}/' \
@@ -415,8 +417,8 @@ do-install:
${WRKDIR}/openoffice-wrapper
${INSTALL_SCRIPT} ${WRKDIR}/openoffice-wrapper \
${STAGEDIR}${PREFIX}/bin/${EXECBASE}
- @cd ${STAGEDIR}${PREFIX}/bin; for i in sbase scalc sdraw \
- setofficelang simpress smath spadmin swriter ; do \
+ @cd ${STAGEDIR}${PREFIX}/bin; for i in printeradmin sbase scalc sdraw \
+ simpress smath spadmin swriter ; do \
${LN} -f ${EXECBASE} ${EXECBASE}-$${i} ; \
done
${LN} -sf ${XDGDIR} ${STAGEDIR}${DESKTOPDIR}/${EXECBASE}
diff --git a/editors/openoffice-4/files/openoffice-wrapper b/editors/openoffice-4/files/openoffice-wrapper
index 6af286a38b8d..271bca94f59b 100644
--- a/editors/openoffice-4/files/openoffice-wrapper
+++ b/editors/openoffice-4/files/openoffice-wrapper
@@ -2,17 +2,16 @@
#
# $FreeBSD$
-oopath=%%OOPATH%%
program=`echo $0 | sed -e 's|.*%%EXECBASE%%-||'`
case $program in
$0)
- $oopath/program/soffice "$@"
+ exec %%OOPATH%%/program/soffice "$@"
;;
-setofficelang)
- $oopath/basis-link/program/$program "$@"
+printeradmin)
+ exec %%OOPATH%%/program/spadmin
;;
*)
- $oopath/program/$program "$@"
+ exec %%OOPATH%%/program/$program "$@"
;;
esac
diff --git a/editors/openoffice-4/files/patch-sysui_desktop_menus_printeradmin.desktop b/editors/openoffice-4/files/patch-sysui_desktop_menus_printeradmin.desktop
deleted file mode 100644
index c73c2f827862..000000000000
--- a/editors/openoffice-4/files/patch-sysui_desktop_menus_printeradmin.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
---- sysui/desktop/menus/printeradmin.desktop.orig 2014-02-25 08:28:56 UTC
-+++ sysui/desktop/menus/printeradmin.desktop
-@@ -24,6 +24,6 @@ Terminal=false
- Icon=printeradmin
- Type=Application
- Categories=Office;X-Red-Hat-Base;X-SuSE-Core-Office;
--Exec=openoffice-printeradmin
-+Exec=openoffice-spadmin
- Name=%PRODUCTNAME Printer Administration
- StartupNotify=true
diff --git a/editors/openoffice-4/files/pkg-message.in b/editors/openoffice-4/files/pkg-message.in
index 467f53f96bef..4587a89bc49b 100644
--- a/editors/openoffice-4/files/pkg-message.in
+++ b/editors/openoffice-4/files/pkg-message.in
@@ -22,13 +22,12 @@ There are some wrappers installed for faster startup. Add "%%PREFIX%%/bin/"
to your PATH and you will be able to use them.
%%PREFIX%%/bin/%%EXECBASE%%
+%%PREFIX%%/bin/%%EXECBASE%%-printeradmin
%%PREFIX%%/bin/%%EXECBASE%%-sbase
%%PREFIX%%/bin/%%EXECBASE%%-scalc
%%PREFIX%%/bin/%%EXECBASE%%-sdraw
-%%PREFIX%%/bin/%%EXECBASE%%-setofficelang
-%%PREFIX%%/bin/%%EXECBASE%%-smath
%%PREFIX%%/bin/%%EXECBASE%%-simpress
-%%PREFIX%%/bin/%%EXECBASE%%-spadmin
+%%PREFIX%%/bin/%%EXECBASE%%-smath
%%PREFIX%%/bin/%%EXECBASE%%-swriter
OpenOffice does need $LANG to be set to a suitable value.
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index 310024376b9b..f4e5e535f0ea 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION1}.${AOOVERSION2}.${SVNREVISION}
-#PORTREVISION= 1
+PORTREVISION= 1
PORTEPOCH= 3
CATEGORIES= editors java
MASTER_SITES= http://ci.apache.org/projects/openoffice/milestones/${AOOVERSION}-${AOORC}-r${SVNREVISION}/source/ \
@@ -93,6 +93,8 @@ RUN_DEPENDS= \
${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme \
${JAVALIBDIR}/commons-httpclient.jar:${PORTSDIR}/java/jakarta-commons-httpclient \
${JAVALIBDIR}/bsh.jar:${PORTSDIR}/lang/bsh \
+ ${LOCALBASE}/share/fonts/Caladea/Caladea-Bold.ttf:${PORTSDIR}/x11-fonts/crosextrafonts-caladea-ttf \
+ ${LOCALBASE}/share/fonts/Carlito/Carlito-Bold.ttf:${PORTSDIR}/x11-fonts/crosextrafonts-carlito-ttf \
${LOCALBASE}/share/fonts/ChromeOS/Arimo-Bold.ttf:${PORTSDIR}/x11-fonts/croscorefonts-fonts-ttf
AOOVERSION1= 4
@@ -414,7 +416,7 @@ do-install:
@cd ${STAGEDIR}${OOPATH}/program ; \
${ECHO_CMD} "stripping executables and shared libraries" ; \
${STRIP_CMD} crashrep pagein uri-encode javaldx regmerge \
- regview *.so* *.bin ; \
+ regview *.so* *.bin
${FIND} ${STAGEDIR}${PRINSTALLATION_BASEDIR} -type d -exec ${CHMOD} 755 {} \;
${REINPLACE_CMD} \
-e '/^UserInstallation/s/=.*/=$$SYSUSERCONFIG\/${AOOUDIR}/' \
@@ -427,8 +429,8 @@ do-install:
${WRKDIR}/openoffice-wrapper
${INSTALL_SCRIPT} ${WRKDIR}/openoffice-wrapper \
${STAGEDIR}${PREFIX}/bin/${EXECBASE}
- @cd ${STAGEDIR}${PREFIX}/bin; for i in sbase scalc sdraw \
- setofficelang simpress smath spadmin swriter ; do \
+ @cd ${STAGEDIR}${PREFIX}/bin; for i in printeradmin sbase scalc sdraw \
+ simpress smath spadmin swriter ; do \
${LN} -f ${EXECBASE} ${EXECBASE}-$${i} ; \
done
${LN} -sf ${XDGDIR} ${STAGEDIR}${DESKTOPDIR}/${EXECBASE}
diff --git a/editors/openoffice-devel/files/openoffice-wrapper b/editors/openoffice-devel/files/openoffice-wrapper
index 6af286a38b8d..271bca94f59b 100644
--- a/editors/openoffice-devel/files/openoffice-wrapper
+++ b/editors/openoffice-devel/files/openoffice-wrapper
@@ -2,17 +2,16 @@
#
# $FreeBSD$
-oopath=%%OOPATH%%
program=`echo $0 | sed -e 's|.*%%EXECBASE%%-||'`
case $program in
$0)
- $oopath/program/soffice "$@"
+ exec %%OOPATH%%/program/soffice "$@"
;;
-setofficelang)
- $oopath/basis-link/program/$program "$@"
+printeradmin)
+ exec %%OOPATH%%/program/spadmin
;;
*)
- $oopath/program/$program "$@"
+ exec %%OOPATH%%/program/$program "$@"
;;
esac
diff --git a/editors/openoffice-devel/files/patch-sysui_desktop_menus_printeradmin.desktop b/editors/openoffice-devel/files/patch-sysui_desktop_menus_printeradmin.desktop
deleted file mode 100644
index 7333737556a9..000000000000
--- a/editors/openoffice-devel/files/patch-sysui_desktop_menus_printeradmin.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
---- sysui/desktop/menus/printeradmin.desktop.orig 2014-09-19 18:25:03 UTC
-+++ sysui/desktop/menus/printeradmin.desktop
-@@ -24,6 +24,6 @@ Terminal=false
- Icon=printeradmin
- Type=Application
- Categories=Office;X-Red-Hat-Base;X-SuSE-Core-Office;
--Exec=openoffice-printeradmin
-+Exec=openoffice-spadmin
- Name=%PRODUCTNAME Printer Administration
- StartupNotify=true
diff --git a/editors/openoffice-devel/files/pkg-message.in b/editors/openoffice-devel/files/pkg-message.in
index 467f53f96bef..4587a89bc49b 100644
--- a/editors/openoffice-devel/files/pkg-message.in
+++ b/editors/openoffice-devel/files/pkg-message.in
@@ -22,13 +22,12 @@ There are some wrappers installed for faster startup. Add "%%PREFIX%%/bin/"
to your PATH and you will be able to use them.
%%PREFIX%%/bin/%%EXECBASE%%
+%%PREFIX%%/bin/%%EXECBASE%%-printeradmin
%%PREFIX%%/bin/%%EXECBASE%%-sbase
%%PREFIX%%/bin/%%EXECBASE%%-scalc
%%PREFIX%%/bin/%%EXECBASE%%-sdraw
-%%PREFIX%%/bin/%%EXECBASE%%-setofficelang
-%%PREFIX%%/bin/%%EXECBASE%%-smath
%%PREFIX%%/bin/%%EXECBASE%%-simpress
-%%PREFIX%%/bin/%%EXECBASE%%-spadmin
+%%PREFIX%%/bin/%%EXECBASE%%-smath
%%PREFIX%%/bin/%%EXECBASE%%-swriter
OpenOffice does need $LANG to be set to a suitable value.