aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2022-12-31 08:35:49 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2022-12-31 08:43:56 +0000
commit19e238d38d9e0ab966e6297264214055e47c7253 (patch)
tree3fdedb77e9e49d0b5ba02a3f2ae3b277d43e320e
parentc04cdbfcaf3adfa37be80b07e79dbceb1bf6fecd (diff)
downloadports-19e238d38d9e0ab966e6297264214055e47c7253.tar.gz
ports-19e238d38d9e0ab966e6297264214055e47c7253.zip
misc/qt6-doc: actually build and install the docs
-rw-r--r--misc/qt6-doc/Makefile5
-rw-r--r--misc/qt6-doc/pkg-plist463
2 files changed, 466 insertions, 2 deletions
diff --git a/misc/qt6-doc/Makefile b/misc/qt6-doc/Makefile
index 1c699181a116..5f908688d8c7 100644
--- a/misc/qt6-doc/Makefile
+++ b/misc/qt6-doc/Makefile
@@ -1,5 +1,6 @@
PORTNAME= doc
DISTVERSION= ${QT6_VERSION}
+PORTREVISION= 1
CATEGORIES= misc
PKGNAMEPREFIX= qt6-
@@ -12,6 +13,8 @@ BUILD_DEPENDS= ${LOCALBASE}/include/vulkan/vulkan.h:graphics/vulkan-headers
USES= cmake compiler:c++17-lang \
qt-dist:6
USE_QT= base declarative tools
-#USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+
+ALL_TARGET= docs
+INSTALL_TARGET= install_docs
.include <bsd.port.mk>
diff --git a/misc/qt6-doc/pkg-plist b/misc/qt6-doc/pkg-plist
index 078b625cb33e..f1698ab90619 100644
--- a/misc/qt6-doc/pkg-plist
+++ b/misc/qt6-doc/pkg-plist
@@ -1 +1,462 @@
-%%QT_MKSPECDIR%%/qtdoc_dummy_file.txt
+%%QT_DOCDIR%%/qtcmake.qch
+%%QT_DOCDIR%%/qtcmake/cmake-build-on-cmdline.html
+%%QT_DOCDIR%%/qtcmake/cmake-build-qml-application.html
+%%QT_DOCDIR%%/qtcmake/cmake-build-reusable-qml-module.html
+%%QT_DOCDIR%%/qtcmake/cmake-command-reference.html
+%%QT_DOCDIR%%/qtcmake/cmake-get-started.html
+%%QT_DOCDIR%%/qtcmake/cmake-imported-targets.html
+%%QT_DOCDIR%%/qtcmake/cmake-manual.html
+%%QT_DOCDIR%%/qtcmake/cmake-property-reference.html
+%%QT_DOCDIR%%/qtcmake/cmake-qt5-and-qt6-compatibility.html
+%%QT_DOCDIR%%/qtcmake/cmake-variable-reference.html
+%%QT_DOCDIR%%/qtcmake/images/arrow_bc.png
+%%QT_DOCDIR%%/qtcmake/images/bgrContent.png
+%%QT_DOCDIR%%/qtcmake/images/btn_next.png
+%%QT_DOCDIR%%/qtcmake/images/btn_prev.png
+%%QT_DOCDIR%%/qtcmake/images/bullet_dn.png
+%%QT_DOCDIR%%/qtcmake/images/bullet_sq.png
+%%QT_DOCDIR%%/qtcmake/images/home.png
+%%QT_DOCDIR%%/qtcmake/images/ico_note.png
+%%QT_DOCDIR%%/qtcmake/images/ico_note_attention.png
+%%QT_DOCDIR%%/qtcmake/images/ico_out.png
+%%QT_DOCDIR%%/qtcmake/images/logo.png
+%%QT_DOCDIR%%/qtcmake/qtcmake.index
+%%QT_DOCDIR%%/qtcmake/qtcmake.qhp
+%%QT_DOCDIR%%/qtcmake/qtcmake.qhp.sha1
+%%QT_DOCDIR%%/qtcmake/style/offline-simple.css
+%%QT_DOCDIR%%/qtcmake/style/offline.css
+%%QT_DOCDIR%%/qtdoc.qch
+%%QT_DOCDIR%%/qtdoc/accelerators.html
+%%QT_DOCDIR%%/qtdoc/accessibility.html
+%%QT_DOCDIR%%/qtdoc/accessible-qtquick.html
+%%QT_DOCDIR%%/qtdoc/accessible-qwidget.html
+%%QT_DOCDIR%%/qtdoc/accessible.html
+%%QT_DOCDIR%%/qtdoc/activeqt-idc.html
+%%QT_DOCDIR%%/qtdoc/activeqt-testcon.html
+%%QT_DOCDIR%%/qtdoc/all-examples.html
+%%QT_DOCDIR%%/qtdoc/android-3rdparty-libs.html
+%%QT_DOCDIR%%/qtdoc/android-building-user-projects.html
+%%QT_DOCDIR%%/qtdoc/android-building.html
+%%QT_DOCDIR%%/qtdoc/android-emojis.html
+%%QT_DOCDIR%%/qtdoc/android-getting-started.html
+%%QT_DOCDIR%%/qtdoc/android-manifest-file-configuration.html
+%%QT_DOCDIR%%/qtdoc/android-openssl-support.html
+%%QT_DOCDIR%%/qtdoc/android-platform-notes.html
+%%QT_DOCDIR%%/qtdoc/android-publishing-to-googleplay.html
+%%QT_DOCDIR%%/qtdoc/android-runtime-licensing-notes.html
+%%QT_DOCDIR%%/qtdoc/android-services.html
+%%QT_DOCDIR%%/qtdoc/android.html
+%%QT_DOCDIR%%/qtdoc/annotated.html
+%%QT_DOCDIR%%/qtdoc/appicon.html
+%%QT_DOCDIR%%/qtdoc/best-practices.html
+%%QT_DOCDIR%%/qtdoc/bughowto.html
+%%QT_DOCDIR%%/qtdoc/build-sources.html
+%%QT_DOCDIR%%/qtdoc/building-qt-for-qnx.html
+%%QT_DOCDIR%%/qtdoc/classes.html
+%%QT_DOCDIR%%/qtdoc/classesandfunctions.html
+%%QT_DOCDIR%%/qtdoc/configure-linux-device.html
+%%QT_DOCDIR%%/qtdoc/configure-options.html
+%%QT_DOCDIR%%/qtdoc/create-your-first-applications.html
+%%QT_DOCDIR%%/qtdoc/debug.html
+%%QT_DOCDIR%%/qtdoc/demos-manifest.xml
+%%QT_DOCDIR%%/qtdoc/deployment-android.html
+%%QT_DOCDIR%%/qtdoc/deployment-plugins.html
+%%QT_DOCDIR%%/qtdoc/deployment.html
+%%QT_DOCDIR%%/qtdoc/desktop-integration.html
+%%QT_DOCDIR%%/qtdoc/embedded-linux.html
+%%QT_DOCDIR%%/qtdoc/examples-android.html
+%%QT_DOCDIR%%/qtdoc/examples-animation.html
+%%QT_DOCDIR%%/qtdoc/examples-draganddrop.html
+%%QT_DOCDIR%%/qtdoc/examples-gestures.html
+%%QT_DOCDIR%%/qtdoc/examples-ios.html
+%%QT_DOCDIR%%/qtdoc/examples-ipc.html
+%%QT_DOCDIR%%/qtdoc/examples-layouts.html
+%%QT_DOCDIR%%/qtdoc/examples-license.html
+%%QT_DOCDIR%%/qtdoc/examples-manifest.xml
+%%QT_DOCDIR%%/qtdoc/examples-sql.html
+%%QT_DOCDIR%%/qtdoc/examples-threadandconcurrent.html
+%%QT_DOCDIR%%/qtdoc/examples-widgets-tools.html
+%%QT_DOCDIR%%/qtdoc/examples-xml.html
+%%QT_DOCDIR%%/qtdoc/exceptionsafety.html
+%%QT_DOCDIR%%/qtdoc/explore-qt.html
+%%QT_DOCDIR%%/qtdoc/extras-changes-qt6.html
+%%QT_DOCDIR%%/qtdoc/fdl.html
+%%QT_DOCDIR%%/qtdoc/functions.html
+%%QT_DOCDIR%%/qtdoc/get-and-install-qt.html
+%%QT_DOCDIR%%/qtdoc/gettingstarted.html
+%%QT_DOCDIR%%/qtdoc/gpl.html
+%%QT_DOCDIR%%/qtdoc/groups.html
+%%QT_DOCDIR%%/qtdoc/hierarchy.html
+%%QT_DOCDIR%%/qtdoc/highdpi.html
+%%QT_DOCDIR%%/qtdoc/i18n-plural-rules.html
+%%QT_DOCDIR%%/qtdoc/i18n-source-translation.html
+%%QT_DOCDIR%%/qtdoc/i18n.html
+%%QT_DOCDIR%%/qtdoc/images/5OiIqFTjUZI.jpg
+%%QT_DOCDIR%%/qtdoc/images/BenchmarkDemoQt6.png
+%%QT_DOCDIR%%/qtdoc/images/accessibleobjecttree.png
+%%QT_DOCDIR%%/qtdoc/images/addalarms.png
+%%QT_DOCDIR%%/qtdoc/images/addressbookclient.png
+%%QT_DOCDIR%%/qtdoc/images/alarms2.png
+%%QT_DOCDIR%%/qtdoc/images/alarms3.png
+%%QT_DOCDIR%%/qtdoc/images/android-single-abis.png
+%%QT_DOCDIR%%/qtdoc/images/android-source-folder.png
+%%QT_DOCDIR%%/qtdoc/images/animation-examples.png
+%%QT_DOCDIR%%/qtdoc/images/applicationwindow.png
+%%QT_DOCDIR%%/qtdoc/images/arrow_bc.png
+%%QT_DOCDIR%%/qtdoc/images/authorize.png
+%%QT_DOCDIR%%/qtdoc/images/bgrContent.png
+%%QT_DOCDIR%%/qtdoc/images/btn_next.png
+%%QT_DOCDIR%%/qtdoc/images/btn_prev.png
+%%QT_DOCDIR%%/qtdoc/images/bullet_dn.png
+%%QT_DOCDIR%%/qtdoc/images/bullet_sq.png
+%%QT_DOCDIR%%/qtdoc/images/coffee_machine_emptycup.png
+%%QT_DOCDIR%%/qtdoc/images/coffee_machine_modify.png
+%%QT_DOCDIR%%/qtdoc/images/coffee_machine_overview.png
+%%QT_DOCDIR%%/qtdoc/images/coffee_machine_selection.png
+%%QT_DOCDIR%%/qtdoc/images/deployment-mac-application.png
+%%QT_DOCDIR%%/qtdoc/images/deployment-mac-bundlestructure.png
+%%QT_DOCDIR%%/qtdoc/images/detailscreen.png
+%%QT_DOCDIR%%/qtdoc/images/dprgadget.png
+%%QT_DOCDIR%%/qtdoc/images/draganddrop-examples.png
+%%QT_DOCDIR%%/qtdoc/images/dynamic-loaded-pro.png
+%%QT_DOCDIR%%/qtdoc/images/dynamic-pro.png
+%%QT_DOCDIR%%/qtdoc/images/fastboot-mode.png
+%%QT_DOCDIR%%/qtdoc/images/front-coding.png
+%%QT_DOCDIR%%/qtdoc/images/front-ui.png
+%%QT_DOCDIR%%/qtdoc/images/home.png
+%%QT_DOCDIR%%/qtdoc/images/ico_note.png
+%%QT_DOCDIR%%/qtdoc/images/ico_note_attention.png
+%%QT_DOCDIR%%/qtdoc/images/ico_out.png
+%%QT_DOCDIR%%/qtdoc/images/icon_QtCreator_78x78px.png
+%%QT_DOCDIR%%/qtdoc/images/icon_Qt_78x78px.png
+%%QT_DOCDIR%%/qtdoc/images/icon_Tools.png
+%%QT_DOCDIR%%/qtdoc/images/integrity-os.png
+%%QT_DOCDIR%%/qtdoc/images/layout-examples.png
+%%QT_DOCDIR%%/qtdoc/images/logo.png
+%%QT_DOCDIR%%/qtdoc/images/mainscreen.png
+%%QT_DOCDIR%%/qtdoc/images/newcontact.png
+%%QT_DOCDIR%%/qtdoc/images/ok.png
+%%QT_DOCDIR%%/qtdoc/images/open-project.png
+%%QT_DOCDIR%%/qtdoc/images/piemenu.gif
+%%QT_DOCDIR%%/qtdoc/images/project-structure.png
+%%QT_DOCDIR%%/qtdoc/images/qml-application.png
+%%QT_DOCDIR%%/qtdoc/images/qml-extending-types.gif
+%%QT_DOCDIR%%/qtdoc/images/qml-uses-animation.png
+%%QT_DOCDIR%%/qtdoc/images/qml-uses-integratingjs.png
+%%QT_DOCDIR%%/qtdoc/images/qml-uses-layouts-anchors.png
+%%QT_DOCDIR%%/qtdoc/images/qml-uses-layouts-direct.png
+%%QT_DOCDIR%%/qtdoc/images/qml-uses-layouts-positioners.png
+%%QT_DOCDIR%%/qtdoc/images/qml-uses-text.png
+%%QT_DOCDIR%%/qtdoc/images/qml-uses-visual-opacity.png
+%%QT_DOCDIR%%/qtdoc/images/qml-uses-visual-rectangles.png
+%%QT_DOCDIR%%/qtdoc/images/qml-uses-visual-transforms.png
+%%QT_DOCDIR%%/qtdoc/images/qt-codesample.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-apply.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-browse-qbsp.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-contribute.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-creator-open.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-creator-welcome.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-custominstallation.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-design-studio-open.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-design-studio-welcome.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-download.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-install-design-studio.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-install-finish-design-studio.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-install-finish-qt.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-install-qt.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-install-xcode.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-license-agreement.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-login.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-maintenancetool.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-password.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-qbsp-download.png
+%%QT_DOCDIR%%/qtdoc/images/qt-edu-qbsp.png
+%%QT_DOCDIR%%/qtdoc/images/qt-embedded-fontfeatures.png
+%%QT_DOCDIR%%/qtdoc/images/qtcreator-clazy-checks-for-porting-to-qt6.png
+%%QT_DOCDIR%%/qtdoc/images/qtcreator-create-templates.png
+%%QT_DOCDIR%%/qtdoc/images/qtcreator-qt-quick-editors.png
+%%QT_DOCDIR%%/qtdoc/images/qtdesigner.png
+%%QT_DOCDIR%%/qtdoc/images/qtdesignstudio-examples.png
+%%QT_DOCDIR%%/qtdoc/images/qtdesignstudio.png
+%%QT_DOCDIR%%/qtdoc/images/qthangman-example.png
+%%QT_DOCDIR%%/qtdoc/images/qthangman-store-example.png
+%%QT_DOCDIR%%/qtdoc/images/qtinstallercomponents.png
+%%QT_DOCDIR%%/qtdoc/images/qtquick-demo-calqlatr.png
+%%QT_DOCDIR%%/qtdoc/images/qtquick-demo-clocks-small.png
+%%QT_DOCDIR%%/qtdoc/images/qtquick-demo-photosurface-small.png
+%%QT_DOCDIR%%/qtdoc/images/qtquick-demo-photoviewer-small.png
+%%QT_DOCDIR%%/qtdoc/images/qtquick-demo-rssnews-small.png
+%%QT_DOCDIR%%/qtdoc/images/qtquick-demo-stocqt.png
+%%QT_DOCDIR%%/qtdoc/images/qtquick3D.png
+%%QT_DOCDIR%%/qtdoc/images/rhiarch.png
+%%QT_DOCDIR%%/qtdoc/images/sa8155-target.png
+%%QT_DOCDIR%%/qtdoc/images/sa8155p.png
+%%QT_DOCDIR%%/qtdoc/images/scalability-gridlayout.png
+%%QT_DOCDIR%%/qtdoc/images/session.png
+%%QT_DOCDIR%%/qtdoc/images/sql-examples.png
+%%QT_DOCDIR%%/qtdoc/images/thread-examples.png
+%%QT_DOCDIR%%/qtdoc/images/threadsandobjects.png
+%%QT_DOCDIR%%/qtdoc/images/threadvisual-example.png
+%%QT_DOCDIR%%/qtdoc/images/tool-examples.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/calqlatr/content/images/paper-edge-left.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/calqlatr/content/images/paper-edge-right.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/calqlatr/content/images/paper-grip.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/clocks/content/arrow.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/clocks/content/background.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/clocks/content/center.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/clocks/content/clock-night.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/clocks/content/clock.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/clocks/content/hour.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/clocks/content/minute.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/clocks/content/quit.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/clocks/content/second.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/coffee/images/cup structure/coffee_cup_large.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/coffee/images/cup structure/coffee_cup_outline.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/coffee/images/cup structure/cup elements/coffee_cup_back.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/coffee/images/cup structure/cup elements/coffee_cup_coverplate.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/coffee/images/cup structure/cup elements/coffee_cup_front.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/coffee/images/cup structure/liquids/liquid_coffee.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/coffee/images/cup structure/liquids/liquid_foam.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/coffee/images/cup structure/liquids/liquid_milk.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/coffee/images/icons/coffees/Americano.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/coffee/images/icons/coffees/Espresso.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/coffee/images/icons/coffees/Latte.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/coffee/images/icons/coffees/Macchiato.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/coffee/images/icons/coffees/cappucino.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/coffee/images/icons/contents/coffee.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/coffee/images/icons/contents/milk.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/coffee/images/icons/contents/sugar.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/coffee/images/ui controls/buttons/back/white.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/coffee/images/ui controls/buttons/go/white.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/coffee/images/ui controls/line.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/photosurface/resources/folder.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/photosurface/resources/icon.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/photoviewer/PhotoViewerCore/images/box-shadow.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/photoviewer/PhotoViewerCore/images/busy.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/photoviewer/PhotoViewerCore/images/cardboard.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/rssnews/content/images/Asia.jpg
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/rssnews/content/images/Business.jpg
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/rssnews/content/images/Entertainment.jpg
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/rssnews/content/images/Europe.jpg
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/rssnews/content/images/Health.jpg
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/rssnews/content/images/Politics.jpg
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/rssnews/content/images/Science.jpg
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/rssnews/content/images/Sports.jpg
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/rssnews/content/images/Technology.jpg
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/rssnews/content/images/TopStories.jpg
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/rssnews/content/images/USNational.jpg
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/rssnews/content/images/World.jpg
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/rssnews/content/images/btn_close.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/rssnews/content/images/busy.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/rssnews/content/images/scrollbar.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/stocqt/content/images/icon-left-arrow.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/stocqt/content/images/wheel-touch.png
+%%QT_DOCDIR%%/qtdoc/images/used-in-examples/demos/stocqt/content/images/wheel.png
+%%QT_DOCDIR%%/qtdoc/images/wayland-multi-process.png
+%%QT_DOCDIR%%/qtdoc/images/wayland-single-process-develop.png
+%%QT_DOCDIR%%/qtdoc/images/wayland-single-process-eglfs.png
+%%QT_DOCDIR%%/qtdoc/images/wiring1.png
+%%QT_DOCDIR%%/qtdoc/images/wiring2.png
+%%QT_DOCDIR%%/qtdoc/images/xml-examples.png
+%%QT_DOCDIR%%/qtdoc/images/yIv0vO8B7tQ.jpg
+%%QT_DOCDIR%%/qtdoc/index.html
+%%QT_DOCDIR%%/qtdoc/inputs-linux-device.html
+%%QT_DOCDIR%%/qtdoc/install-qt-design-studio.html
+%%QT_DOCDIR%%/qtdoc/integrity-building-and-flashing-dd-project.html
+%%QT_DOCDIR%%/qtdoc/integrity-building-monolith.html
+%%QT_DOCDIR%%/qtdoc/integrity-building-qt-8155p-on-ubuntu.html
+%%QT_DOCDIR%%/qtdoc/integrity-building-qt-8155p-on-windows.html
+%%QT_DOCDIR%%/qtdoc/integrity-flash-image-and-run.html
+%%QT_DOCDIR%%/qtdoc/integrity-installing-dependencies.html
+%%QT_DOCDIR%%/qtdoc/integrity-linux-monolith.html
+%%QT_DOCDIR%%/qtdoc/integrity-monolith-project-tutorial.html
+%%QT_DOCDIR%%/qtdoc/integrity-win-monolith.html
+%%QT_DOCDIR%%/qtdoc/integrity.html
+%%QT_DOCDIR%%/qtdoc/internationalization.html
+%%QT_DOCDIR%%/qtdoc/ios-building-from-source.html
+%%QT_DOCDIR%%/qtdoc/ios-platform-notes.html
+%%QT_DOCDIR%%/qtdoc/ios.html
+%%QT_DOCDIR%%/qtdoc/ipc.html
+%%QT_DOCDIR%%/qtdoc/known-issues.html
+%%QT_DOCDIR%%/qtdoc/lgpl.html
+%%QT_DOCDIR%%/qtdoc/license-changes.html
+%%QT_DOCDIR%%/qtdoc/licenses-used-in-qt.html
+%%QT_DOCDIR%%/qtdoc/licensing.html
+%%QT_DOCDIR%%/qtdoc/linux-building.html
+%%QT_DOCDIR%%/qtdoc/linux-deployment.html
+%%QT_DOCDIR%%/qtdoc/linux-issues.html
+%%QT_DOCDIR%%/qtdoc/linux-requirements.html
+%%QT_DOCDIR%%/qtdoc/linux.html
+%%QT_DOCDIR%%/qtdoc/macos-building.html
+%%QT_DOCDIR%%/qtdoc/macos-deployment.html
+%%QT_DOCDIR%%/qtdoc/macos-issues.html
+%%QT_DOCDIR%%/qtdoc/macos.html
+%%QT_DOCDIR%%/qtdoc/mobiledevelopment.html
+%%QT_DOCDIR%%/qtdoc/moc.html
+%%QT_DOCDIR%%/qtdoc/modulechanges.html
+%%QT_DOCDIR%%/qtdoc/modules-cpp.html
+%%QT_DOCDIR%%/qtdoc/modules-qml.html
+%%QT_DOCDIR%%/qtdoc/modules.html
+%%QT_DOCDIR%%/qtdoc/namespaces.html
+%%QT_DOCDIR%%/qtdoc/newclasses60.html
+%%QT_DOCDIR%%/qtdoc/newclasses61.html
+%%QT_DOCDIR%%/qtdoc/newclasses62.html
+%%QT_DOCDIR%%/qtdoc/newclasses63.html
+%%QT_DOCDIR%%/qtdoc/newclasses64.html
+%%QT_DOCDIR%%/qtdoc/obsoleteclasses.html
+%%QT_DOCDIR%%/qtdoc/obsoleteqmltypes.html
+%%QT_DOCDIR%%/qtdoc/overviews-main.html
+%%QT_DOCDIR%%/qtdoc/overviews.html
+%%QT_DOCDIR%%/qtdoc/packaging-recommendations.html
+%%QT_DOCDIR%%/qtdoc/plugins-howto.html
+%%QT_DOCDIR%%/qtdoc/porting-to-android.html
+%%QT_DOCDIR%%/qtdoc/porting-to-ios.html
+%%QT_DOCDIR%%/qtdoc/porting-to-qt6-using-clazy.html
+%%QT_DOCDIR%%/qtdoc/portingguide.html
+%%QT_DOCDIR%%/qtdoc/qml-codingconventions.html
+%%QT_DOCDIR%%/qtdoc/qml-glossary.html
+%%QT_DOCDIR%%/qtdoc/qmlapplications.html
+%%QT_DOCDIR%%/qtdoc/qmlfirststeps.html
+%%QT_DOCDIR%%/qtdoc/qmltypes.html
+%%QT_DOCDIR%%/qtdoc/qmlvaluetypes.html
+%%QT_DOCDIR%%/qtdoc/qnx-support.html
+%%QT_DOCDIR%%/qtdoc/qnx-target-requirements.html
+%%QT_DOCDIR%%/qtdoc/qnx.html
+%%QT_DOCDIR%%/qtdoc/qt-activex.html
+%%QT_DOCDIR%%/qtdoc/qt-attribution-cmake-macros.html
+%%QT_DOCDIR%%/qtdoc/qt-attribution-llvm.html
+%%QT_DOCDIR%%/qtdoc/qt-attribution-llvmpipe.html
+%%QT_DOCDIR%%/qtdoc/qt-conf.html
+%%QT_DOCDIR%%/qtdoc/qt-edu-for-designers.html
+%%QT_DOCDIR%%/qtdoc/qt-edu-for-developers.html
+%%QT_DOCDIR%%/qtdoc/qt-edu-raspberry-pi.html
+%%QT_DOCDIR%%/qtdoc/qt-edu-resources.html
+%%QT_DOCDIR%%/qtdoc/qt-embedded-fonts.html
+%%QT_DOCDIR%%/qtdoc/qt-embedded-kmap2qmap.html
+%%QT_DOCDIR%%/qtdoc/qt-embedded-makeqpf.html
+%%QT_DOCDIR%%/qtdoc/qt-for-education.html
+%%QT_DOCDIR%%/qtdoc/qt-gui-concepts.html
+%%QT_DOCDIR%%/qtdoc/qt-intro.html
+%%QT_DOCDIR%%/qtdoc/qt6-buildsystem.html
+%%QT_DOCDIR%%/qtdoc/qtconcurrent-mtexamples.html
+%%QT_DOCDIR%%/qtdoc/qtconcurrentexamples.html
+%%QT_DOCDIR%%/qtdoc/qtdoc-attribution-coffeeexample-titillium.html
+%%QT_DOCDIR%%/qtdoc/qtdoc-demos-addressbook-example.html
+%%QT_DOCDIR%%/qtdoc/qtdoc-demos-calqlatr-example.html
+%%QT_DOCDIR%%/qtdoc/qtdoc-demos-clocks-example.html
+%%QT_DOCDIR%%/qtdoc/qtdoc-demos-coffee-example.html
+%%QT_DOCDIR%%/qtdoc/qtdoc-demos-hangman-cmakelists-txt.html
+%%QT_DOCDIR%%/qtdoc/qtdoc-demos-hangman-example.html
+%%QT_DOCDIR%%/qtdoc/qtdoc-demos-hangman-hangman-pro.html
+%%QT_DOCDIR%%/qtdoc/qtdoc-demos-hangman-purchasing-android-src-org-qtproject-qt-android-purchasing-base64-java.html
+%%QT_DOCDIR%%/qtdoc/qtdoc-demos-hangman-purchasing-android-src-org-qtproject-qt-android-purchasing-base64decoderexception-java.html
+%%QT_DOCDIR%%/qtdoc/qtdoc-demos-hangman-purchasing-android-src-org-qtproject-qt-android-purchasing-inapppurchase-java.html
+%%QT_DOCDIR%%/qtdoc/qtdoc-demos-hangman-purchasing-android-src-org-qtproject-qt-android-purchasing-security-java.html
+%%QT_DOCDIR%%/qtdoc/qtdoc-demos-hangman-resources-qrc.html
+%%QT_DOCDIR%%/qtdoc/qtdoc-demos-photosurface-example.html
+%%QT_DOCDIR%%/qtdoc/qtdoc-demos-photoviewer-example.html
+%%QT_DOCDIR%%/qtdoc/qtdoc-demos-rssnews-example.html
+%%QT_DOCDIR%%/qtdoc/qtdoc-demos-stocqt-example.html
+%%QT_DOCDIR%%/qtdoc/qtdoc-tutorials-alarms-example.html
+%%QT_DOCDIR%%/qtdoc/qtdoc.index
+%%QT_DOCDIR%%/qtdoc/qtdoc.qhp
+%%QT_DOCDIR%%/qtdoc/qtdoc.qhp.sha1
+%%QT_DOCDIR%%/qtdoc/qtentrypoint.html
+%%QT_DOCDIR%%/qtdoc/qtexamples.html
+%%QT_DOCDIR%%/qtdoc/qtexamplesandtutorials.html
+%%QT_DOCDIR%%/qtdoc/qtmodules.html
+%%QT_DOCDIR%%/qtdoc/qtpurchasing-androidclasses.html
+%%QT_DOCDIR%%/qtdoc/qtpurchasing-appstore.html
+%%QT_DOCDIR%%/qtdoc/qtpurchasing-baseclasses.html
+%%QT_DOCDIR%%/qtdoc/qtpurchasing-googleplay.html
+%%QT_DOCDIR%%/qtdoc/qtpurchasing-iosclasses.html
+%%QT_DOCDIR%%/qtdoc/qtquick-debugging.html
+%%QT_DOCDIR%%/qtdoc/qtquick-deployment.html
+%%QT_DOCDIR%%/qtdoc/qtquick-internationalization.html
+%%QT_DOCDIR%%/qtdoc/qtquick-performance.html
+%%QT_DOCDIR%%/qtdoc/qtquick-qml-runtime.html
+%%QT_DOCDIR%%/qtdoc/qtquick-usecase-animations.html
+%%QT_DOCDIR%%/qtdoc/qtquick-usecase-integratingjs.html
+%%QT_DOCDIR%%/qtdoc/qtquick-usecase-layouts.html
+%%QT_DOCDIR%%/qtdoc/qtquick-usecase-styling.html
+%%QT_DOCDIR%%/qtdoc/qtquick-usecase-text.html
+%%QT_DOCDIR%%/qtdoc/qtquick-usecase-userinput.html
+%%QT_DOCDIR%%/qtdoc/qtquick-usecase-visual.html
+%%QT_DOCDIR%%/qtdoc/qundo.html
+%%QT_DOCDIR%%/qtdoc/rcc.html
+%%QT_DOCDIR%%/qtdoc/reference-overview.html
+%%QT_DOCDIR%%/qtdoc/restoring-geometry.html
+%%QT_DOCDIR%%/qtdoc/scalability.html
+%%QT_DOCDIR%%/qtdoc/session.html
+%%QT_DOCDIR%%/qtdoc/sharedlibrary.html
+%%QT_DOCDIR%%/qtdoc/signalsandslots-syntaxes.html
+%%QT_DOCDIR%%/qtdoc/solutions-for-application-development.html
+%%QT_DOCDIR%%/qtdoc/solutions-for-ui-design.html
+%%QT_DOCDIR%%/qtdoc/sql-examples.html
+%%QT_DOCDIR%%/qtdoc/string-processing.html
+%%QT_DOCDIR%%/qtdoc/style/offline-simple.css
+%%QT_DOCDIR%%/qtdoc/style/offline.css
+%%QT_DOCDIR%%/qtdoc/style/qt5-sidebar.html
+%%QT_DOCDIR%%/qtdoc/supported-platforms.html
+%%QT_DOCDIR%%/qtdoc/testing-and-debugging.html
+%%QT_DOCDIR%%/qtdoc/third-party-libraries.html
+%%QT_DOCDIR%%/qtdoc/thread-basics.html
+%%QT_DOCDIR%%/qtdoc/thread.html
+%%QT_DOCDIR%%/qtdoc/threads-modules.html
+%%QT_DOCDIR%%/qtdoc/threads-qobject.html
+%%QT_DOCDIR%%/qtdoc/threads-reentrancy.html
+%%QT_DOCDIR%%/qtdoc/threads-synchronizing.html
+%%QT_DOCDIR%%/qtdoc/threads-technologies.html
+%%QT_DOCDIR%%/qtdoc/threads.html
+%%QT_DOCDIR%%/qtdoc/tools-for-qt-quick-uis.html
+%%QT_DOCDIR%%/qtdoc/tools-for-qt-widget-based-uis.html
+%%QT_DOCDIR%%/qtdoc/topics-app-development.html
+%%QT_DOCDIR%%/qtdoc/topics-core.html
+%%QT_DOCDIR%%/qtdoc/topics-data-storage.html
+%%QT_DOCDIR%%/qtdoc/topics-graphics.html
+%%QT_DOCDIR%%/qtdoc/topics-network-connectivity.html
+%%QT_DOCDIR%%/qtdoc/topics-scripting.html
+%%QT_DOCDIR%%/qtdoc/topics-ui.html
+%%QT_DOCDIR%%/qtdoc/touchinputexamples.html
+%%QT_DOCDIR%%/qtdoc/trademarks.html
+%%QT_DOCDIR%%/qtdoc/uic.html
+%%QT_DOCDIR%%/qtdoc/unicode.html
+%%QT_DOCDIR%%/qtdoc/unix-signals.html
+%%QT_DOCDIR%%/qtdoc/wasm.html
+%%QT_DOCDIR%%/qtdoc/wayland-and-qt.html
+%%QT_DOCDIR%%/qtdoc/webos.html
+%%QT_DOCDIR%%/qtdoc/whatsnew60.html
+%%QT_DOCDIR%%/qtdoc/whatsnew61.html
+%%QT_DOCDIR%%/qtdoc/whatsnew62.html
+%%QT_DOCDIR%%/qtdoc/whatsnew63.html
+%%QT_DOCDIR%%/qtdoc/whatsnew64.html
+%%QT_DOCDIR%%/qtdoc/whatsnewqt6.html
+%%QT_DOCDIR%%/qtdoc/why-moc.html
+%%QT_DOCDIR%%/qtdoc/windows-building.html
+%%QT_DOCDIR%%/qtdoc/windows-deployment.html
+%%QT_DOCDIR%%/qtdoc/windows-graphics.html
+%%QT_DOCDIR%%/qtdoc/windows-issues.html
+%%QT_DOCDIR%%/qtdoc/windows.html
+%%QT_DOCDIR%%/qtdoc/xml-examples.html
+%%QT_DOCDIR%%/qtplatformintegration.qch
+%%QT_DOCDIR%%/qtplatformintegration/images/arrow_bc.png
+%%QT_DOCDIR%%/qtplatformintegration/images/bgrContent.png
+%%QT_DOCDIR%%/qtplatformintegration/images/btn_next.png
+%%QT_DOCDIR%%/qtplatformintegration/images/btn_prev.png
+%%QT_DOCDIR%%/qtplatformintegration/images/bullet_dn.png
+%%QT_DOCDIR%%/qtplatformintegration/images/bullet_sq.png
+%%QT_DOCDIR%%/qtplatformintegration/images/home.png
+%%QT_DOCDIR%%/qtplatformintegration/images/ico_note.png
+%%QT_DOCDIR%%/qtplatformintegration/images/ico_note_attention.png
+%%QT_DOCDIR%%/qtplatformintegration/images/ico_out.png
+%%QT_DOCDIR%%/qtplatformintegration/images/logo.png
+%%QT_DOCDIR%%/qtplatformintegration/native-interfaces.html
+%%QT_DOCDIR%%/qtplatformintegration/platform-integration.html
+%%QT_DOCDIR%%/qtplatformintegration/platform-type-conversions.html
+%%QT_DOCDIR%%/qtplatformintegration/qnativeinterface.html
+%%QT_DOCDIR%%/qtplatformintegration/qpa.html
+%%QT_DOCDIR%%/qtplatformintegration/qtplatformintegration.index
+%%QT_DOCDIR%%/qtplatformintegration/qtplatformintegration.qhp
+%%QT_DOCDIR%%/qtplatformintegration/qtplatformintegration.qhp.sha1
+%%QT_DOCDIR%%/qtplatformintegration/style/offline-simple.css
+%%QT_DOCDIR%%/qtplatformintegration/style/offline.css