aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-20 10:20:58 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-20 10:22:39 +0000
commit1a2d16db0e015aee879bfb6596286f01dde9bcaa (patch)
treea121c2dde45079f3538e70bb9dfe0f04d3fb463d
parentaa5b5ec42a067216fda26b5b92af57296ddf7121 (diff)
downloadports-1a2d16db0e015aee879bfb6596286f01dde9bcaa.tar.gz
ports-1a2d16db0e015aee879bfb6596286f01dde9bcaa.zip
editors/morla: Fix build with llvm16
- Add LICENSE GPLv2 - Fix missing DEPENDS - Utilize USES=localbase while I am here Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--editors/morla/Makefile39
1 files changed, 24 insertions, 15 deletions
diff --git a/editors/morla/Makefile b/editors/morla/Makefile
index d8e1d8db36e4..48c4123b59e2 100644
--- a/editors/morla/Makefile
+++ b/editors/morla/Makefile
@@ -1,6 +1,6 @@
PORTNAME= morla
PORTVERSION= 0.16.1
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= editors textproc
MASTER_SITES= http://www.morlardf.net/src/ \
http://nivi.interfree.it/distfiles/${PORTNAME}/${PORTVERSION}/
@@ -9,23 +9,26 @@ MAINTAINER= nivit@FreeBSD.org
COMMENT= RDF editor
WWW= http://www.morlardf.net/
-LIB_DEPENDS= libnxml.so:textproc/libnxml \
- librdf.so:textproc/redland \
- libraptor2.so:textproc/raptor2 \
- libcurl.so:ftp/curl
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= dot:graphics/graphviz
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libharfbuzz.so:print/harfbuzz \
+ libnxml.so:textproc/libnxml \
+ libraptor2.so:textproc/raptor2 \
+ librasqal.so:textproc/rasqal \
+ librdf.so:textproc/redland
RUN_DEPENDS= dot:graphics/graphviz
-OPTIONS_DEFINE= XULRUNNER
-XULRUNNER_DESC= Xulrunner as JavaScript engine
+USES= gettext gnome libtool localbase:ldflags pkgconfig
+USE_GNOME= cairo gdkpixbuf2 gtk20 libxslt
+USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-gconf=none --with-gtkhtml=none
-USES= gettext gnome libtool pkgconfig
-USE_GNOME= libxslt gtk20
-USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
DESKTOP_ENTRIES="morla" \
"Edit RDF documents" \
@@ -34,12 +37,18 @@ DESKTOP_ENTRIES="morla" \
"WebDevelopment;" \
true
+OPTIONS_DEFINE= XULRUNNER
+
+XULRUNNER_DESC= Xulrunner as JavaScript engine
+
XULRUNNER_BROKEN= www/libxul is gone, consider using lang/spidermonkey*
XULRUNNER_CONFIGURE_ON= --with-javascript=xulrunner
XULRUNNER_CONFIGURE_OFF= --with-javascript=none
-post-patch:
- @${REINPLACE_CMD} -e 's|-D.*_DISABLE_DEPRECATED||g' \
- ${WRKSRC}/configure
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
.include <bsd.port.mk>