aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-27 12:54:49 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-27 12:54:49 +0000
commit1a425451d2e3058259d8f3134932c4f287632c15 (patch)
tree5b4634e32f3aba81b84e71cf1a8036645ff9588a
parentfe13cf5adcd089603441b1627e77406f9c5264e7 (diff)
downloadports-1a425451d2e3058259d8f3134932c4f287632c15.tar.gz
ports-1a425451d2e3058259d8f3134932c4f287632c15.zip
security/cryptlib: enable on powerpc and powerpc64
-rw-r--r--security/cryptlib/Makefile2
-rw-r--r--security/cryptlib/files/patch-crypt_osconfig.h13
2 files changed, 14 insertions, 1 deletions
diff --git a/security/cryptlib/Makefile b/security/cryptlib/Makefile
index a0a5ce5059da..28484e46c006 100644
--- a/security/cryptlib/Makefile
+++ b/security/cryptlib/Makefile
@@ -9,7 +9,7 @@ DISTNAME= cl${PORTVERSION:S/.//g}
MAINTAINER= ale@FreeBSD.org
COMMENT= Powerful security programming toolkit
-ONLY_FOR_ARCHS= amd64 armv6 armv7 i386
+ONLY_FOR_ARCHS= amd64 armv6 armv7 i386 powerpc powerpc64
OPTIONS_DEFINE= DOCS
diff --git a/security/cryptlib/files/patch-crypt_osconfig.h b/security/cryptlib/files/patch-crypt_osconfig.h
new file mode 100644
index 000000000000..4737b39c8c61
--- /dev/null
+++ b/security/cryptlib/files/patch-crypt_osconfig.h
@@ -0,0 +1,13 @@
+--- crypt/osconfig.h.orig 2021-11-26 15:16:58 UTC
++++ crypt/osconfig.h
+@@ -147,6 +147,10 @@
+ #define L_ENDIAN
+ #else
+ #define B_ENDIAN
++ #ifdef __LP64__
++ #undef SIXTY_FOUR_BIT
++ #define SIXTY_FOUR_BIT_LONG
++ #endif
+ #endif /* Usually big-endian but may be little-endian */
+ #define BN_LLONG
+ #define DES_RISC1