aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2021-12-27 08:44:47 +0000
committerDima Panov <fluffy@FreeBSD.org>2021-12-27 08:46:29 +0000
commit1a478727103345f3a83dd14a19c3d6c212584849 (patch)
tree51b3c8d989c72f00b9b58a45d1d7d19ab494ff15
parente08d023ba5b63a604ec998e5e171e35380589477 (diff)
graphics/gimp-app: fixes gimptool to install plugins into the actual plugin-directory
PR: 240154 With hat: desktop Sponsored by: Netzkommune GmbH
-rw-r--r--graphics/gimp-app/Makefile2
-rw-r--r--graphics/gimp-app/files/patch-tools_gimptool.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/graphics/gimp-app/Makefile b/graphics/gimp-app/Makefile
index 045a7e588996..1f282c31d320 100644
--- a/graphics/gimp-app/Makefile
+++ b/graphics/gimp-app/Makefile
@@ -2,7 +2,7 @@
PORTNAME?= gimp
PORTVERSION= 2.10.28
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH?= 1
CATEGORIES?= graphics gnome
MASTER_SITES= GIMP/gimp/v${PORTVERSION:R}
diff --git a/graphics/gimp-app/files/patch-tools_gimptool.c b/graphics/gimp-app/files/patch-tools_gimptool.c
new file mode 100644
index 000000000000..06092bd9ee02
--- /dev/null
+++ b/graphics/gimp-app/files/patch-tools_gimptool.c
@@ -0,0 +1,13 @@
+--- tools/gimptool.c.orig 2021-09-14 15:53:10 UTC
++++ tools/gimptool.c
+@@ -748,9 +748,7 @@ get_sys_plugin_dir (gboolean forward_slashes)
+ g_free (rprefix);
+ #else
+ dir = g_build_path (forward_slashes ? "/" : G_DIR_SEPARATOR_S,
+- LIBDIR,
+- "gimp",
+- GIMP_PLUGIN_VERSION,
++ GIMPPLUGINDIR,
+ "plug-ins",
+ NULL);
+ #endif